[jaunty] OpenOffice.org Help Menu Inconsistencies

Bug #41694 reported by Richard Laager on 2006-04-27
16
Affects Status Importance Assigned to Milestone
openoffice.org (Ubuntu)
Low
Chris Cheney

Bug Description

The Help menu in OpenOffice.org doesn't match other apps.

The following changes are needed:
   OpenOffice.org Help -> Contents
* Get Help Online...
* Translate this application... -> Translate This Application
* Report a Bug... -> Report a Problem
* About OpenOffice.org -> About

* The ones with an asterisk need the proper icon.

I imagine the Launchpad ones are different because OpenOffice.org isn't using liblaunchpad-integration. There's probably a good reason it's not, but making the options consistent shouldn't have any downside.

Matthias Klose (doko) on 2006-04-27
Changed in openoffice.org:
status: Unconfirmed → Confirmed
Michael Broadbent (mikebro) wrote :

This is still an issue in Feisty.

Chris Cheney (ccheney) on 2007-10-22
Changed in openoffice.org:
importance: Low → Wishlist
Chris Cheney (ccheney) on 2007-11-16
Changed in openoffice.org:
milestone: none → hardy-alpha-1
Chris Cheney (ccheney) on 2007-12-06
Changed in openoffice.org:
milestone: hardy-alpha-1 → none
status: Confirmed → In Progress
Chris Cheney (ccheney) on 2008-03-30
Changed in openoffice.org:
importance: Wishlist → High
Chris Cheney (ccheney) on 2008-04-02
Changed in openoffice.org:
importance: High → Critical

Looks like I need to determine how to edit this file properly to add it:

helpcontent2/source/text/shared/main0108.xhp

Chris Cheney (ccheney) on 2008-04-05
Changed in openoffice.org:
importance: Critical → High
Chris Cheney (ccheney) on 2008-06-14
Changed in openoffice.org:
status: In Progress → Triaged

Please split this bug into three seperate bugs and mark this as a duplicate of one of them. Then each can be marked as it is fixed. The 'Help' icon in OOo 2.4 in Intrepid is currently the same as the desktop theme - so I think that one is fixed.

There's no need to split this bug. The fixes are small and logically related. I removed the one item that has been addressed and cleaned up the description.

description: updated
Chris Cheney (ccheney) on 2008-10-16
Changed in openoffice.org:
importance: High → Wishlist
Chris Cheney (ccheney) on 2008-11-01
Changed in openoffice.org:
assignee: nobody → ccheney
milestone: none → jaunty-alpha-1
Chris Cheney (ccheney) on 2008-12-01
Changed in openoffice.org:
milestone: jaunty-alpha-1 → jaunty-alpha-2
Chris Cheney (ccheney) on 2009-01-17
Changed in openoffice.org:
importance: Wishlist → Low
milestone: jaunty-alpha-2 → jaunty-alpha-4
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openoffice.org - 1:3.0.1-1ubuntu1

---------------
openoffice.org (1:3.0.1-1ubuntu1) jaunty; urgency=low

  * Resynchronise with Debian (r1395). Remaining changes:
    - Add Launchpad integration support.
    - Add Launchpad translations support.
    - Add package openoffice.org-style-human.
    - Add some Ubuntu-specific bitmaps. Adjust broffice diversions for these.
    - Add support for compressing debs with lzma.
    - Add support for shared /usr/share/doc directories.
    - Add support to build l10n as a separate source.
    - Add support to build on lpia.
    - Add support to turn off building on sparc.
    - Add Xb-Npp-xxx tags according to "firefox distro add-on suport" spec.
    - Set startcenter.desktop to not display in the menu.
    - Use imagemagick instead of graphicsmagick.
    - openoffice.org-help switch to internal copy of lucene.
    - Add Depends openoffice.org-math to openoffice.org-writer.
      Closes LP: #223476
    - Remove extra ooo-build changelog. Closes LP: #262579
    - boost1.35 transtition. Closes LP: #297152
    - Add & to ooo87965.execute.sh. Closes LP: #313495
    - OOo needs stlport on i386 for extension compatibility.
      Closes LP: #322188
    - calc needs depends on lp-solve since it links to it.
      Closes LP: #322189
  * Resynchronise with ooo-build-3-0-1 (r15230).
    - Update launchpad-integration menu entries. Closes LP: #41694
    - Add indentation to flat odt files. Closes LP: #226075
    - Change code from Err:529 to Err:519. Closes LP: #226457

 -- Chris Cheney <email address hidden> Thu, 29 Jan 2009 01:00:00 -0600

Changed in openoffice.org:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers