Wrong default paper size for printing

Bug #41147 reported by Brice Bourgoin on 2006-04-24
26
This bug affects 1 person
Affects Status Importance Assigned to Milestone
openoffice.org (Ubuntu)
Medium
Unassigned

Bug Description

My locale is french canadian. In cups-manager, default papersize is set to letter and it works for all applications I try (gedit, firefox, ...) except openoffice.org2. When I open a new document in Writer, Format>page>page>format is correctly is set to letter but File>print>properties>paper is set to a4. So I have to change it each time I want to print.

I try to edit /etc/papersize from a4 to letter, but it doesn't change anything.

Note: the original reporter indicated the bug was in package 'openoffice'; however, that package was not published in Ubuntu.

Brice Bourgoin (bbourgoi) wrote :

Fix by remove then readd my printer in cups-manager. Possible explanation : my dapper is a dist-upgrade from a Breezy, which is also a dist-upgrade from Hoary.

Brice, is the problem fixed?

Brice Bourgoin (bbourgoi) wrote :

Almost! Nervertheless it is a bug that we have to remove then readd a printer to make it works correctly. I think this bug appears just in case of dist-upgrade from breezy or hoary. So it is minor and if you want you can consider that fixed (depends on your requirements for Ubuntu distro upgrade).

If I understand correctly you had to remove and reinstall your printer in gnome-cups-manager.
Marked this bug as Minor, keeping it open in case somebody doing a dist-upgrade from Breezy to the final Dapper experiences the same problem.

stune62 (benoit-neuts) wrote :

i meet the same problem :
this is a fresh install of dapper
printer is a brother mfc7820n (network one) that i installed with brother debian packages

the default settings are sane in gnome printing panel : means A4 is selected as default

but when I want to print from OOo2, i don't even have the possibility to choose a4, the only choices I have are "letter, executive, a5, com-10, DL, b5" so when printing a job set as A4, the result is a bit confusing

any solutions are welcome

Till Kamppeter (till-kamppeter) wrote :

Everyone for whom the bug still occurs, please post

/etc/cups/ppd/*.ppd
/etc/cups/lpoptions
~/.lpoptions OR ~/.cups/lpoptions
/etc/papersize

BEFORE removing anf re-adding the print queue.

Changed in openoffice.org:
status: Unconfirmed → Needs Info
mikko (mikko-) wrote :

The old brother deb-packages include ppd files which are not correct. I'm not sure but the newer versions are maybe better. (If there are newer versions for all drivers..)

http://www.oooforum.org/forum/viewtopic.phtml?p=159601&highlight=incomplete+list+paper#159601

PostPosted: Wed Aug 09, 2006 2:56 pm Post subject: Reply with quote
Hello all (Brother users..)

meanwhile I have an answer from the Brother Hotline in Japan:

The ppd - File they provide in her Drivers is not complete(!). In case you get the problem described here, do the following:

1) edit the affected ppd-File in /etc/cups/ppd
2) go to section *PageSize: and add a "" at each *PageSize-Line
Example for my HL1430:
*OpenUI *PageSize: PickOne
*OrderDependency: 30 AnySetup *PageSize
*DefaultPageSize: A4
*PageSize Letter/Letter: ""
*PageSize Legal/Legal: ""
*PageSize Executive/Executive: ""
*PageSize A4/A4: ""
*PageSize A5/A5: ""
*PageSize A6/A6: ""
*PageSize Env10/Com-10: ""
*PageSize EnvMonarch/Monarch: ""
*PageSize EnvDL/DL: ""
*PageSize EnvC5/C5: ""
*PageSize EnvISOB5/B5: ""
*PageSize EnvISOB6/B6: ""
*CloseUI: *PageSize
3) save and restart cups
4) open OpenOffice Print Dialog - The Page-Format list should now complete

Good luck!
Georg

Till Kamppeter (till-kamppeter) wrote :

In general CUPS only accepts PPDs which pass "cupstestppd <ppd file>". If you get a "FAIL", CUPS will ignore the PPD and so apps with printer dialogs based on CUPS (as OpenOffice.org) will not show the options from the PPD.

This Brother PPD without "" should give a "FAIL". If not, "cupstestppd" has a bug.

Till Kamppeter (till-kamppeter) wrote :

This is not a bug of OpenOffice.org, it is a bug in Brother's PPD files.

Michael F. Rimbert (mrimbert) wrote :

This bug exists, even for PPD files that pass cupstestppd. With a printer configured for letter paper in cups, openoffice printer paper size settings are set to A4. This setting must be changed on every invocation of openoffice.

Changed in openoffice.org:
importance: Low → Medium
status: Needs Info → Confirmed
Matthias Klose (doko) wrote :

please recheck with 2.2.0-0ubuntu2 from feisty

Changed in openoffice.org:
status: Confirmed → Needs Info
Brian Murray (brian-murray) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. Since you reported your bug a newer version of the OpenOffice.org package is available. Could you please retest with the latest version and let us know if this is still an issue? Thanks in advance.

Changed in openoffice.org:
assignee: nobody → brian-murray
James (chiisu81) wrote :

I'm running 2.2.0-1ubuntu3, and I am having the same issue. In Format->Page option, I have it set to letter. But in Print->Options it is set to A4. However, once I added my HP LaserJet 1200 and set it as my default printer, I re-started OpenOffice Writer, and under Print->Options it is set to Letter, since my printer is set to default. Maybe A4 is the distro default when no printer has been added/made default?

Changed in openoffice.org:
assignee: brian-murray → nobody
status: Needs Info → Confirmed
Robert Persson (ireneshusband) wrote :

I have this bug—getting A4 instead of US letter—but I did not upgrade from Breezy or Hoary. (I think I started with Dapper on this machine.) Nor is my printer a Brother model. (It's an Okidata OL 600e).

Robert Persson (ireneshusband) wrote :

Oh. Forgot. Here are some of the files someone said we should post, but not all of them; I don' t seem to have /etc/cups/lpoptions, ~/.lpoptions or /.cups/lpoptions

Robert Persson (ireneshusband) wrote :

Ah. Seems like changing /etc/papersize has solved the problem as far as my laser printer goes. However it's still a bug because some people may have multiple printers, paper trays or virtual printers using different paper sizes.

Haz (haz2a) wrote :

Thanks Georg - your advice to edit the PPD fixed the problem for me.

I have Dapper 6.06 LTS running OpenOffice 2.0.2 which was unable to select A4 paper size for our Brother HL-6050. (My Edgy 6.10 running OO 2.0.4 doesn't have this problem) There is no newer deb from Brother, but editing the PPD as you describe above did the trick.

James (chiisu81) wrote :

I don't have this issue at all in Gutsy Beta, either due to OpenOffice.org 2.3 or the automatic printer configuration in Gutsy.

Chris Cheney (ccheney) on 2007-10-21
Changed in openoffice.org:
status: Confirmed → Fix Released

I have this problem in reverse with OO2.3 under Gutsy. I have a en_GB locale and I have to change the paper size from Letter to A4 before printing every time. Gutsy was a clean install (apart from /home).

Bruneel Michaël (mbruneel) wrote :

I have the same issue with Firefox, Thunderbird and OpenOffice. When we print we have to manually change from letter to a4 ...
I print through a server using the ipp protocol with cups. The file /etc/papersize is set to a4 both in the server and in the client (both ubuntu gusty up to date). I manage the printer with the web interface and the default paper is correctly set to a4. Also, on the client in "System, Administration, Printing" I set the default paper size on a4.

with 2 printers : HP Color Laser Jet 2700 and HP PSC 2175

($LANG is set to en_US.UTF-8)

Chris Cheney (ccheney) wrote :

semola,

You might be having this problem due to your locale not using A4 but you personally are. en_US.UTF-8 is setup for letter by default. I am not certain whether the various apps use /etc/papersize or the locale information. But there is definitely a LC_PAPER to set the default papertype for a locale.

Chris

~$ locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

Bruneel Michaël (mbruneel) wrote :

Chris,

Thank you for your help. I modified /etc/enviromnet and /etc/default/locale and now the result of the command local is :

$ locale
LANG=en_US.UTF-8
LANGUAGE=en_US:en
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC=fr_BE.UTF-8
LC_TIME=fr_BE.UTF-8
LC_COLLATE=fr_BE.UTF-8
LC_MONETARY=fr_BE.UTF-8
LC_MESSAGES="en_US.UTF-8"
LC_PAPER=fr_BE.UTF-8
LC_NAME=fr_BE.UTF-8
LC_ADDRESS=fr_BE.UTF-8
LC_TELEPHONE=fr_BE.UTF-8
LC_MEASUREMENT=fr_BE.UTF-8
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

Now it's OK with evince but the problem thunderbird is still there ...

Chris Cheney (ccheney) wrote :

Semola,

You should probably file a separate bug against thunderbird and whichever other programs show this problem for you.

Chris

Roger Morgan (rmorgan954) wrote :

Surely it's a bug that OpenOffice uses the Locale settings to determine the paper size, instead of the printer properties or /etc/papersize?

GNU/Linux is a multiuser operating system. Different users on one machine may have different locale settings, and at any one time, there may be users with different locale settings logged on concurrently. But the paper size is whatever is loaded in the printer.

Put a different way, if an American comes here (Switzerland) he/she will probably want to set the locale (for spell-checkers etc) to en_US. But he/she will want to print on whatever paper the printers currently have loaded, which is A4 here.

There are printers which have multiple bins which can hold different sizes of paper, so theoretically there could be a printer which had both A4 and USletter loaded, which would print either one on the correct paper. But in practice, nobody ever does that. You can't easily buy USletter size paper where I live, and I'd be surprised if you could easily buy A4 paper in the US. The common case (probably >99.9% of all installations) is that the paper in the printer depends on what country the printer is in, not on what language the user speaks/writes in.

Chris Cheney (ccheney) wrote :

Actually as Till mentioned this probably should be a function of the Cups options for the printer, since both /etc/papersize and the locale papersize settings aren't really useful. You can have multiple printers accessible from one machine each with different size paper, etc.

Chris

Hi Chris,
it is now all OK.

Max
У ср, 2008-08-13 у 18:14 +0000, Chris Cheney пише:

> Actually as Till mentioned this probably should be a function of the
> Cups options for the printer, since both /etc/papersize and the locale
> papersize settings aren't really useful. You can have multiple printers
> accessible from one machine each with different size paper, etc.
>
> Chris
>

Roger Morgan (rmorgan954) wrote :

Do you mean "OK" as in
"papersize is now determined solely by Cups options for the printer, not by the user's
locale settings"?
If so, that is great!

Roger

--- On Thu, 8/14/08, blastv <email address hidden> wrote:
From: blastv <email address hidden>
Subject: Re: [Bug 41147] Re: Wrong default paper size for printing
To: <email address hidden>
Date: Thursday, August 14, 2008, 5:30 AM

Hi Chris,
it is now all OK.

Max
У ср, 2008-08-13 у 18:14 +0000, Chris Cheney пише:

> Actually as Till mentioned this probably should be a function of the
> Cups options for the printer, since both /etc/papersize and the locale
> papersize settings aren't really useful. You can have multiple
printers
> accessible from one machine each with different size paper, etc.
>
> Chris
>

--
Wrong default paper size for printing
https://bugs.launchpad.net/bugs/41147
You received this bug notification because you are a direct subscriber
of the bug.

Status in “openoffice.org” source package in Ubuntu: Fix Released

Bug description:
My locale is french canadian. In cups-manager, default papersize is set to
letter and it works for all applications I try (gedit, firefox, ...) except
openoffice.org2. When I open a new document in Writer,
Format>page>page>format is correctly is set to letter but
File>print>properties>paper is set to a4. So I have to change it each
time I want to print.

I try to edit /etc/papersize from a4 to letter, but it doesn't change
anything.

Note: the original reporter indicated the bug was in package
'openoffice'; however, that package was not published in Ubuntu.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers