[upstream] Writer hangs indefinitely opening MS Word .doc

Bug #401003 reported by VladimirCZ on 2009-07-18
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
LibreOffice
Confirmed
High
OpenOffice
Invalid
Undecided
Unassigned
abiword (Ubuntu)
Undecided
Unassigned
libreoffice (Ubuntu)
Medium
Unassigned
openoffice.org (Ubuntu)
Low
Unassigned

Bug Description

1) lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-proposed/main i386
Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

3) What is expected to happen in LibreOffice Writer via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/401003/+attachment/630609/+files/MS%20Office%20XP%20document.doc && lowriter -nologo MS\ Office\ XP\ document.doc

and it opens quickly and successfully.

4) What happens instead is Writer hangs indefinitely.

WORKAROUND: Use Abiword.

apt-cache policy abiword
abiword:
  Installed: 2.8.6-0.3build1
  Candidate: 2.8.6-0.3build1
  Version table:
 *** 2.8.6-0.3build1 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/universe i386 Packages
100 /var/lib/dpkg/status

Original Report Comments: OOo Writer grey screens and CPU usage jumps up. The running Writer then has to be killed. This happens under Ubuntu 9.04 64-bit with OO 3.0.1 (build 9379).

Attachment was saved by MS Word XP.

VladimirCZ (vlabla) wrote :
Philip Muškovac (yofel) wrote :

Confirmed with attached document on karmic amd64 with OOo 1:3.1.0-5ubuntu1

affects: ubuntu → openoffice.org (Ubuntu)
Changed in openoffice.org (Ubuntu):
status: New → Confirmed
Chris Cheney (ccheney) wrote :

This issue is also seen in official OOo 3.1 and dev300m49 (OOo 3.2).

Changed in openoffice.org (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
summary: - Openoffice Writer freezes during opening MS Word documents
+ [upstream] OOo Writer freezes during opening MS Word documents

Confirmed in Ubuntu 10.10 LibreOffice Writer 3.3.1 at the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/661585/+attachment/1695911/+files/2.%20FR-APL-02%20ASSESSMEN-Mencari%20dan%20Membuat%20Paket%20Produk%20dan%20Jasa%20Pariwisata.doc && lowriter -nologo 2.\ FR-APL-02\ ASSESSMEN-Mencari\ dan\ Membuat\ Paket\ Produk\ dan\ Jasa\ Pariwisata.doc

LO hangs indefinitely.

lsb_release -rd
Description: Ubuntu 10.10
Release: 10.10

apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.1-1ubuntu3~maverick1
  Candidate: 1:3.3.1-1ubuntu3~maverick1
  Version table:
 *** 1:3.3.1-1ubuntu3~maverick1 0
        500 http://ppa.launchpad.net/libreoffice/ppa/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status

Confirmed in LO 3.3.2.

lsb_release -rd
Description: Ubuntu 10.10
Release: 10.10

libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu2~maverick1
  Candidate: 1:3.3.2-1ubuntu2~maverick1
  Version table:
 *** 1:3.3.2-1ubuntu2~maverick1 0
        500 http://ppa.launchpad.net/libreoffice/ppa/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status

description: updated
tags: added: lo33
summary: - [upstream] OOo Writer freezes during opening MS Word documents
+ [upstream] Writer freezes opening MS Word documents
Changed in libreoffice (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
summary: - [upstream] Writer freezes opening MS Word documents
+ [upstream] Writer hangs indefinitely opening MS Word document
summary: - [upstream] Writer hangs indefinitely opening MS Word document
+ [upstream] Writer hangs indefinitely opening MS Word .doc

Created attachment 46642
MS Office XP document.doc

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/401003/+attachment/630609/+files/MS%20Office%20XP%20document.doc && lowriter -nologo MS\ Office\ XP\ document.doc

hangs indefinitely.

As per downstream reporter this was exported from MS Word in XP:
https://bugs.launchpad.net/df-libreoffice/+bug/401003

lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-proposed/main i386
Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

Changed in df-libreoffice:
importance: Unknown → High
status: Unknown → Confirmed
description: updated
Changed in abiword (Ubuntu):
status: New → Invalid

VladimirCZ, please execute the following command, as it will automatically gather debugging information, in a terminal:
apport-collect 401003
When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

Changed in openoffice.org (Ubuntu):
importance: Medium → Low
status: Triaged → Incomplete
Changed in openoffice.org (Ubuntu):
status: Incomplete → Won't Fix

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

Changed in openoffice:
status: New → Invalid

This bug is still alive:
CONFIRMED with LibreOffice 3.4.4, German langpack,
running on MacOS X 10.6.8 German,
AND with LibO-dev 3.5.0,
Build ID: 549f928-b211287-090bcba-45cf606
Build Date: 2011-12-01.

When trying to open the sample document, LibreOffice just hangs.

Changed Platform to "All", because it affects MacOS, too (not only Linux).

[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html

Changed in df-libreoffice:
status: Confirmed → Incomplete

Problem reproducible in:
LOdev 3.5.0beta2
Build ID: 8589e48-760cc4d-f39cf3d-1b2857e-60db978
Microsoft Windows Vista Business 6.0.6002 Service Pack 2 Build 6002

Still [REPRODUCIBLE] with LibreOffice 3.5.2.2 (Build-ID: 281b639-6baa1d3-ef66a77-d866f25-f36d45f), German langpack installed, running on MacOS X 10.6.8 German. When trying to open the sample document, LibreOffice just hangs.

I will attach the MacOS X log file created when I had to force quit LibreOffice.

Created attachment 60395
Log file created by MacOS X when I had to force quit LibreOffice 3.5.2.2

@Cédric:
I inserted your address into the CC list because this bug may be related to other Writer/.doc file bugs assignet to you.

This is an old bug, but still reproducible, and certainly of some importance, as .doc file import is very important for many people, and the bug may affect other .doc files, too, not only the sample file ...

Changed in df-libreoffice:
status: Incomplete → Confirmed
shinyblue (shinyblue) wrote :

Another example of same bug? Unfortunately I can't tell you what produced this document.

shinyblue, please do not post any attachments to this report, as we already have a testcase document. If you are having a problem with Writer, please execute the following via the Terminal and feel free to subscribe me to it:
ubuntu-bug libreoffice-writer

Thanks!

master opens the attached document without any obvious problem.

LibreOffice is id 741c56a, pulled 2012-09-13.

autogen.lastrun:
    --enable-symbols
    --enable-dbgutil
    --enable-crashdump
    --disable-build-mozilla
    --without-system-postgresql
    --enable-debug
    --enable-werror

Build and execution environment:
    $ uname -a
    Linux cougar-natty 2.6.38-15-generic #64-Ubuntu SMP Fri Jul 6 17:18:17 UTC 2012 i686 athlon i386 GNU/Linux
    $ gcc --version
    gcc (Ubuntu/Linaro 4.5.2-8ubuntu4) 4.5.2

For comparison, LibreOffice supplied with ubuntu-natty (LibreOffice
3.3.4, OOO330m19 (Build:401)) has used 100% of the CPU for several
minutes without producing any visible result.

In the complete absence of any idea about what changed in the program,
I am setting bug status to RESOLVED WORKSFORME. Can other commenters,
especially those on other platforms, please confirm the lack of crash?

Terry.

Changed in df-libreoffice:
status: Confirmed → Invalid

Opens apparently without any problem.
Win7x64 LibreOffice Version 3.6.2.1 (Build ID: ba822cc)

Tested again because of request on LibreOffice QA mailing list.

The results are simple (both tests done on Mac OS X 10.6.8, Intel):

* The hang is still REPRODUCIBLE with LibreOffice 3.5.6.2 (Build ID: e0fbe70-dcba98b-297ab39-994e618-0f858f0).

* But the hang is no longer reproducible and the document opens well with LibreOffice 3.6.2.1 (Build ID: ba822cc).

* Also no longer reproducible with current master build: LOdev 3.7.0.0.alpha0+ (Build ID: 01e6335, pull time: 2012-09-18 04:23:03)

So the question is simple: should we leave this bug as RESOLVED/WORKSFORME because it is fixed in 3.6 and 3.7 (master), but not in 3.5.6.2? For me this way to proceed is fine, but if someone else wants to reopen this bug report, I would not resist ...

Roman Eisele wrote:
> ... fixed ..., but not in 3.5.6.2? For me this way to proceed is
> fine, but if someone else wants to reopen this bug report, I would
> not resist ...

I do not think it is possible to backport the fix to 3.5 without
knowing just what the fix is, i.e. the commit id(s). Alas, I am
not in a position to run bibisect.

Terry

(In reply to comment #13)
> I do not think it is possible to backport the fix to 3.5 without
> knowing just what the fix is, i.e. the commit id(s).

Correct. That’s the problem ...

Therefore, and because our current development focus is 3.6 (and 3.7), while we don’t have infinite developer resources, I fear we have to live with this bug in the 3.5 branch, and just need to encourage people to move on to 3.6.x. (At the moment some people hesitate to update, because there are still some unsolved regressions in 3.6.x, but there is good progress about fixing these regressions, and in my personal experience 3.6.2.1 already works better in most situations than any 3.3.x, 3.4.x or 3.5.x version.)

So, RESOLVED/WORKSFORME is not perfect, but realistic.

@leighman

I presume that ubuntu will pick up the fix in the normal course of affairs.

Will you do whatever is necessary for the bug reports at ubuntu?

Thanks,
Terry.

Jack Leigh (leighman) wrote :

This is fixed upstream and should make it into quantal (12.10). Unfortunately it's not likely to be fixed in the LibO 3.5 series used on 12.04

Jack Leigh, regarding your comments https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/401003/comments/19 :
>"This is fixed upstream and should make it into quantal (12.10)."

Great!

>"Unfortunately it's not likely to be fixed in the LibO 3.5 series used on 12.04"

We would not want to make this assumption. Once this report is marked Fix Released for Quantal, this bug could be sent through the SRU process first via https://wiki.ubuntu.com/StableReleaseUpdates#Procedure , and if declined, then the backport process https://wiki.ubuntu.com/UbuntuBackports#Requesting_a_Backport .

Jack Leigh (leighman) wrote :

Christopher, it is not clear what fixed this issue upstream so there is no easy way for it to make it into the 3.5 branch.

VladimirCZ, thank you for taking the time to report this bug and helping to make Ubuntu better. However, I am closing it because the bug has been fixed in the latest development version of Ubuntu - Quantal Quetzal.

This is a significant bug in Ubuntu. If you need a fix for the bug in previous versions of Ubuntu, please do steps 1 and 2 of the SRU Procedure [1] to bring the need to a developer's attention.

[1]: https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

lsb_release -rd
Description: Ubuntu quantal (development branch)
Release: 12.10

apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.6.1~rc2-1ubuntu5
  Candidate: 1:3.6.1~rc2-1ubuntu5
  Version table:
 *** 1:3.6.1~rc2-1ubuntu5 0
        500 http://archive.ubuntu.com/ubuntu/ quantal/main i386 Packages
        100 /var/lib/dpkg/status

Changed in libreoffice (Ubuntu):
status: Triaged → Fix Released

The attached document still doesn't open for me. Neither with LibreOffice 3.6 (libreoffice-writer-3.6.6.2-9.fc18.x86_64) nor with a local build of 4.1 (libreoffice-4.1.0.1-141-gca0bbec --enable-symbols --with-system-headers).

Could someone confirm or deny that the attached document does load for them and if so in which version/configuration?

As far as I can see with gdb the issue is that the while loop in sw/source/core/layout/tabfrm.cxx (SwTabFrm::MakeAll)
    while ( !mbValidPos || !mbValidSize || !mbValidPrtArea )
never succeeds. All values are always set to false during the loop.

Mark Wielaard, this report is not about your attachment, but the attachment noted in the Description https://bugs.freedesktop.org/show_bug.cgi?id=34268#c0 . If you have a bug in LibreOffice, please file a new report following http://wiki.documentfoundation.org/BugReport .

Thank you for your understanding.

(In reply to comment #17)
> Mark Wielaard, this report is not about your attachment, but the attachment
> noted in the Description
> https://bugs.freedesktop.org/show_bug.cgi?id=34268#c0

Yes, that is the one I am talking about. The attachement to this bug report you reference above. Since that one still doesn't open for me with the versions of LibreOffice I mentioned in comment #16. Is the analysis wrong or does the attachment open for you? If so please provide the libreoffice version you are using. Thanks.

Just for reference it also fails to open with another version I have around libreoffice-writer-4.0.3.3-1.el6.rhis.x86_64

Changed in df-libreoffice:
status: Invalid → Confirmed

On pc Debian x86-64 with master sources updated today, I reproduce the hang.
So I put it at NEW.

Tested in LO 4.0.4 and the last release 4.1.4.2 and it also fails !!!
It seems to be not working in all versions except in 3.6.2.1 and 3.7.0.0 (#comment 12)
Proposals are welcome to fix urgently the bug.

Mohamed-Ali, please do not toggle this report. For more on this, please see https://wiki.documentfoundation.org/BugReport .

Mohamed-Ali, as you are not the original reporter, and clearly did not read https://bugs.freedesktop.org/show_bug.cgi?id=34268#c22 please *do not* toggle this report. The fact you reproduced this in a later release, has nothing to do with the Version. The Version is ment for the *earliest* release, not the latest.

Ok Christopher : thank you for the link (I've missed some details). Therefore, i've submitted a new bug:
https://bugs.freedesktop.org/show_bug.cgi?id=73616

test files still causing hang under Win7x64 using LibO 4.2.4.2 and 4.4.0.0.alpha0+
Build ID: 488f31200094d7237d45545ab227014831a1f8e6
TinderBox: Win-x86@39, Branch:master, Time: 2014-06-15_05:02:39

both document can be opened in a few seconds using MS Word Viewer

Created attachment 105706
bt at random

On pc Debian x86-64 with master sources updated today, I could reproduce this.

Michael: I attached a bt at random. I can retrieve others if needed but it could be a infinite recursive loop. One for you?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.