[upstream] [3.2] Apostrophes are not printed when using font 'Gentium'

Bug #376953 reported by Milan Bouchet-Valat on 2009-05-15
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenOffice
Fix Released
Unknown
cups (Ubuntu)
Undecided
Unassigned
openoffice.org (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: openoffice.org

Printing a text with curved apostrophes ( ’ - U+2019, a.k.a. right single quotation mark) using the Gentium font results in blank characters instead of each apostrophe. PDF and PS exported files does not suffer from this bug, and printing these files from Evince allows to actually print the apostrophes. So the bug must be in OO.o printing system. The Gentium font includes the right character for U+2019, and other fonts print curved apostrophes right in the same document.

This is similar to bug 306286, which was closed because the original reporter could no longer provide information. Here we have a quite standard font (not installed by default yet?!), so that's a good way of tackling the bug. How can we get more information? Is that specific to my box/printer?

Chris Cheney (ccheney) wrote :

Till,

Can you take a look at this?

Chris

Changed in openoffice.org (Ubuntu):
assignee: nobody → Till Kamppeter (till-kamppeter)
status: New → Incomplete
Till Kamppeter (till-kamppeter) wrote :

As the characters appear correctly when printing exported PostScript and PDF files, the problem should not be in the printing system, but in OpenOffice.org itself. OOo is capable of producing correct PostScript or PDF, only if one uses OOo's printing function, bad PostScript is produces. For finding a quick and simple patch I recommend to compare the PostScript produced by the printing function and the PostScript produced by the export function.

Long-term fix is to switch the printing function to send PDF instead of PostScript, ideally the same PDF as the export function sends (upstream issue #94173).

http://www.openoffice.org/issues/show_bug.cgi?id=94173

Changed in openoffice.org (Ubuntu):
assignee: Till Kamppeter (till-kamppeter) → nobody
Milan Bouchet-Valat (nalimilan) wrote :

Thanks for your feedback!

Actually, I've picked the PS file OO.o sends to CUPS from /var/spool/cups, and it's identical to the one produced using the "print to file" option. So I've tried to print it via Evince, and I got the same problem with apostrophes, even if it's drawn properly on the screen. OTOH, the same text exported to PS from Abiword (it's using GNOME print) does print correctly!

So the bug may be in CUPS, or Evince is working around an invalid file produced by OO.o, which CUPS does not do. I'm attaching the two short PS files to compare - but they're quite different...

Milan Bouchet-Valat (nalimilan) wrote :
Milan Bouchet-Valat (nalimilan) wrote :
Milan Bouchet-Valat (nalimilan) wrote :

As I said, the bug is likely to be in CUPS, since Evince is able to show the PS file correctly.

Hi,

I opened both of your files into my OS X, here the Preview Application will first convert to PDF.

Still, the 'PS file produced by OO.o' is missing the right apostrophe.

Leonardo

Chris Cheney (ccheney) wrote :

Till,

They mentioned that the postscript output matches the output from print to file and displays correctly in Evince but does not print out correctly, so this sounds like it might be a cups issue after all?

Chris

Changed in openoffice.org (Ubuntu):
assignee: nobody → Till Kamppeter (till-kamppeter)

The PostScript of the attached file is already somehow broken. When sending it unfiltered to an HP LaserJet 3390, the right quote does not appear on the printout, if one displays it with Ghostscript or sends it unfiltered to the HP LaserJet P3005 the right quote appears. If I look into the PostScript file itself, I see an embedded font, and it seems that not the whole font definition is embedded but only the glyphs needed for the file. And when I look closer to it all glyphs but the right quote are defined, the right quote is not defined. It seems that some PostScript interpreters (Ghostscript, LJ P3005) have a fallback for the missing character, others not (LJ 3390).

For me this looks like a bug in the generation of the PostScript file by OpenOffice.org.

Changed in openoffice.org (Ubuntu):
assignee: Till Kamppeter (till-kamppeter) → nobody
Chris Cheney (ccheney) wrote :

This is probably an upstream bug.

Changed in openoffice.org (Ubuntu):
status: Incomplete → Triaged

I just discovered this bug today.

I am using ooo 3.0.1 on Ubuntu 8.04.3 LTS. I have the same bug with Gentium font. (Pair kerning on)

I am printing with CUPS 1.3.7.

My printer is a Kyocera FS-C5015N. I was a bit surprised to see the apostrophe missing (especially as it was a French document!)

OOO ----> Kyocera FS-C5015N - no apostrophe FAIL
OOO ----> PDF and PS - OK
PDF (KPDF) ----> Kyocera FS-C5015N - OK
PDF (Acrobat) ----> Kyocera FS-C5015N - OK
OOO ----> HP LaserJet 1015 - OK !!!!

It seems the OOO to Kyocera fails.

I strongly suspect a problem with the filter as the Kyocera is a PDL printer. Perhaps a bug in PS to PDL?

Hope this helps.

Kevin

Kevin, this result fits exactly to my observation of comment #10.

Time to report it upstream I guess...

Changed in openoffice:
importance: Undecided → Unknown
status: New → Unknown
Changed in openoffice:
status: Unknown → New
Changed in openoffice:
status: New → Confirmed
Changed in openoffice:
status: Confirmed → Invalid

That's a bug in OpenOffice, there's a fix committed upstream.

Changed in openoffice:
status: Invalid → Unknown
Changed in cups (Ubuntu):
status: New → Invalid
Changed in openoffice:
status: Unknown → Fix Released

Bugs similar to this one which can perhaps be the same bug are: bug 124134, bug 124134, bug 306286, and bug 449255.

Chris Cheney (ccheney) on 2009-12-07
summary: - Apostrophes are not printed when using font 'Gentium'
+ [upstream] [3.2] Apostrophes are not printed when using font 'Gentium'

This one seems to have been fixed upstream with 3.2 (ooo32gsl09).

Changed in openoffice.org (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.