OpenOffice Writer save as MS Word format produces blank table

Bug #369290 reported by Bruno Girin on 2009-04-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
openoffice.org (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: openoffice.org

When creating a table in a Writer document where the left margin of the table is outside the page's margin, saving the file as a Microsoft Word 97/2000/XP (.doc) file, the resulting doc file only contains a blank page. Adjusting the left margin of the table so that it is inside the page's margin resolves the problem.

See the following discussion for more details on the bug: http://ubuntuforums.org/showthread.php?t=1142217

Steps to re-create.
1. Open the attached .odt file in Writer
2. Save the .odt file as Microsoft Word 97/2000/XP (.doc)
3. Open the resulting .doc file in OO.o: the file should look identical to the original but is a blank page
3a. Open the .doc file in Microsoft Word: the file is a blank page too
4. Re-open the .odt file in OO.o
5. Adjust the left margin of the table so that it falls within the page's margins
6. Save the .odt file as Microsoft Word 97/2000/XP (.doc)
7. Open the resulting .doc file in OO.o: the file is displayed properly

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
Package: openoffice.org-core 1:3.0.1-9ubuntu3
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: openoffice.org
Uname: Linux 2.6.28-11-generic i686

Bruno Girin (brunogirin) wrote :
Bruno Girin (brunogirin) wrote :

Updating the status to Confirmed as it was reproduced by several users in the forum thread, namely:
- originally reported by Captain Legless who also provided the example file
- reproduced by alphacrucis2 (http://ubuntuforums.org/showpost.php?p=7176020&postcount=10), Big_astur and myself
- workaround provided by Big_astur (http://ubuntuforums.org/showpost.php?p=7176034&postcount=11) and confirmed by alphacrucis2, Captain Legless and myself

Changed in openoffice.org (Ubuntu):
status: New → Confirmed
whakim (wafa1024) wrote :

In addition to all of the above, after inserting a new table into a Word document in OOwriter, saving the file, and closing it, when the file is opened again the table is not visible at all. If the file is saved as .odt, things are fine but the table is still not visible. However, it remains impossible to add text to the part of the file where the table used to be. When the same .doc file is opened in Abiword, the table is visible but covered with black rectangles.

Chris Cheney (ccheney) wrote :

Does this bug look the same as bug 330366 to you?

Chris

Changed in openoffice.org (Ubuntu):
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers