[ooo-build] OpenOffice programs exit at launch

Bug #365763 reported by Mary Gardiner on 2009-04-23
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
OpenOffice
Invalid
Undecided
Unassigned
openoffice.org (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: openoffice.org

When I launch OpenOffice programs on one of my desktop machines, they consistently exit after displaying the splash screen and advancing the progress bar about 1/3 of the way to completion. No error dialogs or messages of any kind appear.

If I run the programs on the command line, I get this error:

$ oowriter

** (soffice:30449): WARNING **: unable to get gail version number

$ oocalc

** (soffice:30468): WARNING **: unable to get gail version number

$ oodraw

** (soffice:30490): WARNING **: unable to get gail version number

I've run it with the debugging symbols (as best I can, since OO programs are launched with shell scripts, so it's a little hard to work out precisely how to invoke them directly), but the exit is not a crash in the normal sense of the word:

$ gdb /usr/lib/openoffice/program/oosplash.bin
GNU gdb 6.8-debian
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "i486-linux-gnu"...
(gdb) run
Starting program: /usr/lib/openoffice/program/oosplash.bin
[Thread debugging using libthread_db enabled]
[New Thread 0xb79a46d0 (LWP 30367)]
[New Thread 0xb7921b90 (LWP 30370)]

** (soffice:30371): WARNING **: unable to get gail version number
[Thread 0xb7921b90 (LWP 30370) exited]

Program exited normally.
(gdb) bt
No stack.
(gdb) quit

Mary Gardiner (puzzlement) wrote :

A couple of notes:

1. I'm using the Jaunty versions.

2. OpenOffice runs fine on a second Jaunty desktop I use.

3. I don't think this is the same bug as bug 350193, since reproducing 350193 seems to imply that OpenOffice has actually launched to the extent that data can be pasted into a spreadsheet.

Chris Cheney (ccheney) wrote :

The gail version warning has nothing to do with the failure to run, it shows that for everyone.

Does moving/removing ~/.openoffice.org* help?

Changed in openoffice.org (Ubuntu):
status: New → Incomplete
summary: - OpenOffice programs exit at launch with "unable to get gail version
- number"
+ OpenOffice programs exit at launch

On Fri, Apr 24, 2009, Chris Cheney wrote:
> Does moving/removing ~/.openoffice.org* help?

No:

$ mv ~/.openoffice.org* /tmp
$ oowriter

** (soffice:7898): WARNING **: unable to get gail version number

[OpenOffice then exits just as described before.]

Changed in openoffice.org (Ubuntu):
status: Incomplete → New

Were both Jaunty systems fresh installed Jaunty or upgrades or some combination of the two?

Changed in openoffice.org (Ubuntu):
status: New → Incomplete

Both systems were upgrades from Intrepid. OpenOffice worked on both systems on Intrepid (and all previous versions). I think I installed the working system at Edgy and have upgraded from there, and the non-working system at Gutsy and upgraded from there.

 status new

Changed in openoffice.org (Ubuntu):
status: Incomplete → New
Mary Gardiner (puzzlement) wrote :

On the non-working system, I just used the Guest account, and OpenOffice works in that account. So this must be a property of my user account, although apparently not the ~/.openoffice.org/ directory per my test of moving it.

When you moved the ~/.openoffice.org/ directory did you also check for and move any ~/.openoffice.org2/ directory as well?

Changed in openoffice.org (Ubuntu):
status: New → Incomplete

Per my comment at the time, I ran

$ mv ~/.openoffice.org* /tmp

to confirm:

$ ls -ld ~/.openoffice*
drwxr-xr-x 3 mary mary 4096 2009-04-24 11:29 /home/mary/.openoffice.org

That's the ~/.openoffice.org/ directory that got newly created after the original 'mv'. There is no ~/.openoffice.org2/ directory (and since I haven't rebooted: there wasn't one moved to /tmp either).

 status new

Changed in openoffice.org (Ubuntu):
status: Incomplete → New

Please attach the output of:

strace -f -o openoffice.log oowriter

The 'openoffice.log' file is what I need attached after the program has finished running.

Thanks,

Chris Cheney

Changed in openoffice.org (Ubuntu):
status: New → Incomplete
Mary Gardiner (puzzlement) wrote :
Changed in openoffice.org (Ubuntu):
status: Incomplete → New
Matthew Helmke (matthelmke) wrote :

My experience is the same as Mary's, except that in my non-working system, OOo does not start in a guest account either. I'm attaching an strace from my system from the main account.

Chris Cheney (ccheney) on 2009-04-26
Changed in openoffice.org (Ubuntu):
status: New → Confirmed
Magnes (magnesus2) wrote :

The same here. Although it works on root account. Also after upgrading from intrepid to jaunty when I started Writer it crashed (but after showing the main window) and after that I wasn't able to run it anymore.

Magnes (magnesus2) wrote :

PS. So maybe the problem is because of the crash recovery? Another thing: the first crash of OOo Writer caused X server to crash.

I had the same symptoms on Jaunty/PowerPC after I installed the "Mac4Lin" package. The relevant statements in strace are apparently

[pid 8713] access("/home/albrecht/.fonts/Aquabase-spanish-support.ttf", R_OK) = 0
[pid 8713] open("/home/albrecht/.fonts/Aquabase-spanish-support.ttf", O_RDONLY) = 27
[pid 8713] fstat64(27, {st_mode=S_IFREG|0644, st_size=174420, ...}) = 0
[pid 8713] mmap(NULL, 174420, PROT_READ, MAP_SHARED, 27, 0) = 0x49b28000
[pid 8713] close(27) = 0
[pid 8713] --- SIGSEGV (Segmentation fault) @ 0 (0) ---
[pid 8713] exit_group(78) = ?

After re-naming the ~/.fonts folder, soffice comes up again. I then re-named the folder back to .fonts, removed the file Aquabase-spanish-support.ttf, and soffice still works. Looks like a bug in the font engine.

Hope this helps, Albrecht.

Shibin CK (shibinck) wrote :

I too had this problem and for me the culprit was Vanib.ttf
-shibin

Chris Cheney (ccheney) wrote :

Where did the two of you get the fonts that caused the problems? I need to examine them to see what the source of the problem actually is.

Thanks,

Chris Cheney

Changed in openoffice.org (Ubuntu):
status: Confirmed → Incomplete

Mac4Lin: see <http://sourceforge.net/project/showfiles.php?group_id=204373>. It contains "Mac4Lin_v1.0_RC1/Fonts/fonts.tar.gz", which tun turn contains the "offending" file (Aquabase-spanish-support.ttf).

Chris Cheney (ccheney) wrote :

This appears to be an ooo-build issue as it does not occur with the official OOo 3.1.0

summary: - OpenOffice programs exit at launch
+ [ooo-build] OpenOffice programs exit at launch
Changed in openoffice.org (Ubuntu):
status: Incomplete → Triaged

As the original bug filer, I cannot confirm that the fonts problem is causing my original bug:

If I move ~/.fonts out of the way:

    $ mv ~/.fonts ~/Desktop
    $ oowriter

    ** (soffice:31662): WARNING **: unable to get gail version number

    [followed by same crash symptoms as always]

The last ttf file mentioned in my strace is Inconsolata, installed as the Ubuntu package ttf-inconsolata:

4447 access("/usr/share/fonts/truetype/ttf-inconsolata/Inconsolata.otf", R_OK) = 0
4447 open("/usr/share/fonts/truetype/ttf-inconsolata/Inconsolata.otf", O_RDONLY) = 28
...

Removing and purging ttf-inconsolata does NOT solve my crash and in any case there is no segmentation fault as in Albrecht's strace.

Should the crashes due to files in ~/.fonts therefore be tracked in a different bug at least until we're sure that my bug is the same?

Chris Cheney (ccheney) wrote :

Mary,

Do you still have this problem with the new version of OOo in the ppa at https://launchpad.net/~openoffice-pkgs/+archive ?

Chris: the version of OO from the PPA (1:3.1.0-3ubuntu2~jaunty1 for openoffice.org) launches for me and appears to work, although I haven't extensively tested.

Chris Cheney (ccheney) on 2009-06-16
Changed in openoffice:
status: New → Invalid
Changed in openoffice.org (Ubuntu):
status: Triaged → Fix Released
tony_wh (tony-wh-esq) wrote :

I too had the same problem. I even opened a thread out of desperation:
http://ubuntuforums.org/showthread.php?p=7578015

I am running a Jaunty upgrade from a clean intrepid install. My symptoms were exactly as outline in the first post. It coincided with an Update, installing VirtualBox to run WM7 (don't ask! I just need it!) and adding msttcorefonts. As a result of wanting to use files on Ubuntu and WM7, I was sharing one of the folders to use files across OS; however I couldn't open any file as a user from any folder whether it was shared or not. If I opened Nautilus as root, everything opened fine. I did uninstall msttcorefonts but it didn't help.

I checked all the permissions and ownership of the files and the ~/.openoffice,org/ files but all seemed in order. I renamed them all in any case, all to no avail.

I then performed the partial upgrade and it works. Thank you very much.

I will re-establish the share and start using Virtualbox and let you know what happens.

I hope this helps. Please let me know if you need any other details.

Eric Polin (eric-polin) wrote :

Not sure this helps, but since there was a question about it, I have the same msg on a BRAND NEW Ubuntu 9.4 when launching (successfully) oocalc, either with my account or as root:

** (soffice:5912): WARNING **: unable to get gail version number

My config is a plain Ubuntu 9.4 Workstation plus the following modules:
 - Codecs: gstreamer0.10-plugins-ugly, gstreamer0.10-plugins-bad, gstreamer0.10-ffmpeg
 - vlc, vlc-plugin-pulse
 - adobe-flashplugin
 - cryptsetup (requires relog or reboot)
 - firestarter
 - apache2
 - mysql-server
 - mysql-admin
 - php5
 - apt-get install secure-delete
 - apt-get install unrar-free
 - apt-get install rlwrap
 - apt-get install meld
 - git-core
 - git-doc
 - gitk
 - imagemagick
 - w32codecs_20071007-0medibuntu3_i386.deb
 - libdvdcss2_1.2.9-2medibuntu4_i386.deb
 - spamassassin
 - ttf-liberation (the msg takes place also without this module)
 - openoffice.org-java-common (the msg takes place also without this module)
I also have an NVidia and a modem drivers, vmware, and probably a few other things I can't think of.

pappy (papoudas) wrote :

Hi everybody
I have the same problem only in my case it happens with writer. All the other programs work fine.
If i run oowriter from console i get the same message

oowriter

** (soffice:6487): WARNING **: unable to get gail version number
I also include the openoffice .log file to see it.
Thank you very much

pappy (papoudas) wrote :

Forgot to mention that I'm running Ubuntu 9.04 clean install

EclipseAgent (ben-kevan) wrote :

I get this when I try to open on remote samba connection

mati (mati-wroc) wrote :

Yesterday's updates caused the same for me. Updating to the PPA version helped: https://launchpad.net/~openoffice-pkgs/+archive

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers