[Upstream] [hardy] Writer mis-shifts OLE object in Microsoft Word .doc

Bug #36156 reported by Matthias Klose on 2006-03-23
12
Affects Status Importance Assigned to Milestone
LibreOffice
Confirmed
Medium
OpenOffice
Unknown
Low
libreoffice (Ubuntu)
Medium
Unassigned
openoffice.org (Ubuntu)
Low
Unassigned

Bug Description

1) lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-proposed/main i386
Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

3) What is expected to happen in LibreOffice Writer via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/36144/+attachment/8047/+files/pd18.doc && lowriter -nologo pd18.doc

it looks as it does in Word.

4) What happens instead is the OLE object at the top of page 1 is mis-shifted to the left.

Phil Bull (philbull) wrote :

Referred-to attachment:

http://librarian.launchpad.net/1819385/pd18.doc

I can confirm incorrect rendering of document.

Changed in openoffice.org:
status: Unconfirmed → Confirmed
Chris Cheney (ccheney) wrote :

I can confirm this document renders correctly in Word 2007 but not in OpenOffice 2.3.0.

Chris

Chris Cheney (ccheney) on 2008-03-24
Changed in openoffice:
importance: Undecided → Unknown
status: New → Unknown
Changed in openoffice:
status: Unknown → New
Changed in openoffice:
status: New → Confirmed
Chris Cheney (ccheney) on 2008-06-13
Changed in openoffice.org:
status: Confirmed → Triaged
Chris Cheney (ccheney) on 2010-05-13
tags: added: hardy

Still not rendered right in Maverick, using OpenOffice 3.2.1.

description: updated

Created attachment 46649
pd18.doc

Downstream bug may be found at:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/36156

OOo bug may be found at:
http://openoffice.org/bugzilla/show_bug.cgi?id=87388

1) lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-proposed/main i386
Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

3) What is expected to happen in LibreOffice Writer via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/36144/+attachment/8047/+files/pd18.doc && lowriter -nologo pd18.doc

it looks as it does in Word.

4) What happens instead is the OLE object at the top of page 1 is mis-shifted to the left.

summary: - [Upstream] [hardy] OpenOffice misrendered Microsoft Word Document
+ [Upstream] [hardy] Writer mis-shifts OLE object in Microsoft Word .doc
Changed in libreoffice (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in openoffice.org (Ubuntu):
status: Triaged → Won't Fix

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html

Changed in df-libreoffice:
status: Confirmed → Incomplete

Problem reproducible in:
LOdev 3.5.0beta2
Build ID: 8589e48-760cc4d-f39cf3d-1b2857e-60db978
Microsoft Windows Vista Business 6.0.6002 Service Pack 2 Build 6002

Changed in df-libreoffice:
status: Incomplete → Confirmed

reproducible with LO 3.6.4.3. (Win7 Home, 64bit)

The file looks different in LO and in Word 2007:
on page 1 and 5 and regarding the colour of the footer.

Created attachment 103135
Comparative screenshot of MS Word 2007 and LO Writer 4.3.0

Reproducible with LibreOffice 4.2.5 and 4.3.0 on Debian and Windows 7. I attach a screenshot which demonstrates a correct representation and the issue. I do not see any problem with font clor in a footer.

Changed in openoffice:
importance: Unknown → Low
status: Confirmed → Unknown
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.