[upstream] Calc Input bar error looses last character of pasted content

Bug #347453 reported by davidpbrown on 2009-03-23
4
Affects Status Importance Assigned to Milestone
LibreOffice
Confirmed
Low
OpenOffice
Confirmed
Unknown
libreoffice (Ubuntu)
Medium
Unassigned
openoffice.org (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: openoffice.org

1) lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

3) What is expected to happen is if one copies a cell containing:
test

and paste it into the 'input line' bar, just test is pasted.

4) What happens instead is that a space is appended to the end of test. If one backspaces or deletes the space, the last character is deleted.

WORKAROUND: Paste into the desired cell directly, not the input line.

Original Reporter Comments: This seen in OOo 3.0.1 Build:9379

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 8.10
NonfreeKernelModules: ndas_core nvidia
Package: openoffice.org-core 1:3.0.1-7ubuntu1~intrepid1
ProcEnviron:
 PATH=/usr/lib/openoffice/program:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: openoffice.org
Uname: Linux 2.6.27-11-generic i686
UnreportableReason: This is not a genuine Ubuntu package

Revision history for this message
davidpbrown (davidpbrown) wrote :
Chris Cheney (ccheney) on 2009-03-23
Changed in openoffice.org (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Revision history for this message
davidpbrown (davidpbrown) wrote :

Delete works ok.. that is delete forward of the cursor. It's more accurately Backspace - deleting the character behind the cursor, that triggers this.

Chris Cheney (ccheney) on 2009-03-23
summary: - Openoffice Calc Input bar error looses last character of pasted content
+ [upstream] Calc Input bar error looses last character of pasted content
Changed in openoffice:
status: Unknown → Confirmed
Chris Cheney (ccheney) on 2010-05-13
tags: added: intrepid
Revision history for this message
Christopher M. Peñalver (penalvch) wrote :

davidpbrown, I performed the same test and noticed a one character space was inserted into the input line after the content. After hitting enter, then checking the cell, the space did not persist. Does this work for you?

lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

apt-cache policy libreoffice-calc
libreoffice-calc:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

Changed in libreoffice (Ubuntu):
status: New → Incomplete
Revision history for this message
In , Christopher M. Peñalver (penalvch) wrote :

Downstream bug may be found at:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/347453

1) lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

3) What is expected to happen is if one copies a cell containing "test", and paste it into the 'input line' bar, just test is pasted.

4) What happens instead is that a space is appended to the end of test. If one backspaces or deletes the space, the last character is deleted.

Revision history for this message
In , Christopher M. Peñalver (penalvch) wrote :

Downstream bug may be found at:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/347453

1) lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

3) What is expected to happen is if one copies a cell containing "test", and paste it into the 'input line' bar, just test is pasted.

4) What happens instead is that a space is appended to the end of test. If one backspaces or deletes the space, the last character is deleted.

Revision history for this message
davidpbrown (davidpbrown) wrote :

Yes. This is obvious a very old bug now and exiting the cell that additional space is properly removed but perhaps it shouldn't be introduced.

It seems the added whitespace isn't actually there but just the appearance of it. So, if you now press backspace to delete that whitespace, it is the last character of the content that's removed.

Example, pasting "test" content value from another cell, you see what appears to be a space suffix, but deleting that space deletes the last character non-obviously. You see "test" as expected in the input bar with the suffix space removed but in the cell you see the reality "tes". That truncated result then is the stored value when you exit the cell.

Revision history for this message
Christopher M. Peñalver (penalvch) wrote :

davidpbrown, good catch on deleting the space removes the last character! Since this bug has enough information provided for a developer to begin work, I'm going to mark it as Triaged and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in libreoffice (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Triaged
description: updated
tags: added: lo33
Changed in df-libreoffice:
importance: Unknown → Low
status: Unknown → Confirmed
Revision history for this message
In , timar (timar74) wrote :

It is the same on Windows. Reproduced also in 3.4.0.

Revision history for this message
In , timar (timar74) wrote :

It is the same on Windows. Reproduced also in 3.4.0.

Revision history for this message
In , timar (timar74) wrote :

Kohei, can you please check this?

Revision history for this message
In , timar (timar74) wrote :

Kohei, can you please check this?

Revision history for this message
In , Wope-1 (wope-1) wrote :

in LibO 3.3.3 and 3.4.1 it seems to be ok. Please test it.

Revision history for this message
In , Wope-1 (wope-1) wrote :

in LibO 3.3.3 and 3.4.1 it seems to be ok. Please test it.

Revision history for this message
In , Christopher M. Peñalver (penalvch) wrote :

Reproduced in LO Calc 3.3.3.

lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

apt-cache policy libreoffice-calc
libreoffice-calc:
  Installed: 1:3.3.3-1ubuntu1
  Candidate: 1:3.3.3-1ubuntu1
  Version table:
 *** 1:3.3.3-1ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-proposed/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

Revision history for this message
In , Christopher M. Peñalver (penalvch) wrote :

Reproduced in LO Calc 3.3.3.

lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

apt-cache policy libreoffice-calc
libreoffice-calc:
  Installed: 1:3.3.3-1ubuntu1
  Candidate: 1:3.3.3-1ubuntu1
  Version table:
 *** 1:3.3.3-1ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-proposed/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

Changed in openoffice.org (Ubuntu):
status: Triaged → Won't Fix
Revision history for this message
Björn Michaelsen (bjoern-michaelsen) wrote : migrating packaging from OpenOffice.org to Libreoffice

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

Revision history for this message
In , Robert Roth (evfool) wrote :

Do you

Revision history for this message
In , Robert Roth (evfool) wrote :

Do you

Revision history for this message
In , Stgohi-lobugs (stgohi-lobugs) wrote :

Reproducible with LO 4.4.0.3, Win 8.1.

Steps Done:
1. Open CALC
2. Write in cell A1 "test"
3. Select cell A1 and press CTRL + C
4. Select cell B1 and put the cursor in the Input Line below the toolbars at the top
5. Press CTRL + V

Interim Result: A space is appended at the end of "test"

6. Press the backspace key to delete this wrongly added space manually
>Take a look at the Input Line and the cell B1 itself<
   Press Enter

Result: In the Input Line only the wrongly added space is deleted, but in "real" the last character of "test" is deleted -> Result: "tes"

Revision history for this message
In , Qa-admin-q (qa-admin-q) wrote :

** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice
   (5.0.5 or 5.1.0) https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and
   your operating system, and any changes you see in the bug behavior

   If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave
   a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not
   appropriate in this case)

If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword

Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2016-02-21

Revision history for this message
In , Qa-admin-q (qa-admin-q) wrote :

** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice
(5.2.5 or 5.3.0 https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and
your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave
a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not
appropriate in this case)

If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3
. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to "inherited from OOo";
4b. If the bug was not present in 3.3 - add "regression" to keyword

Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug-20170306

Revision history for this message
In , Wope-1 (wope-1) wrote :

Since 4.1.6 8(linux) (the earliest version, i have) until 5.3.0.2 (linux and win) the defect was corrected

tags: added: xenial
Revision history for this message
In , Christopher M. Peñalver (penalvch) wrote :

wope, thanks for testing to this. However, I was still able to reproduce as per below:
1) Windows 10 x64
Version: 5.3.0.3 (x64)
Build ID: 7074905676c47b82bbcfbea1aeefc84afe1c50e1
CPU Threads: 2; OS Version: Windows 6.19; UI Render: default; Layout Engine: new;
Locale: en-US (en_US); Calc: group

2) apt policy libreoffice-calc
libreoffice-calc:
  Installed: 1:5.1.6~rc2-0ubuntu1~xenial1
  Candidate: 1:5.1.6~rc2-0ubuntu1~xenial1
  Version table:
 *** 1:5.1.6~rc2-0ubuntu1~xenial1 500
        500 http://us.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
        500 http://us.archive.ubuntu.com/ubuntu xenial-security/main amd64 Packages
        100 /var/lib/dpkg/status
     1:5.1.2-0ubuntu1 500
        500 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 Packages

description: updated
Revision history for this message
In , Qa-admin-q (qa-admin-q) wrote :

** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not
appropriate in this case)

If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3
. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword

Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug

Revision history for this message
In , Wope-1 (wope-1) wrote :

I tested it again with Win 10 and LibO 6.0.4.2
All was ok

Revision history for this message
In , Christopher M. Peñalver (penalvch) wrote :

This still happens in both Windows and Linux:
Version: 6.0.4.2 (x64)
Build ID: 9b0d9b32d5dcda91d2f1a96dc04c645c450872bf
CPU threads: 8; OS: Windows 10.0; UI render: GL;
Locale: en-US (en_US); Calc: group

Version: 6.0.3.2
Build ID: 1:6.0.3-0ubuntu1
CPU threads: 2; OS: Linux 4.15; UI render: default; VCL: gtk3;
Locale: en-US (en_US.UTF-8); Calc: group

tags: added: bionic
Revision history for this message
In , Xiscofauli (xiscofauli) wrote :

(In reply to A (Andy) from comment #6)
> Reproducible with LO 4.4.0.3, Win 8.1.
>
> Steps Done:
> 1. Open CALC
> 2. Write in cell A1 "test"
> 3. Select cell A1 and press CTRL + C
> 4. Select cell B1 and put the cursor in the Input Line below the toolbars at
> the top
> 5. Press CTRL + V
>
> Interim Result: A space is appended at the end of "test"
>
> 6. Press the backspace key to delete this wrongly added space manually
> >Take a look at the Input Line and the cell B1 itself<
> Press Enter
>
> Result: In the Input Line only the wrongly added space is deleted, but in
> "real" the last character of "test" is deleted -> Result: "tes"

I can reproduce the problem with the adde space, but not the 'tes' result.
@Christopher M. Penalver, is this what you reproduce ?

Revision history for this message
In , Christopher M. Peñalver (penalvch) wrote :

Xisco Faulí, I'm only using the instructions noted in the Description (i.e. the scope of this report):
https://bugs.documentfoundation.org/show_bug.cgi?id=37864#c0

Revision history for this message
In , Qa-admin-q (qa-admin-q) wrote :

Dear Christopher M. Penalver,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not
appropriate in this case)

If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3
. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword

Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug

Revision history for this message
In , Thomas-lendo (thomas-lendo) wrote :

I can reproduce the issue from comment 0 (copying).

I cannot reproduce the issue from comment 6 (deleting) as Xisco also said in comment 14.

Version: 6.4.0.0.alpha0+ (x64)
Build ID: 41cd3e8e817c8c33a13608e62eeb06ce2c6977e4
CPU threads: 12; OS: Windows 10.0; UI render: GL; VCL: win;
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-09-01_22:04:10

Changed in df-libreoffice:
importance: Low → Unknown
status: Confirmed → Unknown
Changed in df-libreoffice:
importance: Unknown → Low
status: Unknown → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.