[upstream] Human icon theme gets wrong icons for OOo mimetypes

Bug #339590 reported by David Prieto on 2009-03-08
32
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenOffice
Unknown
Low
openoffice.org (Ubuntu)
Medium
Chris Cheney
Declined for Jaunty by Chris Cheney

Bug Description

Binary package hint: openoffice.org

I am using Openoffice 3.0 on Ubuntu Jaunty. Since recent updates, OOo-related files show new icons instead of the usual ones.

I find these icons extremely ugly, but personal taste might make a weak argument against them. However, they do stand out and feel out of place when compared with the rest of the icons, because of their intense colours and bold layout that don't follow the tango guidelines. It is also, to my knowledge, the first case of apps "stealing" filetypes, that is, of filetypes showing icons belonging to a specific app. If images don't show EOG or GIMP icons, if videos don't show the Totem icon and music files don't show the Rhythmbox icon... why should documents show the OOo icon instead of a generic one?

The new icon does not facilitate recognition, either. Given that the gnome menu doesn't show the original OOo icons (the one with the seagulls) but alternate ones in the tango style, the new file icons don't even give a hint as to which app will open the files. And what if I choose to use Abiword, or Gnumeric, to open them? Why should they have the OOo icon?

Additionally, not all document types show the new icon. ODT files do, but DOC ones don't. Why should they not use the same icon, if they're both document files after all?

Chris Coulson (chrisccoulson) wrote :

Thank you for your bug report. Would you mind please providing a screenshot of your problem. Most likely this is a theme issue rather than an Openoffice issue, but it would be useful to know exactly which icons you are referring to.

Changed in openoffice.org:
importance: Undecided → Low
status: New → Incomplete

Sure. I'm attaching a screenshot showing a .doc file still showing the old document icon, and an .odt file showing the new OOo icon.

These icons appeared right after an OOo updated, so I'm led to believe it is and Openoffice issue indeed.

Changed in openoffice.org:
status: Incomplete → New
Chris Cheney (ccheney) on 2009-03-08
Changed in openoffice.org:
status: New → Won't Fix

Hi, I just noticed you marked this as wontfix. Since I took the time to make my point, would you please say why?

Thanks in advance.

Greg A (etulfetulf) wrote :

incorrect package

Changed in openoffice.org:
status: Won't Fix → Invalid

Oh, thanks for clarifying then :)

Lee Boynton (lboynton) wrote :

I prefer the old icons, and agree that .odt and .doc icons should be the same as they are both documents. What was the reasoning behind the change?

Changed in gnome-icon-theme:
status: New → Invalid
Chris Coulson (chrisccoulson) wrote :

Closing the gnome-icon-theme task. This looks more like an openoffice problem than a gnome-icon-theme problem. The latest version of the openoffice.org-common binary package ships some extra application-vnd.oasis.opendocument.* symlinks in /usr/share/icons/gnome/16x16, 32x32 and 48x48 when it never used to do this. This means that the "gnome" mimetype icons (which is what you saw before the upgrade) contained in /usr/share/icons/gnome/scalable don't get used anymore. I believe that is probably incorrect. Shouldn't these just go in /usr/share/icons/hicolor instead?

Changed in openoffice.org:
status: Invalid → Triaged
Chris Cheney (ccheney) wrote :

Oops, for some reason I managed to get bad output out of dpkg -S earlier when I was following up on the forum. After doing a bit more digging this was a fix for debian bug 512792.

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=512792

Chris Cheney (ccheney) wrote :

According to the information in the Debian bug report this appears to only be an issue in Ubuntu now because the icons were named incorrectly in the past and the Human theme does not override the icons.

Chris Cheney (ccheney) on 2009-03-13
Changed in openoffice.org:
importance: Low → Wishlist
Changed in gnome-icon-theme:
status: Invalid → New

The Human theme doesn't appear to ship any mimetype icons for Openoffice. The icons seen previously were inherited from gnome-icon-theme, in /usr/share/icons/gnome/scalable/mimetypes.

The problem is seen now because Openoffice installs it's own mimetype icons in /usr/share/icons/gnome/*/mimetypes now (with the exception of /usr/share/gnome/scalable/mimetypes), when it didn't do this before. This has the effect of overriding the gnome-icon-theme icons, which I believe is wrong. It also means that gnome-icon-theme now has 2 different icons for these mimetypes, depending on the icon size (scalable has the gnome-icon-theme icon whilst all the others have the OOo one). The Openoffice mimetype icons should go in /usr/share/hicolor, where they will be inherited if no other theme has their own.

The only icons in /usr/share/icons/gnome should be icons that belong to the gnome-icon-theme shouldn't they?

I guess so. Packages should install their custom icons in the hicolor theme from what the icon theme specification says. The current behavior is breaking the whole design of the spec. And anyway, OpenDocument files should use the same icons as generic office documents in those themes.

Chris Cheney (ccheney) wrote :

I understand the OOo part of the issue now. I have talked to the Debian maintainer also and it appears we will be fixing this issue in the next upload. I think this may be an upstream bug also since no files should exist under /usr/share/icons/gnome/ inside OOo packaging.

Of course human icon theme still will need to override the icons if it wants to but the OOo icons should only exist under hicolor.

http://standards.freedesktop.org/icon-theme-spec/icon-theme-spec-latest.html

Thanks,

Chris

Changed in openoffice.org:
importance: Wishlist → Medium
milestone: none → ubuntu-9.04-beta
assignee: nobody → ccheney
Chris Coulson (chrisccoulson) wrote :

Thanks Chris :)

Changed in openoffice:
status: Unknown → Confirmed
Chris Cheney (ccheney) on 2009-03-21
summary: - human icon theme does not have icons for OOo mimetypes
+ [upstream] human icon theme does not have icons for OOo mimetypes
Changed in openoffice.org (Ubuntu):
milestone: ubuntu-9.04-beta → ubuntu-9.04

Applications are only supposed to install icons into /usr/share/icons/hicolor,
the other directories are reserved for specific themes. So the icons currently
in /usr/share/icons/gnome should either be in /usr/share/icons/hicolor, or be
removed.

See:

http://standards.freedesktop.org/icon-theme-spec/icon-theme-spec-latest.html

a ihi: Please have a look.

I'm sorry about the dumb question, but... is the expected outcome still NOT having these "special" icons for OOo files?

I kinda got lost after the bug name change.

David: The problem is not a *lack* of icons, but rather the presence of custom icons that should not be installed in the Human icon theme by OpenOffice.org. OpenDocument files should use generic office icons, just like others.

I've renamed the bug the be more accurate.

Chris Cheney (ccheney) wrote :

I think what will probably need to happen is for OOo to remove the icons from gnome-icon-theme which is what I will be doing and then gnome-icon-theme or human whichever needs to override them with whatever it wants to use, probably using symlinks in their own theme.

Chris: Icons for OpenDocument files are already handled by Human icon theme I guess, and anyway shared-mime-info provides a generic fallback, which is the one we want to use.

Chris Cheney (ccheney) on 2009-04-05
Changed in openoffice.org (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openoffice.org - 1:3.0.1-9ubuntu1

---------------
openoffice.org (1:3.0.1-9ubuntu1) jaunty; urgency=low

  * Resynchronise with Debian (r1448). Remaining changes:
    - Add Launchpad integration support.
    - Add Launchpad translations support.
    - Add package openoffice.org-style-human.
    - Add some Ubuntu-specific bitmaps. Adjust broffice diversions for these.
    - Add support for compressing debs with lzma.
    - Add support for shared /usr/share/doc directories.
    - Add support to build l10n as a separate source.
    - Add support to build on lpia.
    - Add support to turn off building on sparc.
    - Add Xb-Npp-xxx tags according to "firefox distro add-on suport" spec.
    - Set startcenter.desktop to not display in the menu.
    - Use imagemagick instead of graphicsmagick.
    - openoffice.org-help switch to internal copy of lucene.
    - Disable gnome-vfs support since it is buggy.
    - Correct diversions for broffice.org. (LP: #347144)
    - Drop Pre-Depends lzma. (LP: #353336)
    - Remove hicolor and locolor icons. (LP: #339590)
    - Remove qa packages. (LP: #89005)
    - Switch desktop files from %U to %F for gvfs fuse. (LP: #347209)
    - Update human icon theme. (LP: #348666)
  * Resynchronise with ooo-build-3-0-1 (1bfac2ec2a2557d3388330cf35c821a5876f86e9).
    - Add GSI for ca. (LP: #283772)
    - Add pyuno-python26.diff (LP: #346443)
    - Update GSI from linux.cz for be-BY, bg, et, ga, gd, nb, nn, ro, sk, sl.

 -- Chris Cheney <email address hidden> Mon, 06 Apr 2009 00:25:00 -0500

Changed in openoffice.org (Ubuntu):
status: Fix Committed → Fix Released
Adolfo Jayme (fitojb) on 2014-02-08
no longer affects: human-icon-theme (Ubuntu)

Reset assigne to the default "<email address hidden>".

Changed in openoffice:
importance: Unknown → Low
status: Confirmed → Unknown
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.