Crash when trying to insert sound

Bug #3343 reported by Joel Montes de Oca on 2005-10-19
6
Affects Status Importance Assigned to Milestone
openoffice.org (Ubuntu)
Medium
Matthias Klose

Bug Description

openoffice.org2 crashes when I:
o Click "Gallery"
o Select "Sounds" from the gallery list
o Drag a sound clip from the selection into my document.

openoffice creashes after I drag a sound clip into my document.

Some more complete steps for people trying to reproduce this:
1. Start oowriter2 .
2. Go to Tools -> Gallery and ensure it is ticked. A mini window will appear above the document page.
3. On the left of the new window choose sounds.
4. Drag the top left hand sound clip (apert.wav) from the new window to the main document.

Expected results:
Icon representing sound to appear in main window?

Actual results:
After dragging the cursor does not change back to normal and the window will freeze. CPU usage will rise and eventually oowriter will close itself and print the following on the console:
/usr/lib/openoffice2/program/soffice: line 224: 7922 Segmentation fault "$sd_prog/$sd_binary" "$@"

Additional information:
The crash does not happen in OpenSUSE 10 (OpenOffice_org-1.9.125-6). On OpenSUSE when an the icon with notes is double clicked a warning about a JRE not being installed is displayed. On Ubuntu a small media player window appears (but I have GCJ installed thanks to eclipse).

Changed in openoffice.org2:
assignee: nobody → doko
Paul Dufresne (paulduf) wrote :

Hi, I was able this bug on my machine.

Using Breedy, with openoffice

paul@Arcturus:~$ dpkg -l openoffice.org2*|grep ^ii
ii openoffice.org2 1.9.129-0.1ubuntu4 OpenOffice.org Office suite version 2.0
ii openoffice.org2-base 1.9.129-0.1ubuntu4 OpenOffice.org office suite - database
ii openoffice.org2-calc 1.9.129-0.1ubuntu4 OpenOffice.org office suite - spreadsheet
ii openoffice.org2-common 1.9.129-0.1ubuntu4 OpenOffice.org office suite architecture ind
ii openoffice.org2-core 1.9.129-0.1ubuntu4 OpenOffice.org office suite architecture dep
ii openoffice.org2-draw 1.9.129-0.1ubuntu4 OpenOffice.org office suite - drawing
ii openoffice.org2-evolution 1.9.129-0.1ubuntu4 Evolution Addressbook support for OpenOffice
ii openoffice.org2-gnome 1.9.129-0.1ubuntu4 GNOME Integration for OpenOffice.org (Widget
ii openoffice.org2-impress 1.9.129-0.1ubuntu4 OpenOffice.org office suite - presentation
ii openoffice.org2-java-common 1.9.129-0.1ubuntu4 OpenOffice.org office suite Java support arc
ii openoffice.org2-l10n-en-us 1.9.129-0.1ubuntu4 English_american language package for OpenOf
ii openoffice.org2-math 1.9.129-0.1ubuntu4 OpenOffice.org office suite - equation edito
ii openoffice.org2-writer 1.9.129-0.1ubuntu4 OpenOffice.org office suite - word processor
paul@Arcturus:~$

Now this really seems to be related to
JRE, because if I go to tools/options/openoffice.org/Java
and that I unchecked "Use a Java
runtime environment" then I am able
to continue editing my document after
trying to drag&drop the sound (but
no icon for the sound).

Not that this window list my JRE as:
Free Software Foundation 1.4.2

Changed in openoffice.org2:
status: Unconfirmed → Confirmed
Matthias Klose (doko) wrote :

confirmed with 2.0.2, no crash anymore. sound currently doesn't work.

See #34447 as well.

Matthias Klose (doko) wrote :

no crash in 2.0.2-1ubuntu3

Changed in openoffice.org2:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers