[upstream] impress hangs on importing ppt

Bug #332648 reported by Arno Peters on 2009-02-21
4
Affects Status Importance Assigned to Milestone
OpenOffice
Confirmed
Unknown
openoffice.org (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: openoffice.org

Open the attached ppt
Openoffice / impress hangs

I am using Openoffice.org version 3.0 from ppa on an otherwise vanilla Ubuntu Intrepid

Architecture: i386
Version: 1:3.0.1-1ubuntu1~intrepid1

a full backtrace of the runaway process:

(gdb) where
#0 0xb660b907 in ?? ()
   from /usr/lib/openoffice/program/../basis-link/program/libsotli.so
#1 0xb6611124 in ?? ()
   from /usr/lib/openoffice/program/../basis-link/program/libsotli.so
#2 0xb6605655 in ?? ()
   from /usr/lib/openoffice/program/../basis-link/program/libsotli.so
#3 0xb66182fa in SotStorageStream::GetData ()
   from /usr/lib/openoffice/program/../basis-link/program/libsotli.so
#4 0xb6e44155 in SvStream::Read ()
   from /usr/lib/openoffice/program/../basis-link/program/libtlli.so
#5 0xb6e44716 in SvStream::operator>> ()
   from /usr/lib/openoffice/program/../basis-link/program/libtlli.so
#6 0xb21d7387 in operator>> ()
   from /usr/lib/openoffice/program/../basis-link/program/libsvxli.so
#7 0xb21dc311 in DffRecordManager::Consume ()
   from /usr/lib/openoffice/program/../basis-link/program/libsvxli.so
#8 0xb1ad2cc8 in SdrPowerPointImport::SdrPowerPointImport ()
   from /usr/lib/openoffice/program/../basis-link/program/libsvxli.so
#9 0xb0491bc6 in ?? ()
   from /usr/lib/openoffice/program/../basis-link/program/libsdli.so
#10 0xb049219a in ?? ()
   from /usr/lib/openoffice/program/../basis-link/program/libsdli.so
#11 0xb049f3c2 in ?? ()
   from /usr/lib/openoffice/program/../basis-link/program/libsdli.so
#12 0xb03bbb4f in sd::DrawDocShell::ConvertFrom ()
   from /usr/lib/openoffice/program/../basis-link/program/libsdli.so
#13 0xb7760587 in SfxObjectShell::DoLoad ()
   from /usr/lib/openoffice/program/../basis-link/program/libsfxli.so
#14 0xb77ac81f in SfxBaseModel::load ()
   from /usr/lib/openoffice/program/../basis-link/program/libsfxli.so
#15 0xb77ffcf5 in ?? ()
   from /usr/lib/openoffice/program/../basis-link/program/libsfxli.so
#16 0xb2b28806 in ?? ()
   from /usr/lib/openoffice/program/../basis-link/program/libfwkli.so
#17 0xb2b29100 in ?? ()
   from /usr/lib/openoffice/program/../basis-link/program/libfwkli.so
#18 0xb2b1cc42 in ?? ()
   from /usr/lib/openoffice/program/../basis-link/program/libfwkli.so
#19 0xb2b1d281 in ?? ()
   from /usr/lib/openoffice/program/../basis-link/program/libfwkli.so
#20 0xb7b3a041 in comphelper::SynchronousDispatch::dispatch ()
   from /usr/lib/openoffice/program/../basis-link/program/libcomphelp4gcc3.so
#21 0xb7ee1605 in ?? ()
   from /usr/lib/openoffice/program/../basis-link/program/libsofficeapp.so
#22 0xb7ef52b8 in ?? ()
   from /usr/lib/openoffice/program/../basis-link/program/libsofficeapp.so
#23 0xb7ecd34e in ?? ()
   from /usr/lib/openoffice/program/../basis-link/program/libsofficeapp.so
#24 0xb7eceabd in ?? ()
   from /usr/lib/openoffice/program/../basis-link/program/libsofficeapp.so
#25 0xb7ecebd4 in ?? ()
   from /usr/lib/openoffice/program/../basis-link/program/libsofficeapp.so
#26 0xb6bdd2e9 in ?? ()
   from /usr/lib/openoffice/program/../basis-link/program/libvclli.so
#27 0xb4b243f7 in SalDisplay::DispatchInternalEvent ()
   from /usr/lib/openoffice/basis3.0/program/libvclplug_genli.so
#28 0xb4f4a90a in ?? ()
   from /usr/lib/openoffice/basis3.0/program/libvclplug_gtkli.so
#29 0xb51a57c1 in ?? () from /usr/lib/libglib-2.0.so.0
#30 0xb51a76f8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#31 0xb51aada3 in ?? () from /usr/lib/libglib-2.0.so.0
#32 0xb51aaf61 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#33 0xb4f4aa98 in ?? ()
   from /usr/lib/openoffice/basis3.0/program/libvclplug_gtkli.so
#34 0xb4b2c087 in X11SalInstance::Yield ()
   from /usr/lib/openoffice/basis3.0/program/libvclplug_genli.so
#35 0xb69db5c9 in Application::Yield ()
   from /usr/lib/openoffice/program/../basis-link/program/libvclli.so
#36 0xb69db64c in Application::Execute ()
   from /usr/lib/openoffice/program/../basis-link/program/libvclli.so
#37 0xb7ec75aa in ?? ()
   from /usr/lib/openoffice/program/../basis-link/program/libsofficeapp.so
#38 0xb69e02b8 in ?? ()
   from /usr/lib/openoffice/program/../basis-link/program/libvclli.so
#39 0xb69e0355 in SVMain ()
   from /usr/lib/openoffice/program/../basis-link/program/libvclli.so
#40 0xb7f0018c in soffice_main ()
   from /usr/lib/openoffice/program/../basis-link/program/libsofficeapp.so
#41 0x08048d6c in main ()

Arno Peters (awpeters) wrote :
JanBrinkmann (jbrinkmann) wrote :

Thank you for taking the time to report this bug and trying to help make Ubuntu better. However, it seems that you are not using a software package provided by the official Ubuntu repositories. Because of this the Ubuntu project can not support or fix your particular bug. Please report this bug to the provider of the software package. Thanks!

If you are interested in learning more about software repositories and Ubuntu the following pages should be informative:

1. http://www.ubuntu.com/community/ubuntustory/components - information about Ubuntu repositories
2. https://help.ubuntu.com/community/Repositories - information regarding managing repositories

Thanks once again for pointing us to the error. However, you should talk to the owner of the PPA to get that fixed.

Changed in openoffice.org:
status: New → Invalid
Chris Cheney (ccheney) wrote :

JanBrinkmann,

In the future please do not close bugs invalid filed against openoffice-pkgs ppa packages. They are produced by the Ubuntu OOo maintainer (me) for testing purposes, precisely to get bug reports filed, and if you had actually looked at this bug under Jaunty, instead of just closing it immediately, you would have seen that this is a valid bug in Ubuntu, not just in the ppa. I agree that bugs just affecting the ppa would not be particularly useful to keep open, but so far I have not seen any bugs like that, bugs that have affected the ppa also affect 3.0.1 in Jaunty and not everyone can run a bleeding edge distro, but having them test the current OOo packages helps immensely in getting bugs fixed before the next release.

All of the above said, I would like to sincerely thank you for helping to triage OOo bugs as it is big task to keep up with.

Thanks,

Chris

Changed in openoffice.org:
importance: Undecided → Medium
status: Invalid → Triaged
Chris Cheney (ccheney) wrote :

Verified issue an upstream official OOo bug and it will likely be corrected by upstream in the next release.

Changed in openoffice:
status: Unknown → Confirmed
JanBrinkmann (jbrinkmann) wrote :

Ok Chris Cheney, thank you very much for your feedback! I'm still new to Bug Triaging but doing the best job I can. I'll keep that in mind for the future!

Robert Roth (evfool) wrote :

I have tested this bug on Maverick, using OpenOffice.org 3.2.1-7ubuntu1, and now the PPT attached above gives me an error dialog with the text: "Move background page assignment. The loading of
password-encrypted Microsoft PowerPoint presentations is not supported."

Could anyone elso confirm that the behaviour reported in this bug has changed?

Arno Peters (awpeters) wrote :

I can confirm the behaviour has changed as Robert reported.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.