[upstream] [3.1.1] OO 3.0 writer - tables corrupted

Bug #330366 reported by studavis on 2009-02-17
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
OpenOffice
Fix Released
Unknown
openoffice.org (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: openoffice.org

Creating a Table and saving the file as odt works fine. When I then save it as a doc file, the table is always corrupted. Usually column width changes.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 8.10
NonfreeKernelModules: ath_hal
Package: openoffice.org-core 1:3.0.1-1ubuntu1~intrepid1
ProcEnviron:
 PATH=/usr/lib/openoffice/program:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: openoffice.org
Uname: Linux 2.6.27-12-generic i686
UnreportableReason: This is not a genuine Ubuntu package

Chris Cheney (ccheney) wrote :

I can't reproduce this problem. Can you please attach an example document (odt) that exhibits this problem saving to doc?

Changed in openoffice.org:
status: New → Incomplete

Attached is an odt file with a simple table. In the previous post I attached (Table Test.doc) is the result of saving and re-opening as a doc file. This time the table has disappeared completely. I have alos just filed a report using table and powerpoint. Saving as a ppt file, then opening in Powerpoint 2003 corrupts the file. Makes sharing file with Windows users impossible. (Something I have do do all the time, we send fiels around for comment and editing so can't pdf them).

Thanks

I tried this process again and I think I have narrowed it down. I made a simple table in odt and successively edited/saved/closed it as a doc. Each time adding colors, bullets, rows etc. 7 times in all. All was okay. On the 8th time I centered the table (Using Table Properties) - when I re-opened , it had disappear altogether. See attached doc. This may help narrow down the issue.

I sent a couple of files via launchpad, hope u got them.

I've messed about a bit with this. Any table that has been created and
then moved (using Table properties) and then saved in OO as a doc;
closed it and open it, the table has disappeared. Pretty serious bug I
would think.

-----Original Message-----
From: Chris Cheney <email address hidden>
Reply-to: Bug 330366 <email address hidden>
To: <email address hidden>
Subject: [Bug 330366] Re: OO 3.0 writer - tables corrupted
Date: Sat, 21 Feb 2009 03:08:16 -0000

I can't reproduce this problem. Can you please attach an example
document (odt) that exhibits this problem saving to doc?

** Changed in: openoffice.org (Ubuntu)
       Status: New => Incomplete

Just wondering about this bug report, it shows up in Launchpad as
incomplete, I did send a couple of files which demonstrated the problem.
Anything else I can help with.

This is really stopping me using OO writer, the other day I edited our
Montlhy report (we each add our comments and pass it on), when it got
back to my boss, the tables had all disappeared... Most embarrasing. I'd
hate to have to go back to Windows but this issue makes using OO in the
real world just impossible.

cheers

-----Original Message-----
From: Chris Cheney <email address hidden>
Reply-to: Bug 330366 <email address hidden>
To: <email address hidden>
Subject: [Bug 330366] Re: OO 3.0 writer - tables corrupted
Date: Sat, 21 Feb 2009 03:08:16 -0000

I can't reproduce this problem. Can you please attach an example
document (odt) that exhibits this problem saving to doc?

** Changed in: openoffice.org (Ubuntu)
       Status: New => Incomplete

Chris Cheney (ccheney) on 2009-03-13
Changed in openoffice.org:
status: Incomplete → New

Verified on official openoffice.org 3.0.1 need to send upstream.

Changed in openoffice.org (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
summary: - OO 3.0 writer - tables corrupted
+ [upstream] OO 3.0 writer - tables corrupted
Chris Cheney (ccheney) on 2009-03-21
Changed in openoffice:
importance: Undecided → Unknown
status: New → Unknown
Changed in openoffice:
status: Unknown → Confirmed
Chris Cheney (ccheney) on 2009-03-23
Changed in openoffice:
status: Confirmed → Unknown
Changed in openoffice:
status: Unknown → Fix Released

There seems to be no coments for a month, so I thought it would be good to emphasize this - it's a *showstopper* for the whole distribution in a business enviroment.

It is unacceptable for an office suite to behave in such a manner - Linux still hasn't conquered the business world and files need to be exchanged with m$ office users. If we want any uptake in business use bugs like this need to never happen, ever!

But it is happening, and still no fix. If we cannot wait for upstream to fix it and/or backport a fix, then package OpenOffice 2.4 and give users the option to downgrade... or better yet, make 2.4 the default and if someone lives on an island and doesn't need to create doc files he can install 3.0.1 in it's current state...

Thanks for trying to move this forward, we need to get the basic right
before tackling the business world. 90% of users use 25% of Word
functionality (a guess but I'm sure it's true!). If we can get that 25%
working well thats all we can ask!

cheers

Best Regards

Stuart Davis

icarus wrote:
> There seems to be no coments for a month, so I thought it would be good
> to emphasize this - it's a *showstopper* for the whole distribution in a
> business enviroment.
>
> It is unacceptable for an office suite to behave in such a manner -
> Linux still hasn't conquered the business world and files need to be
> exchanged with m$ office users. If we want any uptake in business use
> bugs like this need to never happen, ever!
>
> But it is happening, and still no fix. If we cannot wait for upstream to
> fix it and/or backport a fix, then package OpenOffice 2.4 and give users
> the option to downgrade... or better yet, make 2.4 the default and if
> someone lives on an island and doesn't need to create doc files he can
> install 3.0.1 in it's current state...
>
>

We have the same basic issue but slightly different context - a Word 2003 document with tables, edited in OO3 then saved in Word 2003 format leads to:

users of Word 2003 can see the edited content
the OO3 editor/user can re-open the edited document and sees the edited content
BUT
OO2.4 users see that the tables are present but empty

If the OO3 editor/user saves the document in odt format, OO2.4 users CAN see table contents.

I am attaching a sample document - initially created in Word 2003, edited in OO3 and saved as Word 2003 doc format.

Additionally, on opening the OO3 .doc edited document in Abiword 2.4.6 the table content was visible. Saving from Abiword as Word 2003 format, then opening this saved version in OO2.4 - voila, the table content is visible.

GaryProsser (gary-prosser) wrote :

Correction to above posting - the attached file is incorrect. The correct example is attached with this post.

Peter Petkovic (petkovic) wrote :

I have encountered the same bug. I created a document containing a table in OpenOffice Writer 3.0.1 and saved it as Microsoft XP format. Microsoft Word opens the file reporting an error stating "A table in this document has become corrupted ...". The file is displayed with the text intact but with non-characters in between where, presumably, the table elements are supposed to be. This is a very serious bug for OpenOffice Writer - renders it pretty much useless for me.

The attached file is a table with several rows and columns which causes this failure. Most of the cell text has been deleted.

Jpocreva (jpocreva) wrote :

I disagree with Studavis This bug is a big problem. It may be true that users only use 25% of word functionality but almost all use this functionality. I recall it working in the previous version of OO and it was broken in 3.0

I vote that this gets a high priority because I to cannot use OO Write as long as this bug exists. If you need I can provide you with a highly reproducible test case.

Chris Cheney (ccheney) on 2009-08-07
summary: - [upstream] [3.1] OO 3.0 writer - tables corrupted
+ [upstream] [3.1.1] OO 3.0 writer - tables corrupted
Changed in openoffice.org (Ubuntu):
assignee: nobody → Chris Cheney (ccheney)
milestone: none → karmic-alpha-6
Chris Cheney (ccheney) on 2009-09-15
Changed in openoffice.org (Ubuntu):
assignee: Chris Cheney (ccheney) → nobody
milestone: karmic-alpha-6 → none
status: Triaged → Fix Released
joeclarkia (joeclark) wrote :

Will this fix be backported to Jaunty?

I've not logged in for a while, I do agree with Jpocreva, it is a serious problem, I was trying to say (not very well!) that OO just needs to get the basics right first, and in fact tables are a very basic part of a word processor.

On a positive side, I've installed OO 3.1.1 (direct from OO site) and first tests to appear to be okay. Will check it out more and report if I have time. Now we need to look at tables in OO impress which are also very twitchy and make it pretty unusable. (I end up pasting in from Calc as a bitmap).

Chris Cheney (ccheney) wrote :

joeclarkia,

Feel free to use the ppa at https://launchpad.net/~openoffice-pkgs/+archive/ppa for Jaunty or upgrade to Ubuntu Karmic when it is released next month.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.