No suggestions from spell checker if two are installed (OpenMedSpel)

Bug #329968 reported by Jonathan Blackhall on 2009-02-16
66
This bug affects 11 people
Affects Status Importance Assigned to Milestone
LibreOffice
Incomplete
Undecided
Unassigned
OpenOffice
Fix Released
Unknown
libreoffice (Ubuntu)
Undecided
Unassigned
Nominated for Jaunty by der_vegi
Nominated for Karmic by Jonathan Blackhall
openoffice.org (Ubuntu)
Low
Unassigned
Nominated for Jaunty by der_vegi
Nominated for Karmic by Jonathan Blackhall

Bug Description

Binary package hint: openoffice.org

I am attempting to install the OpenMedSpel plugin (an extension that adds a medical terms dictionary to OO.o 3.0) from http://extensions.services.openoffice.org/project/OMS . Installing the extension disables the normal English dictionary on OO.o 3.0 on Ubuntu 8.10 64-bit from https://launchpad.net/~openoffice-pkgs/+archive/ppa . Once the package is installed and OO.o is restarted, all normal English words are marked as misspelled. Only medical jargon like "reticulocyte" is considered spelled correctly. Uninstalling the plugin fixes the problem. I've contacted the plugin author, and he told me that this is not the case in WinXP. I am not able to check in Jaunty since my VirtualBox network connection is not working (https://bugs.launchpad.net/ubuntu/+bug/326003)

Is there any additional info you might need or any suggestions you can recommend?

This is also seen in OO.o 3.0.1 on Ubuntu Jaunty.

This extension works correctly on a stock install of OO.o 3.0.1 downloaded from the openoffice.org website on Ubuntu Intrepid. There must be some sort of issue with the way Ubuntu's version of OpenOffice is handling it.

Chris Cheney (ccheney) wrote :

This works fine on the 3.0.1-1ubuntu2 in Jaunty, the version in the ppa will be updated sometime soon.

Changed in openoffice.org:
status: New → Fix Released

Hi Chris,
I'm afraid I'm still seeing this bug on a fresh install of Jaunty Alpha 5 (32-bit). I'm attaching a screenshot after installing OpenMedSpel. The problem isn't that the extension isn't working (it is). The problem is that it's preventing the normal dictionary from working. Like I said, the extension works correctly if you install the OO.o 3.0.1 from http://www.openoffice.org , meaning the both dictionaries work simultaneously. Simply uninstalling the OMS plugin "fixes" the problem (finds regular words spelled correctly).

Please let me know if there is more information I can provide.

Changed in openoffice.org:
status: Fix Released → Incomplete
Chris Cheney (ccheney) wrote :

Jonathan,

So do you see this on Ubuntu Jaunty 64bit as well or just on 32bit? It definitely works for me on Jaunty 64bit, I can test 32bit but would take some time to setup.

Thanks,

Chris

I can test that and get back to you. I just did a fresh install of 32-bit
on VirtualBox, and I tested it. I'm downloading 64-bit now to install in
VirtualBox. I'll let you know what I find.

I am still seeing this in 64-bit as well. Again, it's a clean Jaunty Alpha
5 install and only this extension installed.

Does installing the 'openoffice.org' package help any with this issue? It pulls in the rest of openoffice.org, along with the java support packages, so if the dictionary support needs some other files for some reason it might help.

Chris

No, installing the openoffice.org package (and the packages that get pulled
along with it), did not help.

Coming from bug 335514 I'd like to add that I'm seeing exactly the same behaviour as the OP for the *German* medical dictionary (packaged for ubuntu as hunspell-de-med). It therefore seems to be something more general when having more than one dictionary for a language and not a problem specific to the OpenMedSpel plugin.
I'm on an up-to-date jaunty, 32bit with openoffice.org package installed (more infos in my comments for bug 335514).

As it really seems to me it is the same bug, I attach a odt file with German text. If both hunspell-de-de and hunspell-de-med are installed, almost all words are marked as incorrect and corrections from the medical dictionary are suggested.

Chris Cheney (ccheney) on 2009-03-06
Changed in openoffice.org:
status: Incomplete → Confirmed
Chris Cheney (ccheney) wrote :

Marcel Stimberg,

I still don't see this issue with Jaunty amd64 (64bit) with openoffice.org 1:3.0.1-7ubuntu1 I installed both of the dictionaries you mentioned and loaded your document and then took a screenshot to show you. There are only a couple words highlighted as misspelled and I don't think those are due to the error we are discussing.

Chris

Chris Cheney (ccheney) on 2009-03-21
Changed in openoffice.org (Ubuntu):
status: Confirmed → Incomplete

Hi Chris,
I do indeed still still see the same behaviour as before (on i686), your screenshot looks very different from mine. What information on my configuration could I provide that might help? As I said in the previous bug report, my installation is not a clean one but one upgraded from intrepid. But I moved the ~/.openoffice.org dir and reinstalled both openoffice and the hunspell dicts, no change...
My openoffice is the same version as yours: openoffice.org/jaunty uptodate 1:3.0.1-7ubuntu1

Chris Cheney (ccheney) wrote :

All I have done that I know of that might cause a difference is the following:

I have 'openoffice.org' meta package installed
I am using openjdk-6-jre for Java
I have a clean ~/.openoffice.org (I regularly delete ~/.openoffice.org* due to testing things)
Running current Jaunty amd64 with openoffice.org 1:3.0.1-7ubuntu1

I have the meta package installed, I am using the same java (used sun java before, but uninstalling it and using openjdk makes no difference), and also remove ~/.openoffice.org - the only difference is that I'm using i686 not amd64. But it seems that the OP tried it also under 64 Bit (BTW: I can reproduce his problem as well).
I tried to verify the OP's claim that it works with the original openoffice package, but those packages crash for me on startup :-/

Hi again,
I checked and the bug seems to be easily reproducible with a live CD (I used http://cdimages.ubuntu.com/daily-live/20090329/jaunty-desktop-i386.iso ):
Boot, start openoffice and edit a text in English -> spellchecking works fine
Install OpenMedSpell extension (see link above) and restart openoffice -> spellchecking flags all words as incorrect.
Same for German (install language pack first) and installing hunspell-de-med (from universe).
It therefore seems to have nothing to do Jonathan's or my install...

Chris Cheney (ccheney) wrote :

I just tested using the Ubuntu amd64 desktop live beta cd here:

http://releases.ubuntu.com/9.04/ubuntu-9.04-beta-desktop-amd64.iso

And typed in the sentence in this screenshot and it showed fine for all words:

http://launchpadlibrarian.net/23282749/Screenshot.png

I'll try downloading the i386 version to see if it makes a difference.

The only thing I did on the desktop live cd was download and install the OMS extension from this site:

http://extensions.services.openoffice.org/project/OMS

Chris Cheney (ccheney) wrote :

Ok... I still can't reproduce this with the 9.04 i386 Beta CD:

http://releases.ubuntu.com/9.04/ubuntu-9.04-beta-desktop-i386.iso

The only thing I did on the desktop live cd (after selecting English at boot) was download and install the OMS extension from this site:

http://extensions.services.openoffice.org/project/OMS

And then typed in the sentence in this screenshot (from the original bug reporter) and it showed fine for all words:

http://launchpadlibrarian.net/23282749/Screenshot.png

I'm at a loss at how you are seeing this even inside the live cd environment...

Can you tell the EXACT steps from power on (including live cd options you used) to make this show up with underlined words?

Thanks,

Chris Cheney

>
> Ok... I still can't reproduce this with the 9.04 i386 Beta CD:
>
I will check when I get home. I haven't tested it recently, so maybe
something underlying has been fixed. I just did a fresh install of the
64-bit beta last night on my desktop, so I'll try there and with the 64-bit
live cd.

Hi Chris,
This is interesting. On my fairly fresh install of Ubuntu restricted extras, I get the same behavior as previously (normal words spelled incorrectly). However installing OMS on the live cd does make it work correctly. I'm not sure how that's possible. I did install "restricted extras" yesterday on this desktop. Could Sun's JRE have anything to do with it? I "Completely removed" sun-java6-bin and sun-java6-jre, and that didn't help. I also "Completely removed" all dependencies of openjdk stuff: ca-certificates-java, icedtea-6-jre-cacao, icedtea-6-plugin, libaccess-bridge-java, openjdk-6-jre, openjdk-6-jre-headless, and openjdk-6-jre-lib. That didn't help either.

I'm not 100% sure, but my thought is that if I did another fresh install of Jaunty, I would have the same problem. Is there a difference between the live-cd's OO.o and one after a fresh install? I've never tried installing directly in the live cd before, only in a fresh install. That seems to be the differentiating factor for me at this point. If you'd like me to try a true fresh install (without any additional packages) of 64-bit Jaunty on my desktop, I can.

Sorry, it's late, and my last post didn't make much sense. I should proofread. "On my fairly fresh install of Ubuntu (only with restricted extras installed)"
Also, to clarify, I tried 2 different things:
1. Installed OMS in the live-cd environment. It worked correctly.
2. Installed OMS on a freshly installed Jaunty beta system (but it did have Ubuntu restricted extras installed). It did not work. Neither did removing the java packages listed above.

Like I said, I don't *think* re-installing and trying OMS before installing *any* packages would make a difference, but if you'd like me to try, I can.

Chris Cheney (ccheney) wrote :

Installing Jaunty without anything else installed (eg nothing at all that isn't already on the cd) should be essentially identical to running off the live cd. For what its worth none of my systems have ubuntu-restricted-extras installed so it very well could be that package causing the problem.

Chris

Hi again,
I did more tests with the live-cd (http://releases.ubuntu.com/9.04/ubuntu-9.04-beta-desktop-i386.iso) and could at first not reproduce it anymore, than I could and after restarting I again could not :-/
The German dictionary issue is easier to reproduce and it actually somehow triggers the openmedspell bug as well. Ok, here the exact steps with which I can reproduce both problems:
1. boot live cd (chose English but does not seem to make a difference)
2. activate universe repos (I used Software Sources from the systems menu), update sources
3. "sudo apt-get install hunspell-de-med" in a terminal (installs hunspell-de-de, too)
4. go to http://extensions.services.openoffice.org/project/OMS with firefox, open the .oxt with openoffice

Now you should see the issue for English text and if you change the text language to German you see it for German.

Some more observations:
* After the steps described above, removing hunspell-de-med of course removes the issue for the German text, but it remains for the English text. However, removing hunspell-de-de seems to make the English issue go away...

Hope this allows reproducing the bug for you...

Still on the live cd I noticed something even stranger now:
I removed hunspell-en-us (but have hunspell-de-de installed), thereby removing language-support, and logout and login. Now, openoffice still claims to have spellcheck for English (USA) by showing the spellcheck icon next to the language, BUT it apparently uses the German spellchecker now, even if the language is set to English (USA). When started with strace, it seems that it is actually accessing the Luxembourgian variant of the German dictionary (de-LU.dic and .aff which are only symlinks to de_DE), leaving me even more clueless ;-)

Chris Cheney (ccheney) wrote :

Ok, I was able to duplicate this issue following your instructions, it looks like OOo for some reason thinks the OpenMedSpel dictionary is the only en-US dictionary after it is installed. I am not sure if this is a bug in OpenMedSpel oxt or in OOo itself as the README file inside the oxt says to install the dictionaries in such a way as it would not override the en-US dictionary, but the oxt xml file doesn't seem to do this.

Changed in openoffice.org (Ubuntu):
status: Incomplete → Triaged
Chris Cheney (ccheney) wrote :

Apparently the OpenMedSpel guys don't have any idea about how their installation is supposed to work under Linux...

"Thank you for the information. We do not use Ubuntu or any other form
of Linux on a regular basis, so I cannot really answer any questions.

The installation instructions for OpenMedSpel were developed for
installation on Windows, which may be a source of the problems."

I'll have to see if this is an OOo bug by reporting it upstream and seeing it they yell. :-\

I'm glad to see you were able to reproduce the bug. I did further testing today. The OMS plugin continues to work fine under a Live-CD environment (Jaunty Beta 64-bit), however OMS does not work correctly on a fresh install of Jaunty Beta 64-bit (with nothing else installed). It seems that whatever differences in OO.o between the Live CD and the actual install must be causing the issue. Please let me know if I can provide any more information.

Chris Cheney (ccheney) wrote :

Jonathan it seems that all you have to do to make it happen on the live cd is do what Marcel mentioned earlier with installing hunspell-de-med.

> I'll have to see if this is an OOo bug by reporting it upstream and seeing it they yell. :-\

I hope they don't! Could you link that bug report here so I can follow it? Also, I did mention in the beginning of this bug report that OMS works fine on a stock install of OO.o from their official website (last I checked). So if there's a problem upstream, it's likely part of the go-oo.org stuff.

Chris Cheney (ccheney) wrote :

Jonathan,

Well what I am thinking might be causing the problem is that it might not be handling the case where OOo has both system dictionaries and extension dictionaries on the same install. If that is the case you wouldn't see it in the official build even though the official source code supports the feature.

Chris

This might be the same issue here: http://lingucomponent.openoffice.org/issues/show_bug.cgi?id=98644
May contact "tl"?
  Marcel

Chris Cheney (ccheney) wrote :

Yes this looks like it may be the issue we are seeing.

Changed in openoffice:
importance: Undecided → Unknown
status: New → Unknown
Changed in openoffice.org (Ubuntu):
importance: Undecided → Medium
summary: - OpenMedSpel Extension for OpenOffice.org 3.0 disables normal dictionary
+ No suggestions from spell checker if two are installed
+ (OpenMedSpel)Extension for OpenOffice.org 3.0 disables normal dictionary
summary: - No suggestions from spell checker if two are installed
- (OpenMedSpel)Extension for OpenOffice.org 3.0 disables normal dictionary
+ [upstream] No suggestions from spell checker if two are installed
+ (OpenMedSpel)
Changed in openoffice:
status: Unknown → Fix Released

If the fix doesn't make it into Jaunty in time, I would suggest to remove the dependency in language-support-extra-de, since every user installing the default German language support will be affected by this bug.

Chris Cheney (ccheney) wrote :

der_vegi,

I may be wrong but I don't think that package is installed by default even for German language as it is in universe and as far as I know no universe packages get installed by default. Also the only thing that package does at all as far as I can tell is depend on hunspell-de-med, so removing that dependency would be useless as the package would have no point at all anymore.

Chris

der_vegi (m-may) wrote :

Chris, I uninstalled hunspell-de-med, but then my German localisation was not complete any more when I checked over System -> ..., I was asked by gnome-language-selector to install language-support-extra-de again. Shall I file a bug report on gnome-language-selector?

Chris Cheney (ccheney) wrote :

Yes, you can but I am not sure if it is an issue with what you have selected in gnome-language-selector or some other issue.

Chris

summary: - [upstream] No suggestions from spell checker if two are installed
+ [upstream] [3.2] No suggestions from spell checker if two are installed
(OpenMedSpel)

Quick comment on that: language-selector is checking for
language-support-writing-LANGUAGE
language-support-translations-LANGUAGE
language-support-input-LANGUAGE
language-support-fonts-LANGUAGE
language-support-extra-LANGUAGE
to determine whether the support for LANGUAGE is fully installed.
  Marcel

Chris,
all language-support-extra-* packages are universe. As language-selector really checks for language-support-extra-*, I have filed the wishlist bug 363619 to remove hunspell-de-med from language-support-extra-de (which would make it obsolete) as temporary workaround. I guess a properly working ooo spell checker will make more users happy than an additional medical dictionary. ;)

der_vegi (m-may) wrote :

In the forum ubuntuusers.de there are more and more users reporting this problem on fresh installs of Jaunty in combination with German localisation.

LCID Fire (lcid-fire) wrote :

Had to remove hunspell-de-med today, too to get my german dict working again. Good that you guys already figured out a workaround.

Chris,
Is there a work around for OMS? Does the OOo fix in the linked bug report resolve my issue? If so, is it able to be pulled over?

Just FYI, I just upgraded to 3.1.0 from the PPA on Ubuntu 9.04 and this issue is still present.

der_vegi (m-may) wrote :

This bugs renders the OOo spell checker of _all_ people installing the normal german language support unusable so I would suggest to fix it in Jaunty.

I have the same issue in a regular Kubuntu Jaunty 9.04 system. I'm using a standard Kubuntu Jaunty install CD.

The command "sudo dpkg -s openoffice.org-writer" shows that I'm using right now version 3.0.1-9ubuntu3

When the system came out in April I did a regular fresh system install in a new HDD and it worked flawlessly. However three days ago the root system crashed (with ext4) and I had to format it and then did a complete reinstall (I had all my previous data in separate partitions). I installed in addition to the whole Spanish language packages (main system language), the complete English and German language packages.

After the installation I loaded a previous work in Writer (the document was in German) and it showed the same issues discussed here. I removed the hunspell-de-med package and the system removed automatically the language-support-extra-de package along with the hunspell one.

It seems that this "repaired" the problem with the German language, but when I load an document in English, the spell checker suggest even German words mixed with English ones. I tried unloading completely the Openoffice and loading it again, and the problem persist. This problem seemed not affecting the Spanish spell checker though.

I would gladly give additional information to help solve this problem, if it's needed.

Thank you very much in advanced for any help given with this issue.

Just tried out the Karmic beta. This is still an issue.

Still an issue in Karmic release

Still an issue in up-to-date Lucid Beta 1 with OO.o 3.2 installed :-/

Confirming for current Lucid - both 64bit and 32bit. Same problem for hunspell-de-med as well - although it is much less visible for "normal" users now: Instead of the standard German dictionary, now the medical dictionary is ignored :-/

Per upstream bug report, it looks like this should have been fixed in 3.2. Apparently not, though. Is there any more information I can provide or anything else I can do to help this bug report along? I still think (as I stated previously) that this issue has something to do with go-oo, because (at least when I had tried previously), I had no problems last year installing OMS on the version downloaded from http://download.openoffice.org .

@Marcel: That's interesting that the behavior changed for you. It's still behaving the same for me as in the original report.

Jesse Rimshas (jesse-rimshas) wrote :

There is a workaround. I'll post it in Ubuntu Forums and Linux Mint forums (since that's my distro of choice).

This method has only been tested under Linux Mint 8 Helena, but should work with Ubuntu Karmic and other Ubuntu and Mint releases as well. I used it for US English, but there's no reason you can't use it in your standard dictionary language of choice.

1. Download OpenMedSpel's txt and csv file in .zip format by visiting http://www.e-medtools.com/openmedspel.html and clicking on the link at the bottom of the page (or download directly from this link: http://www.e-medtools.com/openmedspel100.zip)

2. Extract the files from the archive. Open en_US_OpenMedSpel.aff with gedit. Use Cntrl+A to highlight all of the text, and Cntrl+C to copy it to the clipboard.

3. Backup the original dictionary. You can do this by renaming /usr/share/dict/american-english to american-english.bac to the filename. You will need root privileges. Then open the file you just renamed, as root, and save it as american-english.

4. Paste the the contents you copied into the file. Now the file isn't alphabetized, but that shouldn't matter. Save the file and exit.

5. Test your new dictionary by opening OpenOffice writer and typing "Zophran." Then right-click on the word. It should offer you "Zofran."

Jesse Rimshas (jesse-rimshas) wrote :

Oops, I gave you the wrong file name. You want to open OpenMedSpel 100.txt and copy the contents. Sorry about that.

Jesse Rimshas (jesse-rimshas) wrote :

Arg, no joy. It was medspel messing with my head. Bad fix. No good. Carry on.

Jesse Rimshas (jesse-rimshas) wrote :

Okay, FWIW I must sheepishly report that I did find a workaround for OpenMedSpel, at least. Changing my language (Tools-->Languages-->All Text) from English, American to English, Canadian allows me to use the Canadian dictionary and OpenMedSpel dictionary at the same time. So far it appears to be working fine. Perhaps the American English dictionary is somehow corrupt?

I'm running Linux Mint 8 on an eeepc 1005 with OpenOffice.org 3.1.1

I got the solution from Hagar of Ubuntu Forums, although editing Dictionaries.xcu didn't work for me--I had to use the menus in OpenOffice: http://ohioloco.ubuntuforums.org/showthread.php?p=9318343#post9318343

I hope that helps.

Jonathan Blackhall, please execute the following command, as it will automatically gather debugging information, in a terminal:
apport-collect 329968
When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

Does LibreOffice work for you? If using Lucid or Maverick feel free to perform at the Terminal:

sudo add-apt-repository ppa:libreoffice/ppa && sudo apt-get update && sudo apt-get -y upgrade && sudo apt-get -y install libreoffice-writer

Changed in openoffice.org (Ubuntu):
importance: Medium → Low
status: Triaged → Incomplete
Changed in libreoffice (Ubuntu):
status: New → Incomplete
Changed in openoffice.org (Ubuntu):
status: Incomplete → Won't Fix

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

summary: - [upstream] [3.2] No suggestions from spell checker if two are installed
- (OpenMedSpel)
+ No suggestions from spell checker if two are installed (OpenMedSpel)
Changed in df-libreoffice:
status: New → Incomplete
Changed in libreoffice (Ubuntu):
status: Incomplete → Fix Released
status: Fix Released → Incomplete
Changed in libreoffice (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.