openoffice 3.01RC1 gives tons of Xerrors and crashes

Bug #318496 reported by Sergio Callegari on 2009-01-18
2
Affects Status Importance Assigned to Milestone
openoffice.org (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: openoffice.org

Hi,

I am running kubuntu intrepid with kde 4.1.3 and the openoffice ppa, as this is the only way you can get an updated openoffice (with pdfimport) in ubuntu.

Today I received a large update notification. Since there were many other things in, I did not really notice there was also openoffice 3.01RC1 in substitution for openoffice 3.0 and I let all of the upgrade through.

To bad.

Here openoffice 3.0.1RC1 is completely broken.

Gives out tons of X errors (BadRequest) and segfaults.

Specifically, it crashes on exit (all times) and on many other operations (pdf export).
I have tried it with and without the kde support package, no difference.

What is upsetting me is that the openoffice 3.0 package have been removed from the PPA, so it is impossible to go back.

Why??? Why removing packages /before/ getting feedback about the new ones?

Daniel Hollocher (chogydan) wrote :

that package is for testing, which is why it is in a ppa in the first place. Once the packagers are satisfied, it will be moved to intrepid-proposed for wider testing. Once the greater powers that be are satisfied, then it will be release in its final form in intrepid-backports.

danielhollocher wrote:
> *** This bug is a duplicate of bug 267376 ***
> https://bugs.launchpad.net/bugs/267376
>
> that package is for testing, which is why it is in a ppa in the first
> place. Once the packagers are satisfied, it will be moved to intrepid-
> proposed for wider testing. Once the greater powers that be are
> satisfied, then it will be release in its final form in intrepid-
> backports.
>
> ** This bug has been marked a duplicate of bug 267376
> [intrepid] Package OpenOffice.org 3.0 for Backports
>
>
That bug thread is huge! - but yes, I see that the bug being reported in
the end is about the fact that 3.0.1 RC1 is broken.

But that is not really my point. To me the bug is not that 3.0.1 RC1 is
broken. This, as you are saying, is perfectly understandable in a PPA.
The bug is that by proposing the package in the PPA, you really invite
the vast majority that is dissatisfied with the choice of shipping 2.4
with intrepid to try it (rather than installing the safer sun's deb
files for OOO 3.0.0) which is obviously a good thing. ... But then you
do not give them a chance to go back if something goes wrong.

Please, if possible before closing the bug, put back in place (or
somewhere) the former 3.0.0-6 packages. They will not interfere since
apt is smart enough to pick the most recent version and to allow users
to downgrade if necessary.

I have already saved my desktop with the former debs found in the apt
cache of another PC I have, and I have switched my friends' machines to
the Sun's debs for 3.0 ... but to many others, finding the 3.0.0-6
packages somewhere can be really be an important way to rescue a
troublesome upgrade.

Thanks!

--
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers