Ubuntu

Starting "Slide Show" caches pixmap data excessively, crashing thin clients

Reported by Jordan Erickson on 2009-01-09
6
Affects Status Importance Assigned to Milestone
OpenOffice
Invalid
Undecided
Unassigned
libreoffice (Ubuntu)
Undecided
Unassigned
openoffice.org (Ubuntu)
Low
Unassigned

Bug Description

+ Ubuntu 8.04.1 LTS
+ OpenOffice 1:2.4.1-1ubuntu2.1
+ LTSP Environment
----

Working in OpenOffice Impress/Presentation is fine until starting "Slide Show", which caches excessive amounts of pixmap data to thin-client memory. This is bad because thin clients generally have very little amount of RAM (64-128MB is typical), and when all of the RAM is exhausted by something like excessive pixmap memory usage, the session simply crashes outright, causing data loss.

Observe my pixmap usage (via 'xrestop') of ~5MB upon simply launching a 1-slide presentation file:
---
3e00000 50 84 1 160 62 5495K 5K 5501K 18330 POWER POINT - OpenOffice.org Impress
---

Now observe pixmap memory usage of ~52MB upon launching "Slide Show -> Slide Show":
---
3e00000 56 100 1 230 73 52767K 6K 52773K 18330 POWER POINT - OpenOffice.org Impress
---

A Jump of more than 50MB by simply launching the presentation slideshow shouldn't happen. Thank you for any help on this, the children at my schools will thank you!

Sincerely,
Jordan/Lns

Jordan Erickson (lns) wrote :
Changed in openoffice:
status: Unknown → Fix Released
Jordan Erickson (lns) wrote :

New issue filed with OOo as per their request

Changed in openoffice:
status: Fix Released → Unknown
Changed in openoffice:
status: Unknown → New
Changed in openoffice:
status: New → Confirmed
Chris Cheney (ccheney) on 2009-01-11
Changed in openoffice.org:
importance: Undecided → Medium
status: New → Triaged
Jordan Erickson (lns) wrote :

Is there anything we (Ubuntu) can do on our end to help this process move forward? I'm still having these issues at a number of my sites.

Jordan Erickson (lns) wrote :

I would strongly advise anyone experiencing these issues to please go to the upstream bug report in the OOo bug tracker, create an account if you do not have one, and comment on the bug stating that the issue affects you as well with as much detail as possible. Nothing seems to be happening upstream and this is a very important issue for schools as it effectively makes OOo Presentation useless in an LTSP environment. Help!

Jordan Erickson, does this issue occur for you with LibreOffice? If you export the presentation to PDF and open in Evince or Acrobat Reader in fullscreen to present, does the workaround your crash? What version of LTSP were/are you using? Crash not reproducible in non-LTSP environment via Ubuntu 11.04, LibreOffice Impress via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/315300/+attachment/436647/+files/POWER%20POINT.odp && loimpress -nologo POWER\ POINT.odp

F5 -> spacebar -> no crash.

lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        500 http://us.archive.ubuntu.com/ubuntu/ natty-proposed/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

Changed in libreoffice (Ubuntu):
status: New → Incomplete
summary: - Starting "Slide Show" caches pixmap data excessively, crashing thin
- clients
+ [Upstream] Starting "Slide Show" caches pixmap data excessively,
+ crashing thin clients

Jordan Erickson, please execute the following command, as it will automatically gather debugging information, in a terminal:
apport-collect 315300
When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

Changed in openoffice.org (Ubuntu):
importance: Medium → Low
status: Triaged → Incomplete
Jordan Erickson (lns) wrote :

Sorry guys, after 2.5 years and no movement on this, we had long since given up. The schools have reverted back to Windows computers in their labs because of issues such as this (this was one of the biggest issues we had which was preventing the kids from using presentation software). It's too bad that it takes so long for people to see bugs in software that are critical to environments such as schools, where the exposure of open source software is critical for young people to have a good (or bad) impression (no pun intended) of it. For myself, I have reverted back to Debian, which experiences very few "roll-over" issues compared to Ubuntu. Not that anyone really cares, I just thought I'd let you all know why I wasn't about to keep going after this bug. Seriously, though. 2.5 years...

Changed in openoffice.org (Ubuntu):
status: Incomplete → Won't Fix

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

summary: - [Upstream] Starting "Slide Show" caches pixmap data excessively,
- crashing thin clients
+ Starting "Slide Show" caches pixmap data excessively, crashing thin
+ clients
Bryan Quigley (bryanquigley) wrote :

I'm sorry you had a bad experience with OpenOffice/Ubuntu at the time. We've improved a lot since then and hope you will take a look at Ubuntu in the future.

I'm going to close this bug because we don't have any way to confirm this is still an issue. In addition, similar issues were fixed in the LTSP setup itself.

Changed in libreoffice (Ubuntu):
status: Incomplete → Invalid
Changed in openoffice:
importance: Unknown → Undecided
status: Confirmed → New
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.