[upstream] pdfimport mis-colors image in imported PDF

Bug #310057 reported by claudio on 2008-12-20
6
Affects Status Importance Assigned to Milestone
LibreOffice
Fix Released
Low
OpenOffice
Unknown
Low
libreoffice (Ubuntu)
Medium
Unassigned
openoffice.org (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: openoffice.org

1) lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

2) apt-cache policy libreoffice-pdfimport
libreoffice-pdfimport:
  Installed: 1.0.3+LibO3.3.2-1ubuntu5
  Candidate: 1.0.3+LibO3.3.2-1ubuntu5
  Version table:
 *** 1.0.3+LibO3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-proposed/universe i386 Packages
        100 /var/lib/dpkg/status
     1.0.3+LibO3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/universe i386 Packages

apt-cache policy libreoffice-draw
libreoffice-draw:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-proposed/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

apt-cache policy unoconv
unoconv:
  Installed: 0.3-6
  Candidate: 0.3-6
  Version table:
 *** 0.3-6 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/universe i386 Packages
        100 /var/lib/dpkg/status

apt-cache policy acroread
acroread:
  Installed: 9.4.2-0natty1
  Candidate: 9.4.2-0natty1
  Version table:
 *** 9.4.2-0natty1 0
        500 http://archive.canonical.com/ubuntu/ natty/partner i386 Packages
        100 /var/lib/dpkg/status

3) What is expected to happen using the libreoffice-pdfimport via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/310057/+attachment/2130070/+files/ah_41813a_j11_a_01564.pdf && unoconv --listener && unoconv -f otg ah_41813a_j11_a_01564.pdf && cp ah_41813a_j11_a_01564.otg export.otg && unoconv -f pdf export.otg && acroread ah_41813a_j11_a_01564.pdf export.pdf

is the O in the VZO logo is displayed green in both files.

4) What happens instead is the O is light blue.

Original Reporter Comments:
openoffice.org-pdfimport 0.3.2+OOo3.0.0-6ubuntu0intrepid1
openoffice.org-draw 1:3.0.0-6ubuntu0intrepid1

From the Ubuntu bug report.

"
I downloaded
http://online.fahrplaninfo.zvv.ch/showpdf.php?pdf=pdf/41/ah_41813a/ah_41813a_j09_a_01564.pdf
and imported it using openoffice.org-pdfimport

I notice some differences to when the file is viewed in evince, which I think
looks right:

1. In the top left a black square is shown where evince shows a white bus
pictogram within the black square.

2. Right next to the black square I see the number 813 aligned on the bottom
with the black square. evince shows the number at mid height within a rectangle,
which was not drawn in the imported file.

3. Top middle of the page there is a VZO Logo which evince shows as the three
letters VZO in the colors red, blue and green and a small ZVV logo on its top
right. In the imported file the letter O ist hollow instead of green and the ZVV
logo is not seen at all.

If I export the imported file to PDF right after having opened it, the resulting
PDF shows the three differences to the original as mentioned above.

As a side note: The letters VZO are not shown as smoothly as evince shows them,
they are jagged. But if after opening the file I export it to PDF right away,
the resulting PDF viewed in evince shows VZO again smooth. So I consider the
jagged letters not a "real bug".
"

Changed in openoffice.org:
importance: Undecided → Low
status: New → Triaged
Changed in openoffice:
status: Unknown → Confirmed

Reproducible. Reassigned.

I found another document which is rendered fine by evince or xpdf but is wrong in openoffice... totally wrong, letters on the second page are scattered over that page and the form on page 1 is broken up too. You can find the document here: http://www.treffpunkt-arbeit.ch/dateien/Formulare/PDF/D/716-007_d.pdf.

Please tell me if you prefer I open a new bug report for this.

Adamson H (adamson) wrote :

http://launchpadlibrarian.net/19751825/dell440.pdf and http://launchpadlibrarian.net/10237551/OO23%20Windows.pdf show up much better in Oo3 than in Evince. However, both files still have display problems. Some characters are missing. Some characters overlap. Viewing dell440.pdf in Oo3 is very slow.

Claudio, the following link does not have the attachment that renders incorrectly in Draw. Could you please attach a copy of this file to this bug? http://online.fahrplaninfo.zvv.ch/showpdf.php?pdf=pdf/41/ah_41813a/ah_41813a_j09_a_01564.pdf

Changed in openoffice.org (Ubuntu):
status: Triaged → Incomplete

The following link does not have the attachment that renders incorrectly in Draw. Could you please attach a copy of this file to this bug? http://online.fahrplaninfo.zvv.ch/showpdf.php?pdf=pdf/41/ah_41813a/ah_41813a_j09_a_01564.pdf

claudio (private-claudio) wrote :

Hi,

the part j09 in the filename contains the year the bus schedule is valid (that is what the document is) and 09 has gone, now it is 11, thus the new link is http://online.fahrplaninfo.zvv.ch/showpdf.php?pdf=pdf/41/ah_41813a/ah_41813a_j11_a_01564.pdf

To make sure the document will stay available for this bug I attach it too as you requested.

claudio (private-claudio) wrote :
claudio (private-claudio) wrote :

This is not really pertaining to this bug, but I report it in because maybe knowing what is going on with LibreOffice it might help you in fixing it for OpenOffice for Ubuntu:

I currently have no Ubuntu at hand to recreate, but have imported the document in LibreOffice 3.3.2 for Mac OS X [OOO330m19 (Build:202)]. Regarding the bugs I originally reported in this bug, in the LibreOffice mentioned above this has changed:

1. The bus icon is now visible.

2. The number is shown correctly within a rectangle.

3. The letter O is not really hollow, but still wrong. The ring is painted light-blue instead of green. The limits/outlines of the O are in black instead of either green or invisible. Furthermore there is a new bug. The V of VZO is placed wrongly. The vertical position seems correct but the horizontal position is wrong. Instead of being placed left of the Z it is placed between Z and O. On the other hand the ZVV Logo which was missing is now there, so this is fixed.

Also the "non-bug" i.e. the jagged appearance of VZO is gone my LibreOffice for Mac. VZO is shown smoothly as expected.

claudio, regarding how this LibreOffice Draw compares to Adobe Reader via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/310057/+attachment/2130070/+files/ah_41813a_j11_a_01564.pdf && acroread ah_41813a_j11_a_01564.pdf lodraw -nologo ah_41813a_j11_a_01564.pdf

acroread ah_41813a_j11_a_01564.pdf

> 1. In the top left a black square is shown where evince shows a white bus pictogram within the black square.

Unreproducible.

> 2. Right next to the black square I see the number 813 aligned on the bottom with the black square. evince shows the number at mid height within a rectangle, which was not drawn in the imported file.

Unreproducible.

> 3. Top middle of the page there is a VZO Logo which evince shows as the three letters VZO in the colors red, blue and green and a small ZVV logo on its top right. In the imported file the letter O ist hollow instead of green...

Confirmed.

> 4. ...and the ZVV logo is not seen at all.

Unreproducible.

As problem 3 was the only thing reproducible, this is what this bug will focus on.

lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

apt-cache policy libreoffice-draw
libreoffice-draw:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-proposed/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

apt-cache policy acroread
acroread:
  Installed: 9.4.2-0natty1
  Candidate: 9.4.2-0natty1
  Version table:
 *** 9.4.2-0natty1 0
        500 http://archive.canonical.com/ubuntu/ natty/partner i386 Packages
        100 /var/lib/dpkg/status

Changed in openoffice.org (Ubuntu):
status: Incomplete → Triaged
Changed in libreoffice (Ubuntu):
status: New → Confirmed
description: updated
description: updated
summary: - [upstream] wrong rendering of imported pdf file
+ [upstream] Draw mis-displays color of image in imported PDF
Changed in libreoffice (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
description: updated
description: updated
summary: - [upstream] Draw mis-displays color of image in imported PDF
+ [upstream] pdfimport mis-colors image in imported PDF

Created attachment 46755
ah_41813a_j11_a_01564.pdf

Downstream bug may be found at:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/310057

1) lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

2) apt-cache policy libreoffice-pdfimport
libreoffice-pdfimport:
  Installed: 1.0.3+LibO3.3.2-1ubuntu5
  Candidate: 1.0.3+LibO3.3.2-1ubuntu5
  Version table:
 *** 1.0.3+LibO3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-proposed/universe i386 Packages
        100 /var/lib/dpkg/status
     1.0.3+LibO3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/universe i386 Packages

apt-cache policy libreoffice-draw
libreoffice-draw:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-proposed/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

apt-cache policy unoconv
unoconv:
  Installed: 0.3-6
  Candidate: 0.3-6
  Version table:
 *** 0.3-6 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/universe i386 Packages
        100 /var/lib/dpkg/status

apt-cache policy acroread
acroread:
  Installed: 9.4.2-0natty1
  Candidate: 9.4.2-0natty1
  Version table:
 *** 9.4.2-0natty1 0
        500 http://archive.canonical.com/ubuntu/ natty/partner i386 Packages
        100 /var/lib/dpkg/status

3) What is expected to happen using the libreoffice-pdfimport via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/310057/+attachment/2130070/+files/ah_41813a_j11_a_01564.pdf && unoconv --listener && unoconv -f otg ah_41813a_j11_a_01564.pdf && cp ah_41813a_j11_a_01564.otg export.otg && unoconv -f pdf export.otg && acroread ah_41813a_j11_a_01564.pdf export.pdf

is the O in the VZO logo is displayed green in both files.

4) What happens instead is the O is light blue.

tags: added: lo33
Changed in df-libreoffice:
importance: Unknown → Low
status: Unknown → Confirmed
Changed in openoffice.org (Ubuntu):
status: Triaged → Won't Fix

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html

Changed in df-libreoffice:
status: Confirmed → Incomplete

Reproducible in:
LOdev 3.5.0beta2
Build ID: 8589e48-760cc4d-f39cf3d-1b2857e-60db978
Microsoft Windows Vista Business 6.0.6002 Service Pack 2 Build 6002

Changed in openoffice:
status: Confirmed → Unknown
Changed in df-libreoffice:
status: Incomplete → Confirmed
Changed in openoffice:
importance: Unknown → Low

Sorry, didn't mean to close this.

Reproducible in:
Microsoft Windows Vista Business x86 6.0.6002 Service Pack 2 Build 6002
Version 4.0.0.3 (Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89)

Light blue color of 'O' is fixed here:
https://gerrit.libreoffice.org/8106

But there are still some related problems

Vort committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=988b695bcc0013d482855b81330e10fdb3448b8b

fdo#37246 PDF Import: Color to string conversion fix

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.

tags: added: natty trusty

Besides incorrect color, in imported sample document there are one more problem - extra strokes.
This problem was tracked down to this bug and it's solution:
https://issues.apache.org/ooo/show_bug.cgi?id=109708
https://wiki.openoffice.org/wiki/User:Joekidd/OpenOffice.org/Internship/PDFImport/Tasks/Issue109708
https://issues.apache.org/ooo/attachment.cgi?id=71099&action=diff

But when I tested PDF from OO bug #109708 and with this lines commented out:
//if(area < minAreaThreshold)
// m_pSink->strokePath(path);
, I found no problems. Maybe that hack is obsolete and can be removed?

And one more question - where this (strokes) problem needs to be discussed?

Hi Vort,
I would just submit a patch and explain the problem in a comment or the commit message.
The reviewer should then decide whether it's ok to merge.

Thanks

Bugreport about extra strokes: Bug 75195
Closing this report

Changed in df-libreoffice:
status: Confirmed → Fix Released
madbiologist (me-again) wrote :

Official support for Ubuntu 11.04 "Natty Narwhal" has ended. Is this fixed in Ubuntu 14.10 "Utopic Unicorn"?

Changed in libreoffice (Ubuntu):
status: Triaged → Incomplete

Fixed in Xenial.

Changed in libreoffice (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.