The upstream OOo still crash when input some utf-8 char.

Bug #30135 reported by D.B. Tsai on 2006-01-31
12
Affects Status Importance Assigned to Milestone
openoffice.org (Ubuntu)
Medium
Matthias Klose

Bug Description

First of all, I think the problem is due to libc6 problemin bug 28640, but yesterday, the problem is fixed.

So I think OOo will have no problem on open Japan or Chinese file, but with no luck, it crash.

You may try the following file.
http://www.phys.ncku.edu.tw/~c2491665/chinese.odt

This problem have been exit for servel mounths, so I holp
someone could fix it soon.

Thanks for great work.

Phil Bull (philbull) on 2006-01-31
Changed in openoffice.org2:
assignee: nobody → desktop-bugs
Loïc Martin (loic-martin3) wrote :

That sounds like a replicate of Bug #5981in openoffice.org2 (Ubuntu): "OOo crashes when input chinese"

https://launchpad.net/distros/ubuntu/+source/openoffice.org2/+bug/5981

Although it only appears on Dapper's Ubuntu (or in Breezy if you're using an unofficial Open Office package).

Could you please check your version of Open Office (and maybe of Ubuntu) and see if it's the same bug?
Thanks

This problem have seen solved by Matthias, see the following mail
between he and I.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

This version work correctly with Chinese, and won't crash anymore.

By the way, this OOo's theme is not the same with my system, look bad.

Thanks

2006/2/26, Matthias Klose <email address hidden>:

> D.B. Tsai writes:

> > > But the current version in dapper would be crash.
> > >
> > > http://www.phys.ncku.edu.tw/~c2491665/chinese.odt
>
>
> a new upstream snapshot, without having your patch applied, can be
> found at http://people.ubuntu.com/~doko/tmp/OOo2/
>
> deb http://people.ubuntu.com/~doko/tmp/OOo2 ./
>
> please check. please don't post the address in the bug report
> yet. These are not official packages...
>
> Matthias

Loïc wrote:
> Public bug report changed:
> https://launchpad.net/malone/bugs/30135
>
> Comment:
> That sounds like a replicate of Bug #5981in openoffice.org2 (Ubuntu):
> "OOo crashes when input chinese"
>
> https://launchpad.net/distros/ubuntu/+source/openoffice.org2/+bug/5981
>
> Although it only appears on Dapper's Ubuntu (or in Breezy if you're
> using an unofficial Open Office package).
>
> Could you please check your version of Open Office (and maybe of Ubuntu) and see if it's the same bug?
> Thanks
>
>

Matthias Klose (doko) wrote :

works with 2.0.2 in dapper

Changed in openoffice.org2:
assignee: desktop-bugs → doko
Ming Hua (minghua) wrote :

The version in dapper (2.0.2-1ubuntu2) opens and displays the attached odt file fine (although using a different font as I don't have Firefly's New Sung font installed). Therefore reject this bug.

I'm using en_US.UTF-8 locale. If this crash can be reproduced in other locales (like the case for bug #5981), please reopen and specify which locale is necessary to reproduce the crash.

Changed in openoffice.org2:
status: Unconfirmed → Rejected
Matthias Klose (doko) wrote :

setting to fixed, we did have a problem before.

Changed in openoffice.org2:
status: Rejected → Fix Released
ZhengPeng Hou (zhengpeng-hou) wrote :

Can open the attachment with up-to-date OOo indaper under zh_CN locales

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers