Bad font appearance in OpenOffice.org menus on KDE (Kubuntu)

Bug #29198 reported by Petr Tomeš on 2006-01-20
14
Affects Status Importance Assigned to Milestone
openoffice.org (Ubuntu)
Medium
Brian Murray

Bug Description

Bad font appearance in OpenOffice.org menus KDE (Kubuntu).

Menu in OpenOffice.org2 Writer on Kubuntu 5.10

Menu in OpenOffice.org Writer 2.0.1 on Mandriva 2006, KDE 3.5, font: sans 10

Matthias Klose (doko) wrote :

- Is this font different from the one used in ither menus?
- Please could you recheck with a current dapper Openoffice.Org 2.0.2 package?

Changed in openoffice.org:
status: Unconfirmed → Needs Info
Machine Screw (machine-screw) wrote :

This apears to be a problem with the font.conf file in genral
currently there was a person in the IRC that figured it out this is on a Kubuntu Dapper flight 6 install after the latest update done on the date of this comment. Here is a screenshot what they looked like

http://i31.photobucket.com/albums/c383/satempler/konvimacscrw.png

and after

http://i31.photobucket.com/albums/c383/satempler/konvimacscrw2.png

here is the contents of the .font.conf file that fixed it i put it in /etc/fonts/local.conf to fix it for all of Xwindows including KDM

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<!-- ~/.fonts.conf file to configure user font settings --><fontconfig>
<!-- Enable sub-pixel rendering --> <match target="font" >
  <test name="rgba" qual="all" >
   <const>unknown</const>
  </test>
  <edit mode="assign" name="rgba" >
   <const>rgb</const>
  </edit>
 </match>
<!-- Autohint fonts --> <match target="font" >
  <edit mode="assign" name="autohint" >
   <bool>true</bool>
  </edit>
 </match>
<!-- Don't autohint my terminal font --> <match target="font" >
  <test name="family" qual="any" >
   <string>Bitstream Vera Sans Mono</string>
  </test>
  <edit mode="assign" name="autohint" >
   <bool>false</bool>
  </edit>
 </match>
<!-- Antialias --> <match target="font" >
  <edit mode="assign" name="antialias" >
   <bool>true</bool>
  </edit>
 </match>
 <match target="font" >
  <edit mode="assign" name="hinting" >
   <bool>true</bool>
  </edit>
 </match>
 <match target="font" >
  <edit mode="assign" name="hintstyle" >
   <const>hintmedium</const>
  </edit>
 </match>
<!-- Alias Helvetica to be something less shit --> <match target="pattern" >
  <test name="family" qual="any" >
   <string>Helvetica</string>
  </test>
  <edit mode="assign" name="family" >
   <string>Bitstream Vera Sans</string>
  </edit>
 </match>
 <match target="font" >
  <edit mode="assign" name="rgba" >
   <const>none</const>
  </edit>
 </match>
</fontconfig>

Brian Murray (brian-murray) wrote :

We are closing this bug report as it concerns Breezy which is no longer supported. However, please reopen it if it is still an issue with a supported version of Ubuntu and feel free to submit bug reports in the future.

Changed in openoffice.org:
assignee: nobody → brian-murray
status: Needs Info → Rejected
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers