[upstream] Office 2007 .pptx presentation failed to load correctly

Bug #288971 reported by Daneken on 2008-10-25
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenOffice
Confirmed
Unknown
openoffice.org (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: openoffice.org

does not look anything like original 2007 PPT presentation
Ubuntu 8

ProblemType: Bug
Architecture: i386
Date: Sat Oct 25 11:42:03 2008
DistroRelease: Ubuntu 8.04
Package: openoffice.org-core 1:2.4.1-1ubuntu2
PackageArchitecture: i386
ProcEnviron:
 PATH=/usr/lib/openoffice/program:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
SourcePackage: openoffice.org
Uname: Linux 2.6.24-21-generic i686

Daneken (great-dane) wrote :

Not a bug. OpenOffice.org 2.4.1 does not support MS-office 2007 file formats. Only OpenOffice.org 3.0 can.

http://www.openoffice.org/dev_docs/features/3.0/#Microsoft_Office_2007_Import_Filters

Could the bug be closed as invalid because of version provided in both hardy and intrepid ?

Mackenzie Morgan (maco.m) wrote :

Fred: that's wrong. The OOo in Ubuntu is built from go-oo.org, and it does include the ability to open Office 2007 formats. In fact, I'm pretty sure Gutsy could do it.

Daneken:
Could you attach screenshots of how the presentation should look and how it actually does look?

Changed in openoffice.org:
status: New → Incomplete
Chris Cheney (ccheney) on 2008-11-17
Changed in openoffice.org:
status: Incomplete → Confirmed
Mackenzie Morgan (maco.m) wrote :

Setting this bug back to Incomplete status pending requested information.

Changed in openoffice.org:
status: Confirmed → Incomplete
Chris Cheney (ccheney) wrote :

I'm the Ubuntu OOo maintainer...

It looks so wrong its actually hard to describe. When opened in OOo it looks like you see part of the windows desktop(?) which isn't there at all when displayed under PowerPoint 2007.

I'll take a look at this more later when determining if this should go to go-oo or upstream.

Changed in openoffice.org:
importance: Undecided → Low
status: Incomplete → Triaged
Chris Cheney (ccheney) on 2009-02-04
Changed in openoffice:
importance: Undecided → Unknown
status: New → Unknown
Changed in openoffice:
status: Unknown → Confirmed
Chris Cheney (ccheney) on 2010-05-13
tags: added: hardy
summary: - [upstream] Office 2007 PPT presentation failed to load correctly
+ [upstream] Office 2007 .pptx presentation failed to load correctly
Changed in openoffice.org (Ubuntu):
status: Triaged → Won't Fix

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

See also: Compatibility issues with Microsoft Office 2010 PowerPoint .pptx presentations Bug #879056

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.