[Upstream] [hardy] OpenOffice doesn't use fontconfig settings

Bug #24004 reported by mbiesz on 2005-10-15
40
Affects Status Importance Assigned to Milestone
OpenOffice
Invalid
Unknown
openoffice.org (Ubuntu)
Low
Unassigned

Bug Description

When setting font rendering to use autohinting (via "dpkg-reconfigure
fontconfig"), OpenOffice (1.9.129) still uses normal bytecode-interpreted
anti-aliasing in both the document and UI.

Tested with latest Breezy packages (as of 10/15/05).

mbiesz (mbiesz) wrote :

By the way, the fix that others mentioned doesn't make a difference for me:

LD_PRELOAD=/usr/lib/libfreetype.so.6 /usr/bin/ooffice2 "$*"

Matthias Klose (doko) wrote :

confirmed, it doesn't make a difference, if you point it to the same system library

Changed in openoffice.org2-amd64:
assignee: doko → openoffice-pkgs
status: Unconfirmed → Confirmed
Ricardo Pérez López (ricardo) wrote :

I can confirm this bug in Dapper. It's a rather annoying bug, because the look & feel of OpenOffice.org doesn't match with the desktop.

Matthias Klose (doko) wrote :

Setting to Wontfix.

From http://freetype.sourceforge.net/patents.html

"Finally, many Linux distributions seem to distribute a patched version of FreeType 2 with the bytecode interpreter activated, unlike to the sources we distribute. Of course, we can only deny any kind of responsibility in this case. It further means that in the event where you need to update the version of FreeType installed on your system from our sources, you should better manually activate the bytecode interpreter at compile time in order to prevent any loss of quality."

Ubuntu doesn't turn on the autohinter

mbiesz (mbiesz) wrote :

Matthias, the autohinter can be activated with dpkg-reconfigure -- the bug is that when it is set, the body of OpenOffice still uses the bytecode interpreter.

And I don't understand your point with quoting that patent page; if anything, that means that the autohinter would be the correct option and that the font rendering in Ubuntu (bytecode interpreter) is illegal as it stands.

Xarafaxz (xarafaxz) wrote :

I just upload screenshot. Working with OpenOffice without bytecode autohinter really sick :/

Xavier (chantry-xavier) wrote :

Could you look at:
https://launchpad.net/distros/ubuntu/+source/openoffice.org/+bug/54776

and try playing with ~/.fonts.conf and tell me if it improves thing for you.
I believe that your screenshot looks like what I had initially. And I believe there is no hinting done there at all.
After adding a ~/.fonts.conf file, fonts look better (so maybe autohinting got enabled?). Though I admit it still doesn't look as nice as bytecode interpreter.

After i enabled subpixel aliasing the bytecode hinting works much better.
Hoverwer not as good as it should be (qt, gtk applications).Also i don't like
subpixel aliasing. Same effect you will get if you build freetype 2.1 by
hand.

ex: ./configure --prefix=/opt/freetype21/ && make && make install
and LD_PRELOAD openoffice against it.

This bug is releated to both dapper and edgy freetype22. I will try some
diffrent OO binaries next week.

Dnia piątek, 13 października 2006 13:40, Xavier napisał:
> Could you look at:
> https://launchpad.net/distros/ubuntu/+source/openoffice.org/+bug/54776
>
> and try playing with ~/.fonts.conf and tell me if it improves thing for
> you. I believe that your screenshot looks like what I had initially. And I
> believe there is no hinting done there at all. After adding a ~/.fonts.conf
> file, fonts look better (so maybe autohinting got enabled?). Though I admit
> it still doesn't look as nice as bytecode interpreter.

Firstly, I don't think there is such a thing as "bytecode autohinter". I think that contradicts itself. You use either native hinting (with the bytecode interpreter) or auto hinting.
Secondly, if you enable subpixel in ~/fonts.conf, openoffice will use something similar to autohinting + grayscale + medium hinting
Otherwise, openoffice use something like no hinting + grayscale.
Note that in both case, antialiasing is done with grayscale level, not with subpixel (RGB).
All these results are totally counter-intuitive. openoffice's fontconfig support seems badly broken in its current state, so I hope it'll be improved. I don't think there is much you can do besides fixing the code.

Changed in openoffice:
status: Unknown → Confirmed
Chris Cheney (ccheney) on 2007-10-19
Changed in openoffice.org:
assignee: openoffice-pkgs → nobody
importance: Medium → Low
Chris Cheney (ccheney) wrote :

Do you still see this problem with Ubuntu 7.10 OpenOffice 2.3.0?

Thanks,

Chris Cheney

Changed in openoffice.org:
importance: Low → Wishlist
assignee: nobody → ccheney
status: Confirmed → Incomplete
Matthias Klose (doko) wrote :

fontconfig support is enabled, but needs improvement; there was no change in newer versions, including 2.3

Changed in openoffice.org:
importance: Wishlist → High
status: Incomplete → Confirmed
Chris Cheney (ccheney) on 2007-10-23
Changed in openoffice.org:
assignee: ccheney → nobody
importance: High → Low
Piotr Gawrysiak (pgawrysiak) wrote :

Still present in Hardy Alpha 2!!!

Gaspard Leon (gaspard.leon) wrote :

Does anyone know where to go upstream for this, or does it need to be fixed in ubuntu?

It's really noticeable if you use "Slight" hinting for your GNOME settings like I do.

VincentB (wxcdfg) wrote :

Hello,
I have exactly the same issue with Ubuntu 7.1 and Open Office 2.4. Picture sent from Xarafaxz is similar to what I get on my screen (HP NC6220 Laptop LCD).
Display of fonts is unsatisfactory in menu/dialog boxes as in the typed text. No other application behaves like this.
I personally do not consider this a minor issue, the application really looks something of another age. Gedit is far better compared to my OpenOffice Writter.

Changed in openoffice:
status: Confirmed → Invalid
Chris Cheney (ccheney) on 2008-06-04
Changed in openoffice.org:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.