[upstream] Font rendering antialiasing broken in tab labels

Bug #232377 reported by Nick Ellery on 2008-05-21
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenOffice
Confirmed
Unknown
openoffice.org (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: openoffice.org

Screenshot attached. The tabs in Openoffice Writer 2.4 are low quality. This is the default Openoffice.org in Hardy. Tabs in any formatting window appear like this.

Nick Ellery (nick.ellery) wrote :
GercoKees (gercokees) wrote :

Hi,
Thanks for your bug report. Can you explain what exactly the problem is? I am afraid that i do not understand...
Thanks in advance...

Nick Ellery (nick.ellery) wrote :

Take a look at the screenshot. You will see that the tabs are low-quality, and not the same as the rest of the text.

GercoKees (gercokees) wrote :

I think this:
http://wiki.services.openoffice.org/wiki/VCL_UI_Rework

means they are working on it...

Chris Cheney (ccheney) wrote :

I'm not 100% certain but I think what you are talking about is due to the fact the font in the tabs is bold and greyed out which appears to look odd with antialiasing. Or is there something else causing this problem?

Changed in openoffice.org:
status: New → Incomplete
Nick Ellery (nick.ellery) wrote :

I'm not entirely sure about that one, but everything is on default settings, as I haven't changed anything, so I would assume other people suffer this issue as well.

GercoKees (gercokees) wrote :

I have the same problem. I thought it had something to do with the rendering of the dialog itself, which is (i assume) not a native gtk-dialog. (See my post may 27)

Chris Cheney (ccheney) wrote :

Yes they look different than regular gtk/gnome tabs, which might be changed with the VCL update. I'll leave this bug open for now.

Thanks,

Chris

Changed in openoffice.org:
status: Incomplete → Confirmed
Chris Cheney (ccheney) on 2008-06-14
Changed in openoffice.org:
status: Confirmed → Triaged
Changed in openoffice.org:
importance: Undecided → Low
GercoKees (gercokees) wrote :

It seems someone is busy with this:
http://lilypond.org/blog/janneke/#2008-07-17

Chris Cheney (ccheney) on 2009-02-04
Changed in openoffice:
importance: Undecided → Unknown
status: New → Unknown
Changed in openoffice:
status: Unknown → Confirmed
Chris Cheney (ccheney) on 2009-05-06
summary: - Low quality tabs in Openoffice Writer 2.4.0
+ [upstream] Font rendering antialiasing broken in tab labels
Changed in openoffice.org (Ubuntu):
status: Triaged → Won't Fix

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.