[jaunty] Vertical CJK text is not rendered properly: it's invisible.

Bug #223433 reported by koban
12
Affects Status Importance Assigned to Milestone
Debian
Fix Released
Unknown
fontconfig (Ubuntu)
Undecided
Unassigned
openoffice.org (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: openoffice.org

CJK text in vertical writing mode is invisible. Horizontal writing is OK. Might be related to fontconfig.
Affected Ubuntu releases: 8.04, 8.10
Last "good" release: 7.10

ProblemType: Bug
Architecture: i386
Date: Mon Apr 28 12:30:12 2008
DistroRelease: Ubuntu 8.04
Package: openoffice.org-core 1:2.4.0-3ubuntu6
PackageArchitecture: i386
ProcEnviron:
 PATH=/usr/lib/openousernameusernameice/program:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=ja_JP.UTF-8
 SHELL=/bin/bash
SourcePackage: openoffice.org
Uname: Linux 2.6.24-16-generic i686

Revision history for this message
koban (letter-msa) wrote :
Revision history for this message
Mitsuya Shibata (cosmos-door) wrote :

I confirmed it.

How to reproduce:
1. Launch OpenOffice.org Writer
2. Change font to "VL Gothic"
3. To enable SCIM, press Ctrl+Space
4. Input Japanese words (ex. "abcあいうえおdef", left image)
5. To change writing direction to vertical, select Format -> Page -> "Page" tab
 then change "Text direction" to "Right-to-left (vertical)", click OK
6. Japanese words are invisible (right image)

Info:
Original OO.o 2.4 couldn't reproduce its bug. It seems that it is Ubuntu package's bug.

Revision history for this message
Catapult (ubunt2+launchpad) wrote :

I can type Japanese text in vertical format.

Revision history for this message
Catapult (ubunt2+launchpad) wrote :

Why use VL Gothic? Why not use a japanese font? I used "DejaVu Sans" to get the fonts appearing in the screenshot in the above post.

Revision history for this message
Mitsuya Shibata (cosmos-door) wrote :

@Catapult
"VL Gothic" is Japanese font. I think that VL Gothic is default font in Japanese locale.

Your result is very interesting. I used "DejaVu Sans" too, but was only reproduced this bug... What is your OO.o package? Do you use hardy-proposed or intrepid?

Revision history for this message
Catapult (ubunt2+launchpad) wrote :

I use the package in regular/official Ubuntu repositiories.
I use OpenOffice.org version 2.4.0.

Package: openoffice.org-writer
Maintainer: Ubuntu Core Developers <<email address hidden>)
Installed Version: 1:2.4.0-3ubuntu6 (hardy)

Revision history for this message
Chris Cheney (ccheney) wrote :

Can anyone who is affected by this problem try out the version in hardy-proposed to see if the problem is resolved there for them? A slightly updated version of those packages will be released for Ubuntu 8.04.1 next month so it would be helpful to find out if they resolve the problem.

Thanks!

Chris Cheney

Changed in openoffice.org:
status: New → Incomplete
Revision history for this message
Catapult (ubunt2+launchpad) wrote :

I've tried the hardy-proposed version (1:2.4.1~rc1-1ubuntu1) but the line is still horizontal.

Chris Cheney (ccheney)
Changed in openoffice.org:
status: Incomplete → New
Revision history for this message
Rolf Leggewie (r0lf) wrote :

FWIW, I can confirm this behaviour.

catapult, I'm a bit perpleced by your last comment. Is the *vertical* line still displayed correctly for you or not?

Changed in openoffice.org:
status: New → Confirmed
Revision history for this message
Alex Forencich (alex-alexelectronics) wrote :

I can confirm this as well. For me, though, VL Gothic does not work at all while DejaVu Sans works but only while the on-screen size is smaller than a certain amount (as in, zooming in or increasing the size will make it disappear). For me, viewing at 100% with a font size of 12 points is fine, but zoom in and it's gone or resize to 13 points or larger and it's gone. Same goes for text appearing in the print preview, though it seems to be able to print to PDF fine. Also, the separator character 「・」 seems to be appearing one character too low - as in 「あ・か」, the 「・」 appears on top of the か instead of in between the characters. Space is left for the character where it should be, but it is being drawn in the wrong place. This only seems to happen at 100% and 12 points, any smaller seems to work just fine.

Revision history for this message
Alex Forencich (alex-alexelectronics) wrote :

By the way, I'm running OpenOffice 1:2.4.1-1ubuntu2 (from Synaptic) on Hardy Heron AMD64 with kernel 2.6.24-19-generic.

Revision history for this message
koban (letter-msa) wrote : Re: [Bug 223433] Re: openoffice,japanese vertical line is not supported.

  Hello.
  I'm sorry for too late to answer your mail.
  And I'm not good at in English.

  "Vertical" line in Japanese still does not appear in my
OpenOffice.Writer.2.4.1.

  Maybe OpenOffice is not updated that I notice,so there are
no improvement.

Revision history for this message
Alex Forencich (alex-alexelectronics) wrote : Re: openoffice,japanese vertical line is not supported.

How is this a duplicate of #181184? Text disappearing above a certain size and spacing problems are two completely different things. The misplaced 「・」may be related to #181184, but the rest isn't as far as I can tell. Does somebody care to enlighten us as to why this seems to have been marked a duplicate of an unrelated bug?

Revision history for this message
Chris Cheney (ccheney) wrote :

Alex,

Sorry about the incorrect merging.

Can you please attach an example document to the launchpad bug report. I need to verify if this bug affects the official version so I know where to forward this bug.

Thanks,

Chris Cheney

Revision history for this message
Alex Forencich (alex-alexelectronics) wrote :

On my computer, this document looks fine at 100% zoom. When I zoom in, the vertical japanese text disappears. If I make the font of the vertical text bigger, it also disappears. The horizontal text scales fine.

Revision history for this message
Chris Cheney (ccheney) wrote :

I can't see either the incorrect or correct line at any zoom level since I apparently don't have the proper fonts installed. It claims to be using DejaVu Sans which I do have installed so it might be some sort of font substitution error. I can see the horizontal text just fine. Do you know what font it is actually using to display?

Revision history for this message
Chris Cheney (ccheney) wrote :

Well I can see it in official openoffice.org 3.0.0, in a virtual machine, with the spacing problems so I will go ahead and forward the bug upstream.

Thanks,

Chris

Changed in openoffice.org:
importance: Undecided → Medium
status: Confirmed → Triaged
Revision history for this message
Chris Cheney (ccheney) wrote :

Actually what I thought was wrong with the document (the length of the text) obviously wasn't so I am back to the original point of not being able to see the document at all with the fonts I have installed.

Changed in openoffice.org:
importance: Medium → Undecided
status: Triaged → Incomplete
Revision history for this message
Chris Cheney (ccheney) wrote :

Can you take a look at this bug I can't seem to get it to display at all for me, so something must be wrong with my setup.

Changed in openoffice.org:
assignee: nobody → arnegoetje
Revision history for this message
Arne Goetje (arnegoetje) wrote :

I can confirm this bug with version 2.4.1-11ubuntu2 on Intrepid and also with 2.4.1-11 on Debian Lenny.
Horizontal CJK text displays fine, but vertical text is invisible, no matter which CJK font you use.
One interesting find: if the font in question contains embedded bitmaps and the selected font size results to use the bitmaps instead of the spline data, then the bitmaps are displayed in the Debian Lenny version, but not in the Intrepid version. As soon as the font size in increased, so that the splines are used to render the font, the text becomes invisible. Fonts, which don't contain embedded bitmaps are always invisible.
My guess is, that it's a rendering bug in openoffice.org, but that maybe fontconfig is involved. Maybe it's a miscommunication between the two.

I will try to rebuild the openoffice suite locally with different patches removed to see if our fontconfig version has something to do with it.

@Chris: if you want to test with CJK fonts, you can install the language-support-fonts-{zh|ja|ko} package(s). That should give you the necessary fonts to test the document.

Changed in openoffice.org:
status: Incomplete → In Progress
Revision history for this message
Arne Goetje (arnegoetje) wrote :

OK, apparently I can't just deactivate some patches, because there is no debian/patches subdirectory... :(
So, it remains guesswork for me. As I said before, my guess would be that it is related to fontconfig in Intrepid, but where exactly the bug is, I don't know.

Changed in openoffice.org:
assignee: arnegoetje → nobody
status: In Progress → Confirmed
Arne Goetje (arnegoetje)
description: updated
Revision history for this message
Arne Goetje (arnegoetje) wrote : Re: [openoffice.org] Vertical CJK text is not rendered properly: it's invisible.

The bug report in Debian states, that the issue does not happen with oo.o 3.0 anymore.

Revision history for this message
Chris Cheney (ccheney) wrote :

Arne,

Thanks very much for testing, we have 3.0.0 debs in the openoffice-pkgs ppa for Intrepid.

In the future if you wish to do some sort of OOo rebuild on your own the patches to enable disable are under ooo-build/patches/(something)/apply for 2.4.1 the dir is src680 and for 3.0.0 it is dev300.

Thanks,

Chris

Revision history for this message
Chris Cheney (ccheney) wrote :

Marking as triaged since it apparently works in 3.0.0 which will be in Jaunty once it opens.

Changed in openoffice.org:
importance: Undecided → Medium
status: Confirmed → Triaged
Chris Cheney (ccheney)
Changed in openoffice.org:
assignee: nobody → ccheney
milestone: none → jaunty-alpha-1
Chris Cheney (ccheney)
Changed in openoffice.org:
milestone: jaunty-alpha-1 → jaunty-alpha-2
Chris Cheney (ccheney)
Changed in openoffice.org:
assignee: ccheney → nobody
milestone: jaunty-alpha-2 → none
status: Triaged → Fix Released
Revision history for this message
Rolf Leggewie (r0lf) wrote :

Anything left to be done here? The fontconfig task is still open.

Changed in fontconfig:
status: New → Incomplete
Revision history for this message
Chris Cheney (ccheney) wrote :

I think this is fixed...

Changed in fontconfig:
status: Incomplete → Fix Released
Revision history for this message
Chelmite (steve-kelem) wrote :

I have the problem of text disappearing when "Show Changes" is in effect, in English, normal text. If I turn off "Show Changes", then I can see the text. Text that was not changed shows up. Zooming in or out does not change the visibility of the changed text.

I'm running OpenOffice.org 3.1.1 OOO310m19 (Build:9420)
openoffice.org-core 1:3.1.1-5ubuntu1

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.