[upstream] [hardy] Open a Word's document as read-only if table of content is present.

Bug #215420 reported by Germán Poo-Caamaño on 2008-04-10
44
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenOffice
Invalid
Undecided
Unassigned
openoffice.org (Ubuntu)
Medium
Unassigned
Hardy
Medium
Chris Cheney

Bug Description

Binary package hint: openoffice.org2

1. Open OpenOffice in Hardy.
2. Create a document.
3. Use styles. Set 'Headings' for same titles.
4. Add a Table of Contents in the beginning of document.
5. Save the document a Word 97/2000/XP
6. Close OpenOffice.

Now:
1. Open the document saved with OpenOffice. Now this file can't be edited because is marked as Read-only (you can see it in the status bar "section2 read-only). This happens even if 'Edit' button in the toolbar is enabled.

The only operation as user you can do is delete the table of contents.

In order to edit the file, you must to delete the Table of Contents, save the file, and then, reopen it.

If you add the Table of contents, next time, it will happen the same. So, at this moment is necessary to add the table of contents when you are finished your document.

This behaviour doens't happen if the document is saved as ODT.

Also, the same document can be edited without problems in Word or OpenOffice of Gutsy. so, this bug affects only OpenOffice in Hardy.

Attached a document which is opened as 'edited mode' but only 'read-only' (weird).

Germán Poo-Caamaño (gpoo) wrote :

$ dpkg -l openoffice.org* | awk '/ii/ {printf("%-30s %10s\n", $2, $3)}'
openoffice.org-base-core 1:2.4.0-3ubuntu2
openoffice.org-calc 1:2.4.0-3ubuntu2
openoffice.org-common 1:2.4.0-3ubuntu2
openoffice.org-core 1:2.4.0-3ubuntu2
openoffice.org-draw 1:2.4.0-3ubuntu2
openoffice.org-gnome 1:2.4.0-3ubuntu2
openoffice.org-gtk 1:2.4.0-3ubuntu2
openoffice.org-help-en-gb 1:2.4.0-3ubuntu1
openoffice.org-help-en-us 1:2.4.0-3ubuntu1
openoffice.org-hyphenation-en-us 2.3.1-2ubuntu1
openoffice.org-impress 1:2.4.0-3ubuntu2
openoffice.org-l10n-common 1:2.4.0-3ubuntu1
openoffice.org-l10n-en-gb 1:2.4.0-3ubuntu1
openoffice.org-l10n-en-za 1:2.4.0-3ubuntu1
openoffice.org-ogltrans 1:2.4.0-3ubuntu2
openoffice.org-presentation-minimizer 1.0+OOo2.4.0-3ubuntu2
openoffice.org-style-human 1:2.4.0-3ubuntu2
openoffice.org-thesaurus-en-au 2.1-3ubuntu1
openoffice.org-thesaurus-en-us 1:2.4.0~m240-1ubuntu1
openoffice.org-writer 1:2.4.0-3ubuntu2

Germán Poo-Caamaño (gpoo) wrote :

Attached the same document as ODT.

Both documents are the same, but one was saved as DOC and the other one as ODT.

Tyler Willingham (tyler-ubuntu) wrote :

I have seen this as well. It seems that this problem was propagated if you save the word document (.doc) as .odt as well.

Changed in openoffice.org:
status: New → Confirmed
Jfdi (dp-jfdi) wrote :

I have the same problem, except can't delete the TOC either. Just upgraded to 8.04

Jfdi (dp-jfdi) wrote :

OK, dumb me, can delete the TOC after all (right click, select delete TOC from menu). Save, reopen & can edit as described above.

PeTe (pe-te-centrum) wrote :

Hi, i can confirm this behavior in Hardy and OO2.4. doesn't matter if i save it as odt, or doc. although it is "read only" i can delete the table of contents and when i save it, and reopen, it is read/write again.. weird. thanks for the tip, i wasn't aware the problem was caused by the TOC..

Jacquesvn (jvnmembership) wrote :

Confirmed. Deleting the table of contents, and saving the document, enables one to edit it.

PeTe (pe-te-centrum) wrote :

I found out an interesting thing: it's not the whole TOC, what is making problems.. when you are creating a TOC, on the first tab you have an option "protected against manual changes". what this should do is make the TOC unchangeable, so that you cannot write to it. when you disable it, (save and reopen) the document becomes read/write again.. so the bug is not in the whole TOC, but only this option, which by mistake makes the whole document read only instead of only the TOC!

Jorge Tomé (jorgetome) wrote :

I have the same problem here. I can confirm what PeTe has said. Unchecking the attribute "Protected against manual changes" in the properties of the Table Of Contents solves the problem, after save, close and reopen the document it is editable again.

Theodore Book (tbook) wrote :

Thanks for the workaround! A fix would be great, though.

Ville Ranki (ville-ranki) wrote :

This bug still exists in Hardy. Very annoying.

larytet (larytet-48904418) wrote :

Confirmed. After I created TOC the whole document was read-only. I went nuts. I could not figure what the problem is until i ran search in google for Hardy. Never happened in the previous version.
OpenOffice 2.4, the system is completely updated.

The only workaround - right click in TOC, menu "Edit Index/Table", uncheck check box "Protected against manual changes"

Ralph Janke (txwikinger) on 2008-06-17
Changed in openoffice.org:
status: Confirmed → Triaged
importance: Undecided → Medium
Chris Cheney (ccheney) wrote :

Confirmed on upstream's 3.0 beta.

C de-Avillez (hggdh2) wrote :

This seems to have gotten a bit worse. Intrepid, openoffice 1:2.4.1-0ubuntu1.

I was updating a document (actually copied over, and was updating the copy). Worked on it for 4 days without issues. Suddenly got hit by this.

The kick is that, in my case, *nothing* seems to recover from the read-only mode.

* I unmarked the ToC as suggested, saved & quit OO, re-opened it -- still read-only.
* I unmarked the ToC as suggested, saved & closed the document, re-opened it -- still read-only.
* I deleted the ToC as suggested, saved & quit OO, reopened it -- still read-only.
* I unmarked the ToC as suggested, saved & closed the document, re-opened it -- still read-only.
* I deleted *all* embedded pictures and the ToC, saved & quit OO, re-opened it -- still read-only.
* I stopped OO, renamed my current OO profile, and re-started OO; I then repeated the steps above -- still read-only.

Right now I am trying to salvage my work by selective copy&paste to a brand new OO document.

Chris Cheney (ccheney) on 2008-06-28
Changed in openoffice.org:
assignee: nobody → ccheney
importance: Undecided → Medium
status: New → Triaged
Steve Langasek (vorlon) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Henrik Nilsen Omma (henrik) wrote :

Tested on an original Hardy install where I could reproduce the problem and on OOo from -proposed where I can confirm the fix.

Steve Langasek (vorlon) wrote :

copied to hardy-updates.

Changed in openoffice.org:
status: Triaged → Fix Released
Steve Langasek (vorlon) wrote :

and copied to intrepid.

Changed in openoffice.org:
status: Triaged → Fix Released
Chris Cheney (ccheney) on 2008-07-03
Changed in openoffice:
status: New → Invalid
Dmitry (baburkin) wrote :

I confirm the same problem on Windows version of OpenOffice 2.4.1 but the difference is that workaround doesn't work.
You right-click in TOC, choose "Edit Index/Table", uncheck check box "Protected against manual changes" but only the TOC becomes writeable. The whole document persists being read-only.
Actually I can unlock the document in Microsoft Word 2003, using Tools -> Unprotect Document option. Then it opens in OO in writeable mode.

Something is wrong with OO compatibility with MS Office. When you use ODT format, everything works like it should.

I can add confirmation that the problem still exists in OpenOffice Writer 3.2.0, running on Lucid Lynx. I imported a Word document and was unable to edit it. There was no Table of Contents. Unprotecting the tables and sections didn't make a whit of difference.

My workaround was to cut and paste all the sections of text into a new ODT document. That affected a lot of the formatting; not catastrophic, but it cost me a couple hours to fix up the formats.

AlwaysTired (alwaystired) wrote :

I can confirm this bug still exists in Open Office 3.2.1 using Maverick. I have no TOC in my file, but it still opens in read-only mode. When I press the "Edit file" button, select all the text, clear formatting and then undo changes, I can edit and save the file without losing the formatting. But when I reopen it, it's read-only again, which is annoying...

jakub angelis (jakub-angelis) wrote :

The same is with me:
OpenOffice.org 3.2.1
OOO320m19 (Build:9505)
ooo-build 3.2.1.4, Ubuntu package 1:3.2.1-7ubuntu1.1

no TOC in my file. The file used to be doc file.
I can normaly edit the file using OpenOffice Portable on Windows, version is 3.2.0.
When I save it on windows and try to edit it on linux - result is the same, the document is read-only.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers