[Upstream] OpenOffice bad interaction with gnome's clipboard management

Bug #21204 reported by Marcos Pinto on 2005-09-08
12
Affects Status Importance Assigned to Milestone
OpenOffice
Confirmed
Unknown
Ubuntu
Undecided
Unassigned
openoffice.org (Ubuntu)
Wishlist
Unassigned

Bug Description

gnome 2.12 has clipboard management so that if you copy something from an app,
then close the app, it'll still be in the clipboard for you to paste elsewhere.
 although this works with plenty of other applications (gedit, evolution, etc),
it does not work with ooo2. if you copy something from within ooo2, then
close ooo2 and try to paste it somewhere else, the clipboard will be blank
and there'll be nothing to paste.

ii openoffice.org2 1.9.125+2.0beta2-1ubuntu1
OpenOffice.org Office suite version 2.0
ii openoffice.org2-base 1.9.125+2.0beta2-1ubuntu1
OpenOffice.org office suite - database
ii openoffice.org2-calc 1.9.125+2.0beta2-1ubuntu1
OpenOffice.org office suite - spreadsheet
ii openoffice.org2-common 1.9.125+2.0beta2-1ubuntu1
OpenOffice.org office suite architecture ind
ii openoffice.org2-core 1.9.125+2.0beta2-1ubuntu1
OpenOffice.org office suite architecture dep
ii openoffice.org2-draw 1.9.125+2.0beta2-1ubuntu1
OpenOffice.org office suite - drawing
ii openoffice.org2-evolution 1.9.125+2.0beta2-1ubuntu1
Evolution Addressbook support for OpenOffice
ii openoffice.org2-gnome 1.9.125+2.0beta2-1ubuntu1
GNOME Integration for OpenOffice.org (Widget
ii openoffice.org2-impress 1.9.125+2.0beta2-1ubuntu1
OpenOffice.org office suite - presentation
ii openoffice.org2-l10n-en-gb 1.9.125+2.0beta2-1ubuntu1.1
English_british language package for OpenOff
ii openoffice.org2-l10n-en-us 1.9.125+2.0beta2-1ubuntu1
English_american language package for OpenOf
ii openoffice.org2-math 1.9.125+2.0beta2-1ubuntu1
OpenOffice.org office suite - equation edito
ii openoffice.org2-writer 1.9.125+2.0beta2-1ubuntu1
OpenOffice.org office suite - word processor

ii nautilus 2.12.0-0ubuntu2 file manager and graphical shell for GNOME
ii gnome-about 2.12.0-0ubuntu1 The GNOME about box
ii gnome-app-install 0+20050903 GNOME Application
Installer
ii gnome-applets 2.12.0-0ubuntu1 Various applets for
GNOME 2 panel - binary f
ii gnome-applets-data 2.12.0-0ubuntu1 Various applets for
GNOME 2 panel - data fil
ii gnome-bin 1.4.2-20 Miscellaneous
binaries used by GNOME
ii gnome-common 2.11.0-0ubuntu1 common scripts and
macros to develop with GN
ii gnome-control-center 2.12.0-0ubuntu1 utilities to
configure the GNOME desktop
ii gnome-desktop-data 2.12.0-0ubuntu1 Common files for
GNOME 2 desktop apps
ii gnome-icon-theme 2.12.0-0ubuntu1 GNOME Desktop icon theme
ii gnome-libs-data 1.4.2-20 Data for GNOME libraries
ii gnome-media 2.12.O-0ubuntu1 The GNOME Media
Utilities
ii gnome-menus 2.12.0-0ubuntu1 an implementation of
the freedesktop menu sp
ii gnome-mime-data 2.4.2-1 base MIME and
Application database for GNOME
ii gnome-panel 2.12.0-0ubuntu1 launcher and docking
facility for GNOME 2
ii gnome-panel-data 2.12.0-0ubuntu1 common files for
GNOME 2 panel
ii gnome-session 2.12.0-0ubuntu1 The GNOME 2 Session
Manager

http://www.openoffice.org/issues/show_bug.cgi?id=57165: http://www.openoffice.org/issues/show_bug.cgi?id=57165

Matthias Klose (doko) wrote :

(In reply to comment #0)
> gnome 2.12 has clipboard management so that if you copy something from an app,
> then close the app, it'll still be in the clipboard for you to paste elsewhere.
> although this works with plenty of other applications (gedit, evolution, etc),
> it does not work with ooo2. if you copy something from within ooo2, then
> close ooo2 and try to paste it somewhere else, the clipboard will be blank
> and there'll be nothing to paste.

confirmed, and I'm unable to paste from an application _to_ OOo2.

Mantas Kriaučiūnas (mantas) wrote :

(In reply to comment #1)
Matthias Klose wrote:
> confirmed, and I'm unable to paste from an application _to_ OOo2.

Is it really true, that you can't paste from an application (for example gedit)
_to_ OOo 2 ?
I'm able to paste without problems text, copied from gedit, into OOo 2.
Could you write more exactly from which application and how you are pasting ?

Marcos Pinto (markybob) wrote :

pasting to oo2 works fine for me. just not from after oo2 has been closed

Marcos Pinto (markybob) wrote :

ooo2 should conform to the freedesktop specification for copy/paste that gnome
2.12 and kde now follow.
http://www.freedesktop.org/wiki/Standards_2fclipboards_2dspec

Matthias Klose (doko) on 2006-03-12
Changed in openoffice.org2-amd64:
status: Unconfirmed → Confirmed
Matthias Klose (doko) wrote :

gnome-control-center: test assignment, rejected

Changed in gnome-control-center:
assignee: nobody → doko
status: Unconfirmed → Rejected
Matthias Klose (doko) wrote :

targeted as an enhancement by upstream

Changed in openoffice.org:
assignee: doko → nobody
Chris Cheney (ccheney) wrote :

This might be fixed in Novell's version, see:

https://bugzilla.novell.com/show_bug.cgi?id=90675

Which is closed as FIXED.

Changed in openoffice:
status: Unknown → Confirmed
Chris Cheney (ccheney) on 2008-06-13
Changed in openoffice.org:
status: Confirmed → Triaged
Chris Cheney (ccheney) on 2010-05-14
tags: added: hardy

This seems to be a duplicate of bug #11334, as that one is set as affecting OpenOffice too, and has the same upstream tracker reference as this one. Shouldn't this be set as a duplicate of that one?

papukaija (papukaija) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 11334, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

If this bug still affects you, please use the "This bug affect me too" option to increase the resolution priority:
https://bugs.launchpad.net/ubuntu/+bug/11334/+affectsmetoo

summary: - [Upstream] [hardy] OpenOffice bad interaction with gnome's clipboard
- management
+ [Upstream] OpenOffice bad interaction with gnome's clipboard management
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.