[Upstream] Writer converting .ott to rtf does not preserve text fields

Bug #211345 reported by Roman Brusa
4
Affects Status Importance Assigned to Milestone
LibreOffice
Fix Released
Medium
OpenOffice
Unknown
Low
libreoffice (Ubuntu)
Medium
Unassigned
openoffice.org (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: openoffice.org

1)
LibreOffice:
lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

OpenOffice:
lsb_release -rd
Description: Ubuntu 7.10
Release: 7.10

2)
LibreOffice:
apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

OpenOffice:
apt-cache policy openoffice.org
openoffice.org:
  Installiert:1:2.3.0-1ubuntu5.3
  Mögliche Pakete:1:2.3.0-1ubuntu5.3
  Versions-Tabelle:
 *** 1:2.3.0-1ubuntu5.3 0
        500 http://archive.ubuntu.com gutsy-updates/main Packages
        100 /var/lib/dpkg/status
     1:2.3.0-1ubuntu5 0
        500 http://archive.ubuntu.com gutsy/main Packages

3) What is expected to happen in LibreOffice Writer via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/211345/+attachment/253514/+files/Vorlage%20Brief.ott && unoconv --listener && unoconv -f rtf Vorlage\ Brief.ott && lowriter -nologo Vorlage\ Brief.ott Vorlage\ Brief.rtf

the text fields remain.

4) What happens instead is they disappear.

PARTIAL WORKAROUND: Convert to .rtf via AbiWord. This will not preserve the text field function but will preserve the words.

abiword --to=rtf --to-name=Vorlage\ Brief.rtf Vorlage\ Brief.ott && abiword Vorlage\ Brief.rtf

Revision history for this message
Roman Brusa (rb05-roman) wrote :
Revision history for this message
Chris Cheney (ccheney) wrote :

I confirmed this on upstream's openoffice.org 2.4.0

Changed in openoffice.org:
importance: Undecided → Low
status: New → Confirmed
Chris Cheney (ccheney)
Changed in openoffice.org:
status: Confirmed → Triaged
Revision history for this message
Pedro Villavicencio (pedro) wrote : Re: [Upstream] [hardy] OO Writer doesn't open/show RTF-File that it just wrote
Changed in openoffice:
importance: Undecided → Unknown
status: New → Unknown
Revision history for this message
In , Pvillavi (pvillavi) wrote :

this report has been opened here:

https://bugs.edge.launchpad.net/ubuntu/+source/openoffice.org/+bug/211345

"Creating a new document on the attached template (.ott) and saving it in RTF
results in OO Writer showing an empty page when re-opening the RTF-file. Word
(on another machine) can open and show the same file."

file:

http://launchpadlibrarian.net/13094368/Vorlage%20Brief.ott

Revision history for this message
In , Michael-ruess (michael-ruess) wrote :

I cannot reproduce the problem using OO 2.4.x and OO 3.0 on Windows and Linux
with native OOo build. It looks that this is a problem of the ubuntu own build.

Revision history for this message
In , Michael-ruess (michael-ruess) wrote :

Closed.

Revision history for this message
Chris Cheney (ccheney) wrote :

Do you still have this problem with openoffice.org 1:2.4.1-11ubuntu2 in Ubuntu 8.10?

Upstream claims they can't reproduce it and I can't reproduce it any longer on Ubuntu 8.10 either.

Changed in openoffice.org:
importance: Low → Undecided
status: Triaged → Incomplete
Revision history for this message
Chris Cheney (ccheney) wrote :

Actually nevermind I can still reproduce it on 1:2.4.1-11ubuntu2 after all. I will have to reconfirm on upstream version again so I can let them know upstream.

Changed in openoffice.org:
importance: Undecided → Low
status: Incomplete → Triaged
Revision history for this message
Chris Cheney (ccheney) wrote : Re: [Upstream] OO Writer doesn't open/show RTF-File that it just wrote

attached an output file on the upstream bug report to prove to them their software is buggy. :\

Revision history for this message
In , Chris Cheney (ccheney) wrote :

I'm seeing this issue on official OOo 3.0.0. So why is that the reporter and I
both see this and even with the official version when you don't? I will attach
the RTF file that 3.0.0 generated for me.

Revision history for this message
In , Chris Cheney (ccheney) wrote :

Created attachment 57515
output file from 3.0.0

Revision history for this message
In , Michael-ruess (michael-ruess) wrote :

I do not know where the difference is in what we all did to create the RTF. But
when I:
- drop the ott from Windows Explorer into OOo,
- save this as RTF,
- reopen -> it looks NOT empty.

However, we now got an RTF from you which will show empty in OOo but not in
Word. This should be enough to get this issue fixed.

Changed in openoffice:
status: Unknown → Confirmed
Revision history for this message
In , John Talbut (i-jt) wrote :

I have had the same problem. I had two .odt files which I saved as .rtf. I
could open one of the .rtf files successfully with OOo, the other would be blank
so I did some investigating of how they were different.

It seems to be something to do with the paragraph styles that OOo generates when
it saves as .rtf. I get a blank when I open the above attachment 57515 with OOo
so I opened it in a text editor. I deleted the unused styles (the document only
appears to use S1 so I deleted S2 - S12, lines 5 - 15 in the text editor) and lo
and behold I can open the file with OOo.

Revision history for this message
In , Hans Deragon (deragon) wrote :

I confirm the problem. The priority should be increased; whenever exporting to
MS Word fails, RTF can be an alternative. However, when this fall back is not
working either, no more options remain to transmit an editable document from the
Linux world to the Windows world.

This said, I have a resume written in ODT that cannot be rendered properly on MS
Word as .doc or .rtf, but it is not a blank page that shows up in MS Word when
reading the RTF; text with bad formating shows up. Thus this bug seams to be
OOo3 related only.

Chris Cheney (ccheney)
tags: added: gutsy
description: updated
tags: added: lo33
Changed in libreoffice (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
summary: - [Upstream] OO Writer doesn't open/show RTF-File that it just wrote
+ [Upstream] Writer converting .ott to rtf does not preserve text fields
Revision history for this message
In , Christopher M. Peñalver (penalvch) wrote :

Created attachment 47262
Vorlage Brief.ott

Downstream bug may be found at:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/211345

1) lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

3) What is expected to happen in LibreOffice Writer via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/211345/+attachment/253514/+files/Vorlage%20Brief.ott && unoconv --listener && unoconv -f rtf Vorlage\ Brief.ott && lowriter -nologo Vorlage\ Brief.ott Vorlage\ Brief.rtf

the text fields remain.

4) What happens instead is they disappear.

Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in openoffice.org (Ubuntu):
status: Triaged → Won't Fix
Revision history for this message
Björn Michaelsen (bjoern-michaelsen) wrote : migrating packaging from OpenOffice.org to Libreoffice

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

Revision history for this message
In , Jbf-faure-9 (jbf-faure-9) wrote :

Is RTF format able to handle such kind of text fields (placeholders)?
Abiword (2.5.8 under Ubuntu) save the name of the placeholder between < and >.
LO should do the same if placeholders are not supported by RTF, instead of removing it.

Best regards. JBF

Revision history for this message
In , Björn Michaelsen (bjoern-michaelsen) wrote :

[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html

Changed in df-libreoffice:
status: Confirmed → Incomplete
Revision history for this message
In , Christopher M. Peñalver (penalvch) wrote :

Problem reproducible in:
LOdev 3.5.0beta2
Build ID: 8589e48-760cc4d-f39cf3d-1b2857e-60db978
Microsoft Windows Vista Business 6.0.6002 Service Pack 2 Build 6002

Changed in openoffice:
status: Confirmed → Unknown
Changed in df-libreoffice:
status: Incomplete → Confirmed
Revision history for this message
In , Jbf-faure-9 (jbf-faure-9) wrote :

Tested with LO 3.5.1. Now LO seems to do the same as Abiword, it save the name of the placeholder.
@Christopher : Please could you verify on your side ?
If it is correct, I suggest to close this bug report as fixed.

Best regards. JBF

tags: added: i386 natty
Revision history for this message
In , Christopher M. Peñalver (penalvch) wrote :

Jean-Baptiste Faure, fixed in:

lsb_release -rd
Description: Ubuntu precise (development branch)
Release: 12.04

LibreOffice 3.5.1.2
Build ID: dc9775d-05ecbee-0851ad3-1586698-727bf66

Revision history for this message
In , Jbf-faure-9 (jbf-faure-9) wrote :

Thank you. Closing.

Changed in df-libreoffice:
status: Confirmed → Fix Released
Revision history for this message
Björn Michaelsen (bjoern-michaelsen) wrote :

fixed as per comment 13

Changed in libreoffice (Ubuntu):
status: Triaged → Fix Released
Changed in openoffice:
importance: Unknown → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.