Ubuntu

Hebrew .doc files show hindu numerals instad of arabic

Reported by Shai Berger on 2008-04-01
16
Affects Status Importance Assigned to Milestone
OpenOffice
Fix Released
Unknown
openoffice.org (Ubuntu)
Medium
Unassigned
Hardy
Medium
Chris Cheney

Bug Description

This bug is filed in order to stop Ubuntu from automatically accepting OpenOffice.org 2.4, until an important upstream bug is fixed.

The bug in question ( http://www.openoffice.org/issues/show_bug.cgi?id=86811 ) kills interoperability with Microsoft Office for Hebrew users.

Yotam Benshalom (benshalom) wrote :

I agree. This bug is unfortunately no less then ubuntu blocker in Hebrew speaking environment.

zohar (zoharsnir) wrote :

I also agree.

This OOo bug definitely means no Hebrew speaker can use this (2.4) version.

Since Word Processing is such a major use of PC's, if this OOo version will be the one installed by default it will mean that Hebrew speakers will get an ubuntu system which is "useless from the box".

rintintin (yonatanhak-gmail) wrote :

This bug must not find it's was into UBUNTU, otherwise all Hebrew newbies will kiss goodbye Linux for a long time.
It makes OOo unusable.

Yonatan Amir (yonatan-amir) wrote :

ditto here,this bug would be a disaster for Ubuntu adoption among Hebrew speakers.

Chris Cheney (ccheney) on 2008-04-01
Changed in openoffice.org:
importance: Undecided → Medium
status: New → Confirmed
Changed in openoffice:
status: Unknown → Confirmed
David Cohen (cdavid68) wrote :

Confirmed. A real usability disaster. Can't use 8.04 unless it's fixed.

Hezy Amiel (hezy) wrote :

My friends asked me about OpenOffice 2.4 and I had to recommend to skip the upgrade. However, most linux users relay on their distribution to make this decision. If this bug will be left as the default for ubuntu 8.04 I will have to recommend avoiding the ubuntu upgrade as well. I really hope that this horrible bug will be fixed as soon as possible.

Changed in openoffice:
status: Confirmed → Fix Released
Chris Cheney (ccheney) on 2008-06-13
Changed in openoffice.org:
status: Confirmed → Triaged
importance: Undecided → Medium
status: New → Triaged
assignee: nobody → ccheney
Steve Langasek (vorlon) wrote :

according to the upstream task, this is fixed in OOo 2.4.1 which is now available in intrepid and hardy-proposed. Please test the package there and let us know whether there are still any problems.

Changed in openoffice.org:
status: Triaged → Fix Released
status: Triaged → Fix Committed
Shai Berger (shai-platonix) wrote :

Yes, well, Ubuntu has included the patch for this bug already in the 2.4.0 versions. I haven't had any problems since I upgraded to Hardy, more than a month ago (there was a separate bug for Ubuntu with the same id, that was closed a few months ago).

Steve Langasek (vorlon) wrote :

ok, thanks for the clarification, Shai. Marking the bug as fixed in hardy.

Changed in openoffice.org:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.