[upstream] openoffice apps are rude and steal wm focus

Bug #20767 reported by desrt on 2005-09-02
44
This bug affects 4 people
Affects Status Importance Assigned to Milestone
OpenOffice
Invalid
Undecided
Unassigned
openoffice.org (Ubuntu)
Low
Unassigned

Bug Description

1. start an openoffice2 app from the menu
2. get bored because it's taking an awful long time to load
3. decide to make use of the fine multitasking capabilities of the linux
operating system and start working in another window
4. openoffice rudely pops open on top of what you were doing and steals input focus

expected result is that open office should open under the application that
you're currently working with and definitely not steal input focus.

Matthias Klose (doko) wrote :

fixed in 2.0.2

Changed in openoffice.org2-amd64:
status: Unconfirmed → Fix Released
Roman Polach (rpolach) wrote :

I can still see this problem in edgy,
openoffice.org-writer 2.0.4-0ubuntu4,
reopen?

warjowuch (lulkoek) wrote :

I can still see this in gutsy too?

Jarno Suni (jarnos) wrote :

People don't seem to belive the bug is fixed.

Changed in openoffice.org2-amd64:
status: Fix Released → Confirmed
Jarno Suni (jarnos) wrote :

There is a patch:
Start OpenOffice.org by command:
kstart --iconify openoffice -nologo
(kstart has some KDE dependencies.)

Jarno Suni (jarnos) wrote :

I didn't test the amd64 package, but I think the problem is more general.

Matthias Klose (doko) on 2008-04-02
Changed in openoffice.org2-amd64:
assignee: doko → nobody

Correction: Contrary to what I told before, apparently kstart doesn't have KDE dependencies, but the 'k' comes from Kerberos.

Jarno Suni (jarnos) wrote :

Correction to correction: kstart command needs kdebase-bin-kde3 package (and its dependencies). There is also kstart package, but it is for other purpose.

Paul Rensing (paulrensing) wrote :

I have a more general complaint about startup. As OOo is loading a file (but not there yet), if you mess with the window, it completely forgets what you have done and resets the window. For instance, if you drag the window while it is loading the file, it puts it back after it is fully loaded. I typically open large CSV files in the spreadsheet, so it takes a while to fully update the window.

Chris Cheney (ccheney) wrote :

Is anyone still seeing this bug under Ubuntu 8.04 openoffice.org 1:2.4.1-1ubuntu2?

Thanks,

Chris Cheney

Changed in openoffice.org:
status: Confirmed → Incomplete
Jarno Suni (jarnos) wrote :

I do, but I am not sure, if it is a bug in OpenOffice.org. Maybe it is a bug, if the "-minimized" command line option is not supposed to open the software minimized. The man page tells "keep startup bitmap minimized".

But anyway you can add a menu item that uses kstart to start OpenOffice.org minimized.

In Xubuntu 8.04, you can tell the window manager not to give focus automatically to newly created windows in window manager settings.

Chris Cheney (ccheney) on 2008-07-20
Changed in openoffice.org:
status: Incomplete → Confirmed
Jarno Suni (jarnos) wrote :

I didn't meant the second "not" on my last comment.

See also Bug 250101.

Liam Zwitser (noliamhere) wrote :

Yep, I am still experiencing this bug under hardy with the latest updates

Chris Cheney (ccheney) on 2008-10-19
Changed in openoffice.org:
status: Confirmed → Triaged
Sunjae Park (darehanl) wrote :

OpenOffice says this issue is fixed ( http://qa.openoffice.org/issues/show_bug.cgi?id=49426 and http://qa.openoffice.org/issues/show_bug.cgi?id=19976 ) but I still see this bug in Hardy.

Jarno Suni (jarnos) wrote :

I can not start openoffice iconified by command "kstart --iconify openoffice -nologo" in ubuntu 8.10 even if I could do it in 8.04.

Chris Cheney (ccheney) on 2009-01-24
Changed in openoffice:
importance: Undecided → Unknown
status: New → Unknown
Changed in openoffice:
status: Unknown → Fix Released
Chris Cheney (ccheney) wrote :

I believe this bug is fixed in OOo 3.0.1 if it is not please feel free to reopen the bug with current detailed and updated information.

Thanks,

Chris Cheney

Changed in openoffice.org (Ubuntu):
status: Triaged → Fix Released
Julien Olivier (julo) wrote :

I tested OpenOffice 3.0.1 on Ubuntu and I still have the problem, but only when using plain metacity (not compiz).

OpenOffice steals the focus at different times:
 - when it displays the splash screen
 - when the main window is displayed
 - when the document is loaded

Julien Olivier (julo) on 2009-04-23
Changed in openoffice.org (Ubuntu):
status: Fix Released → New
Chris Cheney (ccheney) on 2009-04-23
Changed in openoffice:
importance: Unknown → Undecided
status: Fix Released → New
Changed in openoffice.org (Ubuntu):
status: New → Triaged

Following the steps in Ryans initial report

1. start an openoffice2 app from the menu (opened oowriter)
2. get bored because it's taking an awful long time to load
3. decide to make use of the fine multitasking capabilities of the linux
operating system and start working in another window
4. openoffice rudely pops open on top of what you were doing and steals input focus

This still happens in 3.1.1 on 10.04

Changed in openoffice:
importance: Undecided → Unknown
status: New → Unknown
Changed in openoffice:
status: Unknown → Invalid
Julien Olivier (julo) wrote :

Would you mind explaining us what makes this bug invalid, please ?

phobie (phobie) wrote :

It was a automatic change because of
http://qa.openoffice.org/issues/show_bug.cgi?id=49426
which has been marked as duplicate of
http://qa.openoffice.org/issues/show_bug.cgi?id=19976
.
I don't know why the "Bug Watch Updater" takes tree weeks to update the status.

Changed in openoffice:
status: Invalid → Unknown
Julien Olivier (julo) wrote :

Thanks for the information.

However, this bug is not fixed at all. So, either this bug or http://qa.openoffice.org/issues/show_bug.cgi?id=19976 should be re-opened.

Changed in openoffice:
status: Unknown → Fix Released
Rob Kudla (lists-kudla) wrote :

This is still happening for me in OOO310m19 under Karmic. If the automatic status updater is able to detect a fix having been released, I think it should include a link to that alleged fix.

I can confirm it still happens in Lucid:
- with Metacity, OO steals focus when the main window has finished loading
- with Compiz, all applications steal focus, so can't test
- with Mutter/GNOME Shell, OO steals focus as with Metacity

Upstream said a year ago, after the bug was fixed:
> a) it was integrated two and a half years ago in SRC680m192
> b) the patched code doesn't even exist anymore

Something must have gone wrong, I'm reopening upstream.

I reported a new issue because I couldn't reopen bug myself, and the original report is form 2003, code is likely to have changed in that regard.

Changed in openoffice:
status: Fix Released → Unknown
Changed in openoffice:
status: Unknown → New
Robert Roth (evfool) wrote :

Still an issue with OpenOffice 3.2.1-7ubuntu1, hopefully this will be fixed in the LibreOffice build that will be included in Natty(if LibreOffice will be the default in Natty).

Changed in openoffice.org (Ubuntu):
status: Triaged → Won't Fix
Changed in openoffice:
importance: Unknown → Undecided
status: New → Invalid

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.