[Upstream] cursor does not change to arrow hovering over "X" box

Bug #207220 reported by Christian González on 2008-03-26
4
Affects Status Importance Assigned to Milestone
LibreOffice
Confirmed
Low
OpenOffice
Invalid
Medium
libreoffice (Ubuntu)
Low
Unassigned
openoffice.org (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: openoffice.org

1) lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        500 http://us.archive.ubuntu.com/ubuntu/ natty-proposed/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

3) What is expected to happen in LibreOffice Writer via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/207220/+attachment/2134007/+files/Unbenannt%201.doc && lowriter -nologo Unbenannt\ 1.doc

hover ones mouse cursor over the checkbox and it changes from the I to an arrow.

4) What happens instead is it remains an I.

Original Reporter Comments: Ubuntu hardy beta, OOo 2.4.0-rc2-1ubuntu3

Chris Cheney (ccheney) wrote :

Works for me just fine in openoffice.org 1:2.4.0~rc2-1ubuntu3. If you still have this problem then please attach the document where this issue can be seen. I tested in both Database and Word Processor and checkboxes on both switch from the text cursor to an arrow when I go over the checkbox.

Changed in openoffice.org:
status: New → Incomplete
Christian González (droetker) wrote :

Hm - funny.
Maybe it has to do with that document - it is read only.
(attached as .odt or here as link as .doc)

http://www.netzwerk-essstoerungen.at/kongress08/download/k08_registrationform.doc

Chris Cheney (ccheney) on 2008-03-26
Changed in openoffice.org:
status: Incomplete → New
Chris Cheney (ccheney) wrote :

The odt version doesn't open properly in either upstream 2.4.1 or 3.0m24. However saving the doc file back to odt makes it work fine. It appears it somehow got converted incorrectly in an old version of OpenOffice.org?

Changed in openoffice.org:
status: New → Invalid
Chris Cheney (ccheney) wrote :

Sorry, I forgot to verify with Ubuntu's version, so yes this bug still seems to exist and it seems to be ooo-build specific.

Thanks,

Chris Cheney

Changed in openoffice.org:
importance: Undecided → Medium
status: Invalid → Triaged

See this file:

http://www.netzwerk-essstoerungen.at/kongress08/download/k08_registrationform.doc

In ooo-build version hovering over the checkboxes doesn't change the cursor from the insert(?) cursor to the pointer like in official openoffice.org. Also the checkboxes look a lot different than they do in official openoffice.org and not really like checkboxes instead like "X" boxes.

Changed in openoffice:
importance: Undecided → Unknown
status: New → Unknown
Changed in openoffice:
status: Unknown → Confirmed

This is down to Florian's sexy fields work, that substantially improves interop and field functionality. Try tabbing through that form, and filling it out when using up-stream's OO.o ;->

back to shared owner for re-eval.

The problem is still in OOo-3.1.1 => assigning to Cedric

Christian A. Reiter, the attached file did not seem to have a checkbox. As well, the hyperlink mentioned does not contain the file http://www.netzwerk-essstoerungen.at/kongress08/download/k08_registrationform.doc Could you please attach a file that demonstrates this problem?

Changed in openoffice.org (Ubuntu):
status: Triaged → Incomplete
Christian González (droetker) wrote :

Thats maybe because the part of the file name "kongress08" and k08_registrationform gives a hint that this bug was introduced in 2008 and now we have 2011 ;-)

Anyway - just create an empty file with writer, put a checkbox in it labeled "test" (with View->Toolbars->Form control).
The cursor changes to the standard arrow when hovering over the checkbox.
Now save the file as .doc, not as .odt, and reopen it.
Now the cursor refuses to change.

Reproduced with
LibreOffice 3.3.2
OOO330m19 (Build:202)
tag libreoffice-3.3.2.2, Ubuntu package 1:3.3.2-1ubuntu5
on Ubuntu lucid lynx, today.
File attached,
cheers, Christian

Christian A. Reiter, this is not Wishlist as the icon switch occurred in a prior release, as intended. Marking back to Medium.

Changed in openoffice.org (Ubuntu):
importance: Medium → Wishlist
status: Incomplete → Triaged
importance: Wishlist → Medium
Changed in libreoffice (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
description: updated
tags: added: lo33

Christian A. Reiter, what specific steps were done to input the clickable X box object into the attached .doc file? Word?

The only Writer checkbox found in View -> Toolbars -> Form Control was a box with a check mark inside when clicked, and the cursor changes to the arrow appropriately when hovered over it.

Changed in libreoffice (Ubuntu):
status: Triaged → Incomplete
Changed in openoffice.org (Ubuntu):
status: Triaged → Incomplete
Christian González (droetker) wrote :

This is funny.
No, I did this in the LibreOffice version i specified above, 5 minutes before sending the last message.
This is weird - I just tried to do it again, and got the same: a(differently looking) checkbox, which is white and not grey, and with the correct hovering behaviour.
have a look at this file, there are both of them.
I just saved it as .doc not as .odt.
I unzipped the odt to give you the content.xml as well - I cant see much things in it, you maybe more.

Christian González (droetker) wrote :
Christian González (droetker) wrote :
Changed in openoffice.org (Ubuntu):
status: Incomplete → Triaged
Changed in libreoffice (Ubuntu):
importance: Medium → Low
status: Incomplete → Triaged
summary: - [ooo-build] cursor should change when hovering over checkbox
+ [ooo-build] cursor does not change to arrow hovering over "X" box

Created attachment 47509
Unbenannt 1.doc

Downstream bug may be found at:
https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/207220

Novell bug may be found at:
https://bugzilla.novell.com/show_bug.cgi?id=437569

1) lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        500 http://us.archive.ubuntu.com/ubuntu/ natty-proposed/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

3) What is expected to happen in LibreOffice Writer via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/207220/+attachment/2134007/+files/Unbenannt%201.doc && lowriter -nologo Unbenannt\ 1.doc

hover ones mouse cursor over the checkbox and it changes from the I to an arrow.

4) What happens instead is it remains an I.

Changed in openoffice.org (Ubuntu):
importance: Medium → Low
summary: - [ooo-build] cursor does not change to arrow hovering over "X" box
+ [Upstream] [ooo-build] cursor does not change to arrow hovering over "X"
+ box
Changed in df-libreoffice:
importance: Unknown → Low
status: Unknown → Confirmed
Changed in openoffice.org (Ubuntu):
status: Triaged → Won't Fix

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html

Changed in df-libreoffice:
status: Confirmed → Incomplete

reproduced in LibO 3.6.0 master on Fedora 64 bit
and in LibO 3.5.0 beta on Windows XP 32 bit

Changed in df-libreoffice:
status: Incomplete → Confirmed

On pc Debian x86-64 with master sources updated today, I still reproduce this behaviour.

Michael: any idea about this or perhaps some code pointer if it can be an easyhack (for a dev of course! :-))

Changed in openoffice:
importance: Unknown → Medium

The document is, unfortunately, not available any more under that URL.

Changed in openoffice:
status: Confirmed → Invalid

Look at https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/207220 (the downstream Ubuntu bug), I have attached some files (Comment #10 onwards) there. They are stripped down versions of the faulty behaviour.

Adolfo Jayme (fitojb) on 2014-10-17
summary: - [Upstream] [ooo-build] cursor does not change to arrow hovering over "X"
- box
+ [Upstream] cursor does not change to arrow hovering over "X" box

** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.3.5 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.