Open office appears to complete spell check when no spell check dictionary is installed

Bug #203759 reported by TKFRC on 2008-03-18
34
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenOffice
Confirmed
Unknown
openoffice.org (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: openoffice.org

Open office sets the language default to Canadian English for my Canadian machine. There is no Canadian spell check installed but when I click Spell Check I get the same message as I would if I had no spelling errors. I've sent out two major projects with typos as a result.

jlparise (jlparise) wrote :

Thanks for posting this bug report to help make Ubuntu and Open Office better!

In order to properly diagnose this issue we will need the following infomation:

1) What version of Ubuntu are you running?
2) What version of Open Office are you running? Please upload the output of dpkg -l openoffice.org

Changed in openoffice.org:
status: New → Incomplete
Chris Cheney (ccheney) on 2008-03-19
Changed in openoffice.org:
importance: Undecided → Low
status: Incomplete → Confirmed
Changed in openoffice:
status: Unknown → Confirmed

I reproduce this problem with a fresh install of 8.04 here in Canada:

administrator@zeya:~$ dpkg-query -W openoffice.org-core
openoffice.org-core 1:2.4.0-3ubuntu6
administrator@zeya:~$

Though I can work around this problem using Format > Character > Language and choosing "English (USA)", several students for whom I installed Ubuntu complain that spellcheck is broken.

I notice this problem on a fresh install of 8.04 in Canada, "AutoSpellcheck" appears to be on, but does not detect misspellings and Tools > Spellcheck reports that spellcheck completed successfully, though misspellings are not detected.

I think in both cases (using AutoSpellcheck or Tools > Spellcheck) OO.org should warn the user that no dictionary is available, instead of reported that spellcheck completed successfully.

Thanks and best wishes, Jack

CTenorman (ctenorman) wrote :

I can confirm this bug. Though I know the priority of this bug might appear low at first, it's actually a bug of at least moderate, if not more, concern. Most people use their computer to type documents at some point or other, and expect spell checking on the fly as expected behaviour. Joe user likely wouldn't have a clue how to install a new dictionary, or perhaps even change to the installed UK or other dictionary in Openoffice. Given that there are likely at least a few thousand "Joe users" floating around Canada, a few thousand people are likely to either stop using Ubuntu or get really frustrated with the experience. Often these are people who just want to get work done, and had their computer setup by someone else who's now long gone.

The easy temporary fix for this is to simply have the program use the UK dictionary. It's already installed by default, and is so similar to Canadian English that hardly any users would notice the difference. Or perhaps copy the UK package, point Ubuntu to the copy that would be called Canadian in the repos, and worry later about making the dictionary truly Canadian. Again, Canadian English and UK English are very similarl, so changing that would be a very low priority indeed.

Chris Cheney (ccheney) on 2008-06-13
Changed in openoffice.org:
status: Confirmed → Triaged
Mateosan (lingerhaus) wrote :

Thus bug is still present in Intrepid Ibex. I can confirm that using Uk dictionary does not fix the problem. I'm trying to use the US dictionary and despite being marked it does not work. Only the format hack above seems to work. I'm running ubuntu 8.10 with hunspell and aspell dictionaries installed. All the appropriate boxes are checked, and all of the language preferences are set to English. I've done everything I've been told from all forums and all other launch pad listings for this a similar bugs. Is this going to be fixed in Jaunty?

Can anyone still reproduce this in Lucid?

Just reproduced it myself. Definitely still a big issue.

summary: - [Upstream] [hardy] Open office appears to complete spell check when no
- spell check dictionary is installed
+ Open office appears to complete spell check when no spell check
+ dictionary is installed
Changed in openoffice.org (Ubuntu):
status: Triaged → Won't Fix

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.