[upstream] OpenOffice.org should use F11 for "Full Screen" for consistency

Bug #198932 reported by Mark Stosberg on 2008-03-05
4
Affects Status Importance Assigned to Milestone
OpenOffice
Confirmed
Unknown
openoffice.org (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: openoffice.org2

Ubuntu has done a good job of having applications consistently use "F11" to toggle their full screen modes. The consistency creates a more pleasant experience, and makes the shortcut easier to remember. At least the following applications support F11 for "Full Screen":

Gnome Terminal
Firefox 3
Eye of Gnome Image Viewer
Gimp
Evince Document Viewer
Totem Movie Player
Rhythmbox Music Player

However, in Gutsy Open Office Writer is using "Ctrl-Shift-J" for "Full Screen".

Even if that's the default upsteam, Ubuntu should modify this default to be more consistent with the rest of the desktop.

     Mark

Chris Cheney (ccheney) on 2008-07-26
Changed in openoffice.org2:
importance: Undecided → Wishlist
status: New → Confirmed
Chris Cheney (ccheney) on 2008-10-20
Changed in openoffice.org:
status: Confirmed → Triaged
Chris Cheney (ccheney) on 2008-10-21
Changed in openoffice:
importance: Undecided → Unknown
status: New → Unknown
Changed in openoffice:
status: Unknown → Confirmed
grikdog (dcoshel) wrote :

F11 may mean Full Screen, but Full Screen means brain dead for newbies who don't know about F11 and can't find it in the reduced menu structure at the top of the screen. Go ahead, use F11 for Full Screen, but please ALSO use the sanity inducing ESC key to let the neophytes regain control.

Lem (lem-jjr) wrote :

This seems to be the way OpenOffice.org behaves in Ubuntu 10.04 LTS .. however the help file says that the shortcut key for the Styles and Formatting menu is F11. Not sure if I should open a new bug?

Lem (lem-jjr) wrote :

Sorry that was a terrible post, lacking information and specificity, let me try again.

I'm using OpenOffice.org in Ubuntu 10.04 LTS AMD64. Pressing F11 does indeed make the OOo window fullscreen, with the escape key returning to non-fullscreen mode.

The help file included in 10.04's version of OOo (as of 2010-08-18) states that the keyboard shortcut to open the Styles and Formatting window is F11. This of course goes into fullscreen mode.

In the Format menu, the Styles and Formatting item has no hotkey listed beside it, but instead gets a tick beside it when the Styles and Formatting window is open.

Perhaps it's just the help file that needs updating. I assume this is Ubuntu specific, I haven't tested other distributions. This is definitely a bug, albeit a small one.

Robert Roth (evfool) wrote :

I also agree that the help file should be upgraded accordingly to the ubuntu-specific changes made, but I think that this problem has been fixed, as F11 now goes into fullscreen, and the help issue is a separate one.

Changed in openoffice.org (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.