[Upstream] Impress inserted video does not play

Bug #172262 reported by tuharsky on 2007-11-27
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
LibreOffice
Confirmed
Wishlist
OpenOffice
Unknown
Unknown
libreoffice (Ubuntu)
Wishlist
Unassigned
openoffice.org (Ubuntu)
Wishlist
Unassigned

Bug Description

WORKAROUND: Keep inserted video files in the same directory as the Impress file or manually update each inserted video file via Edit -> Links.

1) HOST:

lsb_release -rd
Description: Ubuntu 10.10
Release: 10.10

GUEST:

lsb_release -rd
Description: Ubuntu 10.10
Release: 10.10

2) HOST:

apt-cache policy libreoffice-impress
libreoffice-impress:
  Installed: 1:3.3.0-1maverick1
  Candidate: 1:3.3.0-1maverick1
  Version table:
 *** 1:3.3.0-1maverick1 0
        500 http://ppa.launchpad.net/libreoffice/ppa/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status

apt-cache policy totem
totem:
  Installed: 2.32.0-0ubuntu1
  Candidate: 2.32.0-0ubuntu1
  Version table:
 *** 2.32.0-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status

 apt-cache policy virt-manager
virt-manager:
  Installed: 0.8.4-7ubuntu1.1
  Candidate: 0.8.4-7ubuntu1.1
  Version table:
 *** 0.8.4-7ubuntu1.1 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick-updates/main i386 Packages
        100 /var/lib/dpkg/status
     0.8.4-7ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick/main i386 Packages

GUEST:

apt-cache policy openoffice.org-impress
openoffice.org-impress:
  Installed: 1:3.2.1-7ubuntu1
  Candidate: 1:3.2.1-7ubuntu1
  Version table:
     1:3.2.1-7ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status

3) What is expected to happen is when one embeds a video file into a blank Impress file, or opens an Impress file with video in it via openoffice.org-impress or libreoffice-impress ( sudo add-apt-repository ppa:libreoffice/ppa && sudo apt-get update && sudo apt-get -y upgrade && sudo apt-get -y install libreoffice-impress ) via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/172262/+attachment/250365/+files/test.odp && soffice -impress test.odp && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/172262/+attachment/250368/+files/instalacia.ogg && totem instalacia.ogg

it shows the first frame of the embedded video in openoffice.org-impress or libreoffice-impress, plays the video in editing mode, and plays the video in Slide Show, just as it does in totem.

4) What happens instead is that in openoffice.org-impress or libreoffice-impress you see a grey rectangle where the video file is supposed to be, clicking the play button in the right-hand pane does not play the video, nor does clicking Slide Show -> Slide Show. The embedded video file plays fine in totem.

Original description:
When I put a video into presentation and change its size (doesn't matter, whether I keep aspect ratio), the picture is low quality on presentation mode playback, every font has some black dots inbound and so on. Seems like an issue with anti aliasing.

Feisty plays the video OK.

Hi,
Can you please provide me with information regarding your graphics card and version of OpenOffice?
Code of conduct is also worth following as some members of the community may have found your choice of language offensive.

Thanks a lot,

description: updated
description: updated
Changed in openoffice.org:
assignee: nobody → elliot-hughes
status: New → Incomplete
tuharsky (tuharsky) wrote :

Hi,

as of the language, the video is quite useless by the means of presentation (if only I wouldn't wish to torped out the presented thing ;-)
so I assume the term "crappy" is technically allright, however if someone finds it offending, I don't object the changes.

As of information, it is Compaq nx6310 with Intel 945 graphics. OpenOffice.org is of version 2.3 (distributional).

Elliot Hughes (elliot-hughes) wrote :

I see your point - and it'd have to be quite a sensitive person to be offended, but its probably better to stay on the most family safe side possible if it doesn't disguise the meaning too much.

Back on topic I'll see if I can reproduce the bug next time I get a moment, then I will be able to confirm.

Thanks for your bug and continued responsiveness.
Elliot

Chris Cheney (ccheney) on 2008-03-21
Changed in openoffice.org:
assignee: elliot-hughes → nobody
status: Incomplete → New
Chris Cheney (ccheney) wrote :

Do you still have this problem on Ubuntu hardy with openoffice.org 1:2.4.0~rc2-1ubuntu3?

Thanks,

Chris Cheney

Changed in openoffice.org:
status: New → Incomplete
tuharsky (tuharsky) wrote :

Sorry, the attachment is for other issue. Please delete.

tuharsky (tuharsky) wrote :

Starting from CD, Ubuntu Hardy 8.04b is even worse. The video is not even shown in editation mode, and in presentation mode, it kinda visibly "zoomz" from initial size to the specified size, and then exists immediately.

Other words, the VIDEO DOSEN'T PLAY infact, only the first frame is being shown for some 1/2 sec.

Chris Cheney (ccheney) wrote :

Can you attach an example presentation with this problem? Playing video for me works perfectly on Ubuntu hardy

Thanks,

Chris Cheney

tuharsky (tuharsky) wrote :
tuharsky (tuharsky) wrote :

Follows the presentation (ordinary empty, You can create Yourselve also) and the video to place into (save into the same location as presentation)

tuharsky (tuharsky) wrote :
Chris Cheney (ccheney) on 2008-04-01
Changed in openoffice.org:
status: Incomplete → New
Chris Cheney (ccheney) wrote :

I believe that this bug has been corrected in Ubuntu 8.04 that is currently available. I can't reproduce this bug and looking at the video itself in totem, it has no anti aliasing on the fonts which may be the problem you are speaking of?

Changed in openoffice.org:
status: New → Fix Released
tuharsky (tuharsky) wrote :

With Ubuntu 10.10, video is not even shown in editation mode, just a grey rectangle is displayed. In presentation mode, video dosen't play either.

Changed in openoffice.org (Ubuntu):
status: Fix Released → Confirmed

When you insert a movie in a slideshow by Insert > Movie and Sound there is a small problem: it is impossible to retrieve the path of the inserted file. It is not listed in Edit > Links...
That is very annoying: for example if you want to move the slideshow to another location you need to move such files too. That may be difficult if you have several files in the directory and if you have forgot which file you inserted.

Please, add this information somewhere.

Best regards. JBF

There's work-in-progress around embedding sound/video files into the ODF container, see here: http://cgit.freedesktop.org/libreoffice/build/tree/patches/dev300/impressmedia-features.diff

In Ubuntu 10.10, downloaded https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/172262/+attachment/250365/+files/test.odp and opened in libreoffice-impress, does not show the movie either in editing mode or Slide Show. Downloaded video https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/172262/+attachment/250368/+files/instalacia.ogg and played fine in totem. Opened blank libreoffice-impress file, inserted video file, does not play in editing mode or Slide Show.

lsb_release -rd
Description: Ubuntu 10.10
Release: 10.10

apt-cache policy totem
totem:
  Installed: 2.32.0-0ubuntu1
  Candidate: 2.32.0-0ubuntu1
  Version table:
 *** 2.32.0-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status

apt-cache policy libreoffice-impress
libreoffice-impress:
  Installed: 1:3.3.0-1maverick1
  Candidate: 1:3.3.0-1maverick1
  Version table:
 *** 1:3.3.0-1maverick1 0
        500 http://ppa.launchpad.net/libreoffice/ppa/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status

tags: added: lo33
summary: - [Gutsy] Impress video Low Quality - Suspected anti aliasing problem
+ [Impress inserted video does not play
summary: - [Impress inserted video does not play
+ Impress inserted video does not play
description: updated

$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=10.10
DISTRIB_CODENAME=maverick
DISTRIB_DESCRIPTION="Ubuntu 10.10"

2.6.35-26-generic #46-Ubuntu SMP Sun Jan 30 08:10:51 UTC 2011 i686 GNU/Linux

I cannot reproduce on Ubuntu's OOo:
$ cat /usr/lib/openoffice/program/versionrc
[Version]
AllLanguages=en-US
BuildVersion=ooo-build 3.2.1.4, Ubuntu package 1:3.2.1-7ubuntu1.1
buildid=320m19(Build:9505)
ExtensionUpdateURL=http://updateext.services.openoffice.org/ProductUpdateService/check.Update
OOOBaseVersion=3.2
ProductBuildid=9505
ProductMajor=320
ProductMinor=19
ProductSource=OOO320
UpdateID=OpenOffice.org_3_en-US
UpdateURL=
UpdateUserAgent=<PRODUCT> (${buildid}; ${_OS}; ${_ARCH};
BundledLanguages=${AllLanguages})
Vendor=Debian and Ubuntu
$ apt-cache policy openoffice.org-impress
openoffice.org-impress:
  Installed: 1:3.2.1-7ubuntu1.1
  Candidate: 1:3.2.1-7ubuntu1.1
  Version table:
 *** 1:3.2.1-7ubuntu1.1 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick-updates/main i386
Packages
        500 http://security.ubuntu.com/ubuntu/ maverick-security/main i386
Packages
        100 /var/lib/dpkg/status
     1:3.2.1-7ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick/main i386 Packages

Also created another test presentation: testNoOp.odp (attached). Note that instalacia.ogg must be in
the same folder as test.odp or testNoOp.odp to work properly.

@Christopher: you are using a PPA version of LibreOffice (500
http://ppa.launchpad.net/libreoffice/ppa/ubuntu/ maverick/main i386), please
file a bug against that PPA version and that package.

NoOp (glgxg) wrote :

<quote>
Note that instalacia.ogg must be in
the same folder as test.odp or testNoOp.odp to work properly.
</quote>

Correction: instalacia.ogg can be in another folder _if_ the link in the presentation is modified and updated (Edit|Links|Modify|Update).

Changed in libreoffice:
importance: Unknown → High
status: Unknown → Confirmed

NoOp, thank you for working together on this bug and helping make Ubuntu better. I confirmed your workaround via the following tests:

In Ubuntu 10.10, in both libreoffice-impress & openoffice.org-impress at the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/172262/+attachment/1827497/+files/testNoOp.odp && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/172262/+attachment/250368/+files/instalacia.ogg && soffice -impress testNoOp.odp

A popup box notes: Update all Links? -> clicked Yes button -> clicked on the grey box with a question mark -> Play button, first time it played for a second then stopped. Second and subsequent times did not play at all. However, pressed F5 and the video was displayed in it's entirety. Closed the file. At the Terminal:

mv instalacia.ogg ~/ && soffice -impress testNoOp.odp

A popup box notes Update all Links? -> clicked Yes button -> grey box with a question is now a grey box with a speaker & waves coming out. Clicking Play button or F5 does not show the video. Clicked Edit -> Links -> Modify button -> instalacia.ogg -> Open button -> Close button -> Play button did not play at all. However, pressed F5 and the video was displayed in it's entirety.

lsb_release -rd
Description: Ubuntu 10.10
Release: 10.10

apt-cache policy libreoffice-impress
libreoffice-impress:
  Installed: 1:3.3.0-1maverick1
  Candidate: 1:3.3.0-1maverick1
  Version table:
 *** 1:3.3.0-1maverick1 0
        500 http://ppa.launchpad.net/libreoffice/ppa/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status

lsb_release -rd
Description: Ubuntu 10.10
Release: 10.10

apt-cache policy openoffice.org-impress
openoffice.org-impress:
  Installed: 1:3.2.1-7ubuntu1
  Candidate: 1:3.2.1-7ubuntu1
  Version table:
     1:3.2.1-7ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status

Regarding your comment:

> @Christopher: you are using a PPA version of LibreOffice (500 http://ppa.launchpad.net/libreoffice/ppa/ubuntu/ maverick/main i386), please file a bug against that PPA version and that package.

It is known a PPA is being used & the bug against it is this bug. ;) Following the directions as per http://wiki.documentfoundation.org/BugReport#Reporting_Ubuntu_bugs this bug was tagged with lo33. As well, this bug addresses the same problem (& workaround) in both openoffice.org-impress & libreoffice-impress, triangulating the efforts of the Ubuntu, LibreOffice, & OOo communities. Thank you for your understanding.

description: updated

Confirmed same problem (& workaround) in Ubuntu 11.04, libreoffice-impress.

lsb_release -rd
Description: Ubuntu natty (development branch)
Release: 11.04

apt-cache policy libreoffice-impress
libreoffice-impress:
  Installed: 1:3.3.0-1ubuntu1
  Candidate: 1:3.3.0-1ubuntu1
  Version table:
 *** 1:3.3.0-1ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages
        100 /var/lib/dpkg/status

Changed in libreoffice (Ubuntu):
status: New → Confirmed
NoOp (glgxg) wrote :

I'm afraid that you've misunderstood; this is not a workaround. OOo has never "embeded" a video into the impress file (with the possible exception of https://bugs.launchpad.net/bugs/660807 - which is an anomaly and different issue - not a duplicate) and has always been the case. The tests that I performed were not 'workarounds' but instead demontrating that this issue is invalid/fixed.

If you wish to have video files "embeded" into an .odp, then please file a wishlist bug requesting that 'enhancement'. Please also be sure to file the bug under the proper package (OOo or LO).

Further, if you are going to throw libreoffice into the mix (this bug was/is filed under openoffice.org) please do so at:
https://bugs.launchpad.net/ubuntu/+source/libreoffice, or with the PPA maintainers where you obtained your LO packages. Please do not intermix OOo bugs with LO bugs - they are not the same. Please also do the same for the "upstream" http://bugs.freedesktop.org/show_bug.cgi?id=33860 that you filed.

As an added note: I've tested the same .odp/.ogg files in Natty using LibreOffice 1:3.3.0-1ubuntu1 using the test .odp w/.ogg files - works in that version as well.

NoOp (glgxg) wrote :

Also tested in Lucid 10.04:

$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=10.04
DISTRIB_CODENAME=lucid
DISTRIB_DESCRIPTION="Ubuntu 10.04.2 LTS"
lucid@lucid-desktop:~$ uname -a
Linux lucid-desktop 2.6.32-28-generic #55-Ubuntu SMP Mon Jan 10 21:21:01 UTC 2011 i686 GNU/Linux
lucid@lucid-desktop:~$ cat /usr/lib/openoffice/program/versionrc
[Version]
AllLanguages=en-US
BuildVersion=ooo-build 3.2.0.10, Debian 1:3.2.0-7ubuntu4.2, Wed Jan 26 22:22:24 UTC 2011
buildid=320m12(Build:9483)
ExtensionUpdateURL=http://updateext.services.openoffice.org/ProductUpdateService/check.Update
OOOBaseVersion=3.2
ProductBuildid=9483
ProductMajor=320
ProductMinor=12
ProductSource=OOO320
UpdateID=OpenOffice.org_3_en-US
UpdateURL=
UpdateUserAgent=<PRODUCT> (${buildid}; ${_OS}; ${_ARCH}; BundledLanguages=${AllLanguages})
Vendor=Debian and Ubuntu

test files work.
Marked this bug as fixed.

Changed in openoffice.org (Ubuntu):
status: Confirmed → Fix Released
Changed in libreoffice:
importance: High → Wishlist

*** Bug 33860 has been marked as a duplicate of this bug. ***

NoOp, thank you for continuing to work on this bug and helping make Ubuntu better. Regarding your comments:

> I'm afraid that you've misunderstood; this is not a workaround.

As I have migrated over to LibreOffice personally and professionally (Fortune 500 company with current mass deployment of OOo, looking to migrate to LibreOffice), your marking this issue Fixed Released for OOo will not be challenged by me. I have added upstream OOo link for embedding enhancement as context only http://qa.openoffice.org/issues/show_bug.cgi?id=81753 for it's anticipated resolution has an impact on path dependent video quality playback.

> OOo has never "embeded" a video into the impress file...

Agreed.

> ...(with the possible exception of https://bugs.launchpad.net/bugs/660807 - which is an anomaly and different issue - not a duplicate) and has always been the case.

I found the path dependence issues of bug 660807, and anticipated resolution, highly related but if you insist that it's not a duplicate I will not re-dup it to this bug, no big deal.

> The tests that I performed were not 'workarounds' but instead demontrating that this issue is invalid/fixed.

Regarding OOo, agreed.

> If you wish to have video files "embeded" into an .odp, then please file a wishlist bug requesting that 'enhancement'. Please also be sure to file the bug under the proper package (OOo or LO).

Again, this bug is exactly that. That is the beauty of Launchpad.

> Further, if you are going to throw libreoffice into the mix (this bug was/is filed under openoffice.org) please do so at: https://bugs.launchpad.net/ubuntu/+source/libreoffice, or with the PPA maintainers where you obtained your LO packages. Please do not intermix OOo bugs with LO bugs - they are not the same.

Viewing OOo & LibreOffice as drastically different is myopic and not constructive as the source for both are 90%+ similar. As well, not finding where the two communities can work together on the same problem(s) is wasteful. In the future, should the code bases drastically diverge then this argument holds water.

Thank you for your continued understanding and effort.

Not only a Presentation problem, please see Bug 33156!

Changed in libreoffice:
status: Confirmed → Unknown
cement_head (andorjkiss) wrote :

This bug is NOT fixed - at all.

Using LO 3.3 final on Lucid from the PPA. The "update links" is greyed out for newly created impress files. Files created with OO 3.2 and OO 3.1 can have links updated.

- CH

affects: libreoffice → df-libreoffice
Victor Vargas (kamus) on 2011-02-22
Changed in libreoffice (Ubuntu):
importance: Undecided → Wishlist
Changed in libreoffice (Ubuntu):
status: Confirmed → Triaged
Victor Vargas (kamus) on 2011-02-22
Changed in openoffice.org (Ubuntu):
importance: Undecided → Wishlist
Changed in df-libreoffice:
status: Unknown → Invalid

Updating LO upstream bug link.

Changed in df-libreoffice:
importance: Wishlist → Unknown
status: Invalid → Unknown
Changed in df-libreoffice:
importance: Unknown → Wishlist
status: Unknown → Confirmed

Marking back to Confirmed as NoOp was mistaken in marking this Fix Released. This issue is still open upstream.

Changed in openoffice.org (Ubuntu):
status: Fix Released → Confirmed

I found that video fails to work in presentation only if there's Cyrillic letters in the path to the video. In case when there are only Latin letters video is played normally.

summary: - Impress inserted video does not play
+ [Upstream] Impress inserted video does not play
Changed in openoffice.org (Ubuntu):
status: Confirmed → Won't Fix

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

This is:
- a clearcut upstream issue
- wishlist/feature request unlikely to be fixable with a simple patch
- wont be fixed in libreoffice packaging
Resolving as WONTFIX in libreoffice packaging. This does not mean the issue will not be cared about, but if it is cared about (even by Ubuntu/Canonical contributors), it is done upstream at LibreOffice.

Changed in libreoffice (Ubuntu):
status: Triaged → Won't Fix

Deleted "Easyhack" from summary.

Apologies for not having gotten around fixing this bug yet; unfortunately in future I'll have even less time at my disposal for this, so I'm freeing up ownership for other volunteers to take over.

adding LibreOffice developer list as CC to unresolved EasyHacks for better visibility.

see e.g. http://nabble.documentfoundation.org/minutes-of-ESC-call-td4076214.html for details

Please read this message in its entirety before responding.

Your bug was confirmed at least 1 year ago and has not had any activity on it for over a year. Your bug is still set to NEW which means that it is open and confirmed. It would be nice to have the bug confirmed on a newer version than the version reported in the original report to know that the bug is still present -- sometimes a bug is inadvertently fixed over time and just never closed.

If you have time please do the following:
1) Test to see if the bug is still present on a currently supported version of LibreOffice (preferably 4.2 or newer).
2) If it is present please leave a comment telling us what version of LibreOffice and your operating system.
3) If it is NOT present please set the bug to RESOLVED-WORKSFORME and leave a short comment telling us your version and Operating System

Please DO NOT
1) Update the version field
2) Reply via email (please reply directly on the bug tracker)
3) Set the bug to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing - http://www.libreoffice.org/get-help/mailing-lists/.

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material

It is still impossible to retrieve the filename and the path of a video inserted as a link.
It is less uncomfortable when the video is embedded but the problem is the same, once the video has been inserted you can't know where the file comes from.

Tested with the current master. Version: 4.4.0.0.alpha1+
Build ID: 3e2dfde73b46526b901c0c38b1e9b2a4872761ac

Best regards. JBF

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.