Ubuntu

[REGRESSION] Openoffice Italic doesn't work

Reported by gmlion on 2007-10-17
12
Affects Status Importance Assigned to Milestone
OpenOffice
Fix Released
Unknown
openoffice.org (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: openoffice.org-writer

The Italic button sometimes doesn't work, in random places of the document. Sadly, I can honly hope this is reproducible. Sometimes it doesn't turn on, other times it doesn't turn off (i had to CTRL+SPACE to turn it off). I'm running latest Gutsy (sadly, because it's an updated RC).

Clay Weber (claydoh) wrote :

I can confirm this, in Kubuntu Gutsy.

For me it seems random as well. This doesn't happen every time I open a new or existing document.
If I select italic text, it is fine, but on the same line I cannot turn it off, I have to go to a new line. It can occur both directions, that is turning italic text off or on does not change the text.

Using the keyboard shortcut (ctrl-i) , this also can happen as well

Clay Weber (claydoh) wrote :

To clarify:

Type some normal text. Then, either click the italic button (or ctrl-i) and type more text. Often, the text is not typed in italic as desired.

Mitch Golden (mgolden) wrote :

Can you tell us more about the configuration of your system? How did you install Gutsy - was it an upgrade? I am unable to duplicate this bug.

gmlion (gm-l) wrote :

Yes, it was updated since Beta 3 to the final release. Will try a fresh install soon, if no other confirmations arrive.

gmlion (gm-l) wrote :

I have it confirmed on a computer of a friend of mine, but I still don't know if it was a fresh install or an upgrade from a pre-release version. I will ask ASAP.

gmlion (gm-l) wrote :

Ok. New OpenOffice arrived but bug still present. And the installation of my friend was a *fresh* one

Todd Deshane (deshantm) wrote :

I can confirm that this exists on my fresh install of gusty on my i386 laptop.

I can't seem to find a pattern either. It will work fine for awhile, but as mentioned above after playing around with it. It either gets in a "stuck on" or "stuck off". Moving away from the line seems to also work to fix the problem

Changed in openoffice.org:
status: New → Confirmed
anachreon (anachreon-) wrote :

I can also confirm this bug on Kubuntu Gutsy. The problem did not exist before I upgraded from Feisty to Gutsy. Basically, italic and bold work by hitting ctrl+b or ctrl+i IF I have text selected. But if I want to type a word in italic or bold by either clicking the button or hitting the hotkey and THEN typing, they don't work. Similarly, if I have already typed a bold or italic word and want to turn off bold or italic formatting, I have to type bold or italic text, select it, and THEN click the formatting button or press the hotkey, I can't simply have the cursor after the formatted text and turn bold or italic off.

Clay Weber (claydoh) wrote :

it is a known bug in OOo 2.3, to be fixed in 2.3.1 due in December
http://qa.openoffice.org/issues/show_bug.cgi?id=81764

Christian Reis (kiko) on 2007-10-30
Changed in openoffice:
importance: Undecided → Unknown
status: New → Unknown
Changed in openoffice:
status: Unknown → Fix Released
Martin Božič (martin-bozic) wrote :

I'm having a problem with the Italic button in OpenOffice.org Writer. I can't turn it off after I write a word in italic, but I can write normally elsewhere.

I usually use the keyboard shortcut Ctrl+i, but for turning it off neither way works now. Bold and underline button work without problems.

Chris Cheney (ccheney) wrote :

I believe that this bug has been corrected in Ubuntu hardy openoffice.org 1:2.4.0~rc2-1ubuntu3 so I am marking it as Fix Released. If after upgrading you continue to have problems with this issue then feel free to reopen this bug.

Thanks,

Chris Cheney

Changed in openoffice.org:
status: Confirmed → Fix Released

Bug is back today. Italics works fine both ways with Times New Roman,
but not with Nimbus Roman No 9 L. It can't be closed using ctr+i or the
I button (or more correct K-button, since my language is Swedish, kursiv)
Regards
Hans O

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.