Openoffice splash screen includes Ubuntu logo

Bug #153132 reported by jeroenl on 2007-10-16
18
Affects Status Importance Assigned to Milestone
openoffice.org (Ubuntu)
Medium
Unassigned
Gutsy
Medium
Unassigned
Hardy
Medium
Unassigned

Bug Description

[gutsy] I updated openoffice today and the OOo splash screen is back to the ubuntu one, instead of the blue kubuntu one.

jeroenl (jeroenl) wrote :

This should be assigned to openoffice.org-kde, but that is not possible, it says:" 'openoffice.org-kde' is a binary package. This bug has been assigned to its source package 'openoffice.org' instead."

Jonathan Jesse (jjesse) wrote :

I can confirm this.... I ran my updates and also now ahve the brown Ubuntu splash instead of Kubuntu splash. Had blue yesterday, today I have brown... boo brown

Changed in openoffice.org:
status: New → Confirmed

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

 status confirmed

Any idea why this is happening?
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFHFBVZ7/o1b30rzoURAkheAKCPIe3tsaOPUuG1E+hdPnWdek9rLgCfdeiN
GAK69qXlSx3S2pFZc2OsC2I=
=93gg
-----END PGP SIGNATURE-----

The splash screens are found in:

/usr/lib/openoffice/program

There you will find the Kubuntu splash (intro.bmp) and the Ubuntu splash (openintro_ubuntu.bmp). The latter one is used.

So to fix it:

sudo cp /usr/lib/openoffice/program/intro.bmp /usr/lib/openoffice/program/openintro_ubuntu.bmp

Jonathan Riddell (jr) wrote :

There's no such thing as an Ubuntu splash and a Kubuntu splash, there's only 1 splash used for all variants. However the splash in gutsy includes an Ubuntu logo which goes against our "branding for derivatives" policy where we do not include logos so that people can derive from Ubuntu without having to change lots of artwork.

Kenneth Wimer (kwwii) wrote :

Here is a fixed version - sorry for the error. I simply exported the SVG without thinking/looking :-(

jeroenl (jeroenl) wrote :

@Riddel: I understand, but I thought Kubuntu uses the blue one and not the brown one.

Matthias Klose (doko) on 2007-10-17
Changed in openoffice.org:
status: Confirmed → Fix Committed
Matthias Klose (doko) on 2007-10-17
Changed in openoffice.org:
importance: Undecided → Medium
milestone: none → gutsy-updates
Chris Cheney (ccheney) on 2007-10-17
Changed in openoffice.org:
status: Fix Committed → In Progress
Chris Cheney (ccheney) on 2007-10-17
Changed in openoffice.org:
status: In Progress → Confirmed
Martin Pitt (pitti) wrote :

Accepted into gutsy-proposed, please test.

Changed in openoffice.org:
status: Confirmed → Fix Committed
Nikola M (nikolam) wrote :

Also, Xubuntu should use blue one.

I have just downloaded this in the GNOME version of Ubuntu. The splash is now blue, when in previous releases it was Brown to match the human theme. It contrasts badly.

I would also like to add that this is an enormous update to do something as petty as remove a logo. Can it be held a while until there are several fixes to be released?

Sanjaya Karunasena (sanjayak) wrote :

I did an update last night and the problem is still there in Kubuntu. The about box also has the same problem. There are the BMPs in my "/usr/lib/openoffice/program".

intro.bmp
openabout_ubuntu.bmp
openintro_ubuntu.bmp

intro.bmp is the right one. But it uses openintro_ubuntu.bmp.

jan37 (dotjan-msn) wrote :

Today i installed Ubuntu Gutsy OpenOffice Updates of 78 MB and now i have also a blue splashscreen while i use gnome.

Sam Liddicott (sam-liddicott) wrote :

I don't want the blue splashscreen under gnome.
Should I hold off on this update till it is fixed so I keep the brown one?

jeroenl (jeroenl) wrote :

Maybe because of this:

/usr/lib/openoffice/program/openintro_ubuntu.bmp: Just 24 bpp bitmaps are supported.

openintro_ubuntu.bmp is now the brown splashscreen and
intro.bmp is the blue splash screen.

jeroenl (jeroenl) wrote :

I changed /usr/lib/openoffice/program/openintro_ubuntu.bmp to a 24bpp bitmap (see attachment) and now the brown is used. Great for the Gnome/Ubuntu users, but still bad news for KDE/Kubuntu users :-(. So we still have to do:

sudo cp /usr/lib/openoffice/program/intro.bmp /usr/lib/openoffice/program/openintro_ubuntu.bmp

To use the attachment, copy it (as root) to /usr/lib/openoffice/program/

Sanjaya Karunasena (sanjayak) wrote :

What is the workaround for Help->About? I am using KDE/Kubuntu.

Rafal Kwasny (mag) wrote :

Making users download 70MB update because of wrong splash screen is silly.
I think we must implement delta-deb's for such cases.

Vadim Peretokin (vperetokin) wrote :

Hi all,

I just got the update for this today, but I really don't want to install it - I like the ubuntu logo on it!

Is there any way I can "skip" this update? (sorry, this is a bit offtopic).

Juerd (ubuntu-juerd) wrote :

Can't the bitmap be generated post-install, with a generic logo in it? This technique could be used for all applications with splash screens, about screens, and other artwork. Some simple package could just have the logo in /etc/.../distro-logo.png, and imagemagick can be used to compose new images. Maybe a useful global feature for gutsy+1?

nowshining (nowshining) wrote :

 Vadim Peretokin

1. stop auto updates and uncheck it everytime

OR

2. lock the openoffice version in synaptic and all related files that depend on each other in the openoffice circle, etc.. doing it this way will hide it in the updates GUI manager Like I did :)

open up synaptic - input password - find the openoffice program - select it and or them and then at top click packages and then click lock.

Test completed successfully.

With openoffice.org-common version 1:2.3.0-1ubuntu5, the Ubuntu logo is visible in the OpenOffice splash.
After an update to openoffice.org-common version 1:2.3.0-1ubuntu5.1 the Ubuntu logo is no longer in the OpenOffice splash.

Henrik Nilsen Omma (henrik) wrote :

Thanks for fixing and testing. We'll hold off on adding this to updates for now though since it is a very large download for a minor change. If we need an OpenOffice update later this will be included.

Chris Cheney (ccheney) wrote :

I am attaching a debdiff for 1:2.3.0-1ubuntu5.2 that properly corrects the splash screen to the right bitmap format and fixes several other high visibility bugs.

Chris

Changed in openoffice.org:
status: Fix Committed → In Progress
Chris Cheney (ccheney) wrote :
Martin Pitt (pitti) wrote :

Thanks, Chris. The debdiff looks good mostly, except that due to the moving of libdba680lx.so you need to add a "Conflicts:/Replaces: openoffice.org-base (<< 1:2.3.0-1ubuntu5.2)" to -core.

Please also create gutsy tasks for all bugs that are fixed by this update, and add "TEST CASE:"s to their description, according to the current SRU policy (https://wiki.ubuntu.com/StableReleaseUpdates). Thanks a lot!

Chris Cheney (ccheney) wrote :

Martin,

The Conflicts line is already there and it seems to upgrade fine, does it really need the Replaces line? I know that in the past I have added both for KDE file moves in Debian but the lack of the 'Replaces' line didn't seem to make a difference in this case. I don't know the underlying reason why it just worked though.

I have added the 'TEST CASE' entries to each bug report.

Thanks!

Chris

Martin Pitt (pitti) on 2007-11-26
Changed in openoffice.org:
status: In Progress → Fix Committed
Chris Cheney (ccheney) wrote :

Martin,

I noticed a problem with the 1:2.3.0-1ubuntu5.2 upload while it was building on a few of the buildds. It appears that some of the libraries 'libdba680lx.so' for example encode architecture information into the soname for whatever reason upstream decided to do it for. So I had to loosen the mv call to libdba680l?.so so that it would catch all the versions of the library and will be uploading a 1:2.3.0-1ubuntu5.3 soon.

Thanks,

Chris

Chris Cheney (ccheney) wrote :
Martin Pitt (pitti) wrote :

Copied to gutsy-updates.

Changed in openoffice.org:
status: Fix Committed → Fix Released
assignee: nobody → ccheney
milestone: gutsy-updates → hardy-alpha-2
Steve Langasek (vorlon) on 2007-12-15
Changed in openoffice.org:
milestone: hardy-alpha-2 → none
Steve Langasek (vorlon) on 2007-12-15
Changed in openoffice.org:
milestone: none → ubuntu-8.04-beta
Chris Cheney (ccheney) on 2008-02-18
Changed in openoffice.org:
assignee: ccheney → nobody
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers