Ubuntu

Stream of JRE errors when going to "Macros" tab in frame properties

Reported by Mackenzie Morgan on 2007-10-05
20
This bug affects 1 person
Affects Status Importance Assigned to Milestone
openoffice.org (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: openoffice.org

1. Create a frame
2. Click on the "Macro" tab
3. JRE error comes up:

OpenOffice.org requires a Java runtime environment (JRE) to perform this task. The selected JRE is defective. Please select another version or install a new JRE and select it under Tools - Options - OpenOffice.org - Java

The error comes up more than once. It keeps popping up (at least 10 times), and you can't click elsewhere (for instance, to follow the directions)

I'm using Sun Java 1.6. Bazhang confirmed that he has this bug on IRC and checked with a SuSE user to see if it's a distro bug or upstream. The SuSE user does not have the bug, and is using Sun Java 1.5, so either it dislikes Sun 1.6 (which we didn't check on another distro) or it's from the Ubuntu build. This is with OpenOffice 2.3 on Gutsy.

Gert Kulyk (gkulyk) wrote :

I can not reproduce it with up-to-date gutsy. Can you please check which jre is selected in tools->option->java menu?

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

It is Sun Java 1.6. That was the first thing I checked. Do you have
Java 1.5, perhaps? It wasn't reproducable with Java 1.5 on SuSE.

Gert Kulyk wrote:
> I can not reproduce it with up-to-date gutsy. Can you please check which
> jre is selected in tools->option->java menu?
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFHBrRFojm3DbyNMmkRApMrAJ4uBUIRxHCC+4ZIwsgvpkI5Mgy1QQCghktU
l8H8yREx9k65Gmni1sx8o8g=
=ESH9
-----END PGP SIGNATURE-----

Gert Kulyk (gkulyk) wrote :

No, I'm using sun-java6-jre package from multiverse. I've tried it several times, still cannot reproduce this on gutsy.

Gert Kulyk (gkulyk) wrote :

I forgot to ask: are we talking about i386 or amd64 version? My comments are concerning the i386 version.

Mackenzie Morgan (maco.m) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

i386

Gert Kulyk wrote:
> I forgot to ask: are we talking about i386 or amd64 version? My comments
> are concerning the i386 version.
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFHB4l9ojm3DbyNMmkRAk5yAKCr6ARJY3JmJ5uKWFto95KyqT3C4QCgnwNA
s8rkH6EYeZxBGbhthuMF9tM=
=oAFM
-----END PGP SIGNATURE-----

Gert Kulyk (gkulyk) wrote :

Can you reproduce this on a clean account, too? Maybe some customization-settings are preventing proper use of the jre? But at least you seem not to be alone, according to Bug #150236, though I cannot reproduce the mentioned behavior of this report either.

Mackenzie Morgan (maco.m) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

I figured out what it is. I think it should still count as a bug,
though. If the radio button for the JRE (in options) is not activated,
the error comes up, but it doesn't if the JRE is explicitly clicked /
activated. Expected behaviour is that if there is only 1 JRE, that one
is activated by default (it is highlighted, but the radio button isn't
filled in, currently) instead of bringing up this error.

Gert Kulyk wrote:
> Can you reproduce this on a clean account, too? Maybe some
> customization-settings are preventing proper use of the jre? But at
> least you seem not to be alone, according to Bug #150236, though I
> cannot reproduce the mentioned behavior of this report either.
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFHCTiuojm3DbyNMmkRAosgAJ9JHwbfF1s13+LpxTLlcqLiJbWasQCff7Y/
e31qZdHreIJqtCgLvMOBGnY=
=B9Ue
-----END PGP SIGNATURE-----

Steven McCoy (fnjordy) wrote :

Various dialog boxes require 10+ closes when a JRE is not activated:

"OpenOffice.org requires a Java runtime environment (JRE) to perform
this task. However, user of a JRE has been disabled. Do you want to
enable the use of a JRE now?"

"For the selected Java runtime environment to work properly,
OpenOffice.org must be restarted. Please restart OpenOffice.org now."

and as above:

"OpenOffice.org requires a Java runtime environment (JRE) to perform this task. The selected JRE is defective. ..."

sun-java-6-jre 6-03-0ubuntu2
openoffice.org 1:2.3.0-1ubuntu5
Linux 2.6.22-14-generic i686

Arthur Penn (arthur-penn) wrote :

I had the 'JRE is defective' dialog when clicking on the Tables tab in OpenOffice.org Base. I have both the JRE 1.6 and JRE 1.5 installed. When I went to Tools | Options | Java, no JRE was selected, and none was visible in the selection area. I hit the browse button, went to /usr/bin, and hit enter; even though the Java libs are not here, it then displayed both the JRE 1.6 and 1.5 options in the selection area. I canceled the browse, and then selected the 1.6 runtime. This corrected my error.

Chris Cheney (ccheney) wrote :

I believe that this bug has been corrected in Ubuntu hardy openoffice.org 1:2.4.0~rc2-1ubuntu3 so I am marking it as Fix Released. If after upgrading you continue to have problems with this issue then feel free to reopen this bug.

Thanks,

Chris Cheney

Changed in openoffice.org:
status: New → Fix Released
Nicolas_Raoul (nicolas-raoul) wrote :

Reopening bug, as it is easily reproducible with the Ubuntu Hardy RC Live CD. See my comment.

Changed in openoffice.org:
status: Fix Released → New

How to reproduce :

- Run the Live CD of Ubuntu Hardy RC.
- In the examples folder, open oo-maxwell.odt
- Right-click a formula and click "edit".
- It says that the file is read-only and asks whether I want to edit a copy, click "ok".
- Right-click a formula and click "object".
- Click on the last tab, called "Macro".
- It says "OpenOffice.org requires a Java runtime environment (JRE) to perform this task. Please install a JRE and restart OpenOffice.org.".
- Click "ok". The same dialog reappears immediately.
- Click "ok" again. Reappears again.
- Repeat. Forever.

No way to get rid of it nicely, have to reboot (or kill OpenOffice for those who know how to).
100% reproducible.

My optional story:
As a science-oriented guy, when I ran the Live CD, the first thing that attracted me was the example "Maxwell" document. When I saw the nice formulas, I wanted to modify them. And so far I did not find how to do it, it is not obvious :-( Everybody in my case will right-click the formula, look for the right tab, and get stuck on this blocking bug. That is to say: many people will get this bug, please fix it quickly before Hardy release !

I did the upgrade from Gutsy to Hardy, last Saturday (2008/04/19) .

Since then, whenever I open any application from OpenOffice I get this message:

"OpenOffice.org requires a Java runtime environment (JRE) to perform this task. The selected JRE is defective. Please select another version or install a new JRE and select it under Tools - Options - OpenOffice.org - Java".

I then press the Ok button twice till OOo open. Went to:
 "Tools - Options - OpenOffice.org - Java"

And select the Java package that appeared there. And press the "Ok button".

Close OOo, and tried open it again.

But receive the same message:
"OpenOffice.org requires a Java runtime environment (JRE) to perform this task. The selected JRE is defective. Please select another version or install a new JRE and select it under Tools - Options - OpenOffice.org - Java".

After that I tried start OpenOffice as root trough the command line, so I can try to select Java, and then I get the following message in command line:
"javaldx failed!
[Java framework]sunjavaplugin.so could not load Java runtime library:
file:///usr/lib/jvm/java-6-sun-1.6.0.03/jre/lib/i386/client/libjvm.so.urban@urban-laptop:~$ [Java framework]sunjavaplugin.so could not load Java runtime library:
file:///usr/lib/jvm/java-6-sun-1.6.0.03/jre/lib/i386/client/libjvm.so.[Java framework]sunjavaplugin.so could not load Java runtime library:
file:///usr/lib/jvm/java-6-sun-1.6.0.03/jre/lib/i386/client/libjvm.so."

And the same message when OOo open:
"OpenOffice.org requires a Java runtime environment (JRE) to perform this task. The selected JRE is defective. Please select another version or install a new JRE and select it under Tools - Options - OpenOffice.org - Java".

Urban (urbanofreitas) wrote :

I did the upgrade from Gutsy to Hardy, last Saturday (2008/04/19) .

Since then, whenever I open any application from OpenOffice I get this message:

"OpenOffice.org requires a Java runtime environment (JRE) to perform this task. The selected JRE is defective. Please select another version or install a new JRE and select it under Tools - Options - OpenOffice.org - Java".

I then press the Ok button twice till OOo open. Went to:
 "Tools - Options - OpenOffice.org - Java"

And select the Java package that appeared there. And press the "Ok button".

Close OOo, and tried open it again.

But receive the same message:
"OpenOffice.org requires a Java runtime environment (JRE) to perform this task. The selected JRE is defective. Please select another version or install a new JRE and select it under Tools - Options - OpenOffice.org - Java".

After that I tried start OpenOffice as root trough the command line, so I can try to select Java, and then I get the following message in command line:
"javaldx failed!
[Java framework]sunjavaplugin.so could not load Java runtime library:
file:///usr/lib/jvm/java-6-sun-1.6.0.03/jre/lib/i386/client/libjvm.so.urban@urban-laptop:~$ [Java framework]sunjavaplugin.so could not load Java runtime library:
file:///usr/lib/jvm/java-6-sun-1.6.0.03/jre/lib/i386/client/libjvm.so.[Java framework]sunjavaplugin.so could not load Java runtime library:
file:///usr/lib/jvm/java-6-sun-1.6.0.03/jre/lib/i386/client/libjvm.so."

And the same message when OOo open:
"OpenOffice.org requires a Java runtime environment (JRE) to perform this task. The selected JRE is defective. Please select another version or install a new JRE and select it under Tools - Options - OpenOffice.org - Java".

Urban (urbanofreitas) wrote :

I did the upgrade from Gutsy to Hardy, last Saturday (2008/04/19) .

Since then, whenever I open any application from OpenOffice I get this message:

"OpenOffice.org requires a Java runtime environment (JRE) to perform this task. The selected JRE is defective. Please select another version or install a new JRE and select it under Tools - Options - OpenOffice.org - Java".

I then press the Ok button twice till OOo open. Went to:
 "Tools - Options - OpenOffice.org - Java"

And select the Java package that appeared there. And press the "Ok button".

Close OOo, and tried open it again.

But receive the same message:
"OpenOffice.org requires a Java runtime environment (JRE) to perform this task. The selected JRE is defective. Please select another version or install a new JRE and select it under Tools - Options - OpenOffice.org - Java".

After that I tried start OpenOffice as root trough the command line, so I can try to select Java, and then I get the following message in command line:
"javaldx failed!
[Java framework]sunjavaplugin.so could not load Java runtime library:
file:///usr/lib/jvm/java-6-sun-1.6.0.03/jre/lib/i386/client/libjvm.so.urban@urban-laptop:~$ [Java framework]sunjavaplugin.so could not load Java runtime library:
file:///usr/lib/jvm/java-6-sun-1.6.0.03/jre/lib/i386/client/libjvm.so.[Java framework]sunjavaplugin.so could not load Java runtime library:
file:///usr/lib/jvm/java-6-sun-1.6.0.03/jre/lib/i386/client/libjvm.so."

And the same message when OOo open:
"OpenOffice.org requires a Java runtime environment (JRE) to perform this task. The selected JRE is defective. Please select another version or install a new JRE and select it under Tools - Options - OpenOffice.org - Java".

Urban (urbanofreitas) wrote :

The problem is due to a extension that I was using in OOo, called: OpenOffice.org2GoogleDocs.

I already disabled it, and the pop window "JRE defective" disappeared.

So it's not a Ubuntu problem.

Chris Cheney (ccheney) wrote :

Does this problem go away if you install the openoffice.org-java-common package? The message that pops up should now also tell you to install that package if you don't have it installed already.

Chris

Changed in openoffice.org:
status: New → Incomplete
Urban (urbanofreitas) wrote :

I did try to install the package that you recomend- "openoffice.org-java-common".

It install a older version of Java compared to the package "java-common" package.

After that I tried to install again "java-common" package and I get a dependency error.

As said before, it was related with a extension that I was using in OOo, called "OpenOffice.org2GoogleDocs".
This extension requires Java to work.

When I disable it, the problem gone.

But thanks for the advice!
Urbano

Chris Cheney (ccheney) on 2008-04-26
Changed in openoffice.org:
status: Incomplete → Invalid
esdaniel (esdaniel) wrote :

As per Urban, I also had same issue and after disabling GDocs plugin the exception disappeared.

(+1 Urban)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers