OpenOffice calc crashes opening this ods file if openoffice.org-base not installed

Bug #134276 reported by Christian González
6
Affects Status Importance Assigned to Milestone
openoffice.org (Ubuntu)
High
Unassigned
Gutsy
Undecided
Unassigned

Bug Description

Binary package hint: openoffice.org

*NOTE* - Interesting bit about this thread is that it also affects oocalc.

--

I just include the link to the .doc file - it's a public file to download at

http://www.sws.or.at/vorl/FragebgZW.doc

if you want me to attach it here, tell me.

Openoffice crasshes each single time I try to to open it, it keeps trying to recover the last crash, but crashes again.

TEST CASE:

Open above file if it doesn't crash then the bug is corrected.

Revision history for this message
polopolo (linux-debaat) wrote :

Do you use ubuntu or kubuntu or xubuntu?
Do you have installed msttcorefonts or ubuntu-restricted-extras?

Changed in openoffice.org:
assignee: nobody → linux-debaat
status: New → Incomplete
Revision history for this message
Christian González (droetker) wrote :

Using Kubuntu, msttcorefonts installed, ubuntu-restricted-extras not.

Revision history for this message
exactt (giesbert) wrote :

opens fine on Ubuntu feisty amd64, msttcorefonts installed, ubuntu-restricted-extras not.

what version of Kubuntu/OOo are you running?

Revision history for this message
polopolo (linux-debaat) wrote :

Also works for me, installed ubuntu-restricted-extras. (wich includes msttcorefonts)

Revision history for this message
Christian González (droetker) wrote :

I Use Kubuntu Feisty. Strange.
I just opened it with OOO in Windows without problems.
I'll go on searching...

Revision history for this message
Christian González (droetker) wrote :

I just did a fresh Ubuntu feisty install, there it works without a problem.
Maybe it has to do with my configuration in KDE/JAVA/something else - just close the bug / mark as invalid.
Thanks for the fast response anyway.

Revision history for this message
polopolo (linux-debaat) wrote :

You're welcome, we hope when you have a bug, you can always report it to us.

I send this bug to the openoffice.org team, this can be interesting.

Changed in openoffice.org:
assignee: linux-debaat → openoffice-pkgs
Revision history for this message
Scott Kitterman (kitterman) wrote :

Confirmed to be a problem on Kubuntu Gutsy with or without msttcorefonts. Calc (Ubuntu OOO Maintainer) says it should not be forwarded upstream.

Changed in openoffice.org:
status: Incomplete → Confirmed
Revision history for this message
Chris Cheney (ccheney) wrote :

It doesn't crash for me with the IcedTea test debs I created and installed last night on my Ubuntu Gutsy (Gnome) system. I will test it further with the debs actually in Ubuntu to see if it may be an issue with compiling with gcj/gij.

Revision history for this message
Chris Cheney (ccheney) wrote :

I also can't reproduce the crash on Ubuntu Gutsy (Gnome) system using the official debs.

Revision history for this message
Sisyphe (verslenet-buntu) wrote :

Hi,

I have a similar problem with an ods file and oocalc.
This file that I attach was created using the openoffice package in Kubuntu Dapper and didn't have any problem.
Since I installed Feisty on the same machine (fresh installed, not an upgrade) I can't open my file anymore.

I contacted the french OpenOffice.org users list and the people responding were able to open my file but none of them were using the OpenOffice.org package provided by Feisty.

When browsing the launchpad to see if there was anything related, this bug report was the closest. So I downloaded the file from the link in the first message and I was unable to open it. I get into an endless loop of crashes and recovery attempts without success.

Just like with this attached ods file.

I am using the standard OpenOffice.org provided by Kubuntu 7.04, msttcorefonts is installed but not ubuntu-restricted-extras.

I insist on the fact that this does not happen with every file, I actually only witnessed it on this very one. I can't see anything special in it though.

Revision history for this message
Chris Cheney (ccheney) wrote :

Both files work fine for me on Ubuntu 7.10 (Gutsy) OpenOffice.org 1:2.3.0~rc1-1ubuntu2. Please try with the up to date version and let me know if it works for you.

Thanks,

Chris Cheney

Chris Cheney (ccheney)
Changed in openoffice.org:
assignee: openoffice-pkgs → ccheney
status: Confirmed → Incomplete
Revision history for this message
Christian González (droetker) wrote :

I tried with the Gutsy version - no problem for me any more.
Seems to be fixed, however.

Thynks,
Chris

Revision history for this message
Sisyphe (verslenet-buntu) wrote :

I installed Gutsy and the openoffice.org package I have is 1:2.3.0-1ubuntu2
Is it newer or older than 1:2.3.0~rc1-1ubuntu2 because with the package I have I still can't open document 'totaux_examens.ods' posted above.

Thanks anyway.

Revision history for this message
Chris Cheney (ccheney) wrote :

The quick solution to this problem is to just install openoffice.org meta package and/or the openoffice.org-base package. Something that writer/calc needs to display the documents is in the openoffice.org-base package. I intend to track down more of these related issue during UDS next week.

Thanks,

Chris Cheney

Changed in openoffice.org:
assignee: ccheney → nobody
importance: Undecided → High
status: Incomplete → Confirmed
description: updated
Revision history for this message
Sisyphe (verslenet-buntu) wrote :

That's it.
No problem anymore.
Thanks very much for your help.

PS (just in case it might help)
I never installed anything openoffice.org related in the past (I've been using Kubuntu since Dapper and Debian before) but always used nothing more that what was installed by default. That means that something that I used to create my file was present in the default install in the past and isn't anymore. Unfortunately, I cannot say for sure what version of Kubuntu I had when the file was created but I think it was Dapper. I never installed Edgy so I cannot say if the problem exists with that version but it appeared for me in Feisty.

Chris Cheney (ccheney)
Changed in openoffice.org:
milestone: none → gutsy-updates
Revision history for this message
Chris Cheney (ccheney) wrote :

The documents in these bug reports need the following library installed for the crash to stop happening:

/usr/lib/openoffice/program/libdba680li.so

Thanks,

Chris Cheney

Revision history for this message
Pablo Pita Leira (pitagora) wrote :

I was going to report the bug with an ods file of mine. Here, I am in Gutsy. By watching the thread, I found that openoffice.org-base was not installed, so that happens to fix it. Here is the output:

pleira@barebone:~/doc/projects$ oocalc invoices.ods

** (process:6050): WARNING **: Unknown error forking main binary / abnormal early exit ...
pleira@barebone:~/doc/projects$ apt-cache policy openoffice.org-base
openoffice.org-base:
  Instalados: (ninguno)
  Candidato: 1:2.3.0-1ubuntu5
  Tabla de versión:
     1:2.3.0-1ubuntu5 0
        500 http://es.archive.ubuntu.com gutsy/main Packages
pleira@barebone:~/doc/projects$ sudo apt-get install openoffice.org-base
[sudo] password for pleira:
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Se instalarán los siguientes paquetes extras:
  libhsqldb-java libservlet2.4-java
Paquetes sugeridos:
  libhsqldb-java-doc libhsqldb-java-gcj libservlet2.4-java-gcj unixodbc libmyodbc
  odbc-postgresql libsqliteodbc tdsodbc mdbtools libmysql-java libpg-java libsapdbc-java
  openoffice.org-gcj openoffice.org-report-builder
Se instalarán los siguientes paquetes NUEVOS:
  libhsqldb-java libservlet2.4-java openoffice.org-base
0 actualizados, 3 se instalarán, 0 para eliminar y 42 no actualizados.
Necesito descargar 4293kB de archivos.
Se utilizarán 11,6MB de espacio de disco adicional después de desempaquetar.
¿Desea continuar [S/n]?
Des:1 http://es.archive.ubuntu.com gutsy/main libservlet2.4-java 5.0.30-6ubuntu1 [143kB]
Des:2 http://es.archive.ubuntu.com gutsy/main libhsqldb-java 1.8.0.8-1ubuntu1 [949kB]
Des:3 http://es.archive.ubuntu.com gutsy/main openoffice.org-base 1:2.3.0-1ubuntu5 [3202kB]
Descargados 4293kB en 17s (248kB/s)
Seleccionando el paquete libservlet2.4-java previamente no seleccionado.
(Leyendo la base de datos ...
85097 ficheros y directorios instalados actualmente.)
Desempaquetando libservlet2.4-java (de .../libservlet2.4-java_5.0.30-6ubuntu1_all.deb) ...
Seleccionando el paquete libhsqldb-java previamente no seleccionado.
Desempaquetando libhsqldb-java (de .../libhsqldb-java_1.8.0.8-1ubuntu1_all.deb) ...
Seleccionando el paquete openoffice.org-base previamente no seleccionado.
Desempaquetando openoffice.org-base (de .../openoffice.org-base_1%3a2.3.0-1ubuntu5_i386.deb) ...
Configurando libservlet2.4-java (5.0.30-6ubuntu1) ...
Configurando libhsqldb-java (1.8.0.8-1ubuntu1) ...

Configurando openoffice.org-base (1:2.3.0-1ubuntu5) ...

pleira@barebone:~/doc/projects$ oocalc invoices.ods

The file opened now without crashing oocalc.

Chris Cheney (ccheney)
description: updated
Revision history for this message
Pelládi Gábor (pelladigabor) wrote :

This has been fixed in openoffice.org 2.3.0-1ubuntu5.3

Changed in openoffice.org:
status: Confirmed → Fix Released
Changed in openoffice.org:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers