[upstream] RTF: Vertical Cell merging in tables not imported correctly

Bug #132916 reported by Yuri Tsyganenko on 2007-08-16
8
Affects Status Importance Assigned to Milestone
libreoffice (Ubuntu)
Undecided
Unassigned
openoffice.org (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: openoffice.org

1) lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-proposed/main i386
Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

apt-cache policy unoconv
unoconv:
  Installed: 0.3-6
  Candidate: 0.3-6
  Version table:
 *** 0.3-6 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/universe i386 Packages
100 /var/lib/dpkg/status

apt-cache policy abiword
abiword:
  Installed: 2.8.6-0.3build1
  Candidate: 2.8.6-0.3build1
  Version table:
 *** 2.8.6-0.3build1 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/universe i386 Packages
100 /var/lib/dpkg/status

Version (from Help -About): openoffice.org 2.2.0-lubuntu4, Mon Jul 2 13:17:52 UTC 2007

3) What is expected to happen in LibreOffice Writer or AbiWord via the Terminal:

cd ~/Desktop && unoconv --listener && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/132916/+attachment/132337/+files/new_merged_cells.odt && unoconv -f rtf new_merged_cells.odt && lowriter -nologo new_merged_cells.rtf new_merged_cells.odt

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/132916/+attachment/132337/+files/new_merged_cells.odt && abiword --to=rtf --to-name=new_merged_cells.rtf new_merged_cells.odt && abiword new_merged_cells.rtf new_merged_cells.odt

the .rtf document looks the same as the .odt.

4) What happens instead is it does not.

Yuri Tsyganenko (tsyg) wrote :
Chris Cheney (ccheney) wrote :

Confirmed on upstream's openoffice.org 2.4.0~rc2. It saves to doc format properly but doesn't save to rtf right or doesn't display it right not sure which.

Changed in openoffice.org:
importance: Undecided → Low
status: New → Confirmed
Chris Cheney (ccheney) on 2008-03-18
Changed in openoffice:
importance: Undecided → Unknown
status: New → Unknown
Changed in openoffice:
status: Unknown → Confirmed
Chris Cheney (ccheney) on 2008-06-13
Changed in openoffice.org:
status: Confirmed → Triaged

Same behavior with
- 3.1.0 (Build: 9399) for Windows XP and
- 3.1.0 (Build: 9399) for Ubuntu 9.04

I'm very interested in a bugfix or workaround for this bug. I could also provide a help with the it.
I'm familiar with RTF-specification, Java and C++, but not OpenOffice (not yet).

Please, let me know, if I can speed up the fixing in some way.

Thanks.

Changed in openoffice:
status: Confirmed → Invalid
Chris Cheney (ccheney) on 2009-09-11
summary: - [Upstream] [hardy] Writer: Merging cells in a table in trouble when
- saved in RTF,or DOC format
+ [upstream] Writer: Merging cells in a table in trouble when saved in
+ RTF,or DOC format
Changed in openoffice:
status: Invalid → Unknown
Changed in openoffice:
status: Unknown → In Progress
summary: - [upstream] Writer: Merging cells in a table in trouble when saved in
- RTF,or DOC format
+ [upstream] RTF: Vertical Cell merging in tables not imported correctly
description: updated
tags: added: lo33
Changed in libreoffice (Ubuntu):
importance: Undecided → Medium
status: New → Triaged

Yuri Tsyganenko, thank you for reporting this bug and helping make Ubuntu better. If you also want the issue to be dealt with upon .doc conversion, please search for it, and if not found, file a separate Ubuntu and upstream bug.

Created attachment 46663
new_merged_cells.odt

Downstream bug may be found at:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/132916

OOo bug may be found at:
http://openoffice.org/bugzilla/show_bug.cgi?id=26964

1) lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-proposed/main i386
Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

apt-cache policy unoconv
unoconv:
  Installed: 0.3-6
  Candidate: 0.3-6
  Version table:
 *** 0.3-6 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/universe i386 Packages
100 /var/lib/dpkg/status

3) What is expected to happen in LibreOffice Writer via the Terminal:

cd ~/Desktop && unoconv --listener && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/132916/+attachment/132337/+files/new_merged_cells.odt && unoconv -f rtf new_merged_cells.odt && lowriter -nologo new_merged_cells.rtf new_merged_cells.odt

the .rtf document looks the same as the .odt.

4) What happens instead is it does not.

Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in openoffice.org (Ubuntu):
status: Triaged → Won't Fix

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

I confirm the problem with LO 3.5.0 beta-1 under Ubuntu 10.04 x86_64 (LibreOffice 3.5.0beta1+ Build ID: 6e7299d-7f15fca-8eae9f1-ca8e46d-5bcbce4)

Steps to reproduce:
1/ open the bugdoc
2/ save as RTF file and close the document
3/ reopen the RTF file

The table is broken.

Miklos: feel free to reassign if you can't handle this bug.

Best regards. JBF

This is an export problem, the created RTF doesn't contain the table cell strings, at all.

Hm, and seems to affect DOCX export as well, so probably a bug in MSWordExportBase.

So the major problem was that with the sample document only the first cell of the whole table was exported at all, this is now fixed with

http://cgit.freedesktop.org/libreoffice/core/commit/?id=83fbebfea32b27cd722466607aa978244ac53575

on master, also cherry-picked to -3-5:

http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-3-5&id=99fccadd08d41e8a4abcc062d075886d4a0910be

The export result should be now on par with the DOC export, though still not perfect. If you want that improved, please file a separate bug for the DOC exporter (on which the RTF export is based).

Changed in df-libreoffice:
status: Confirmed → Fix Released

Released with 3.5.0 in precise.

Changed in libreoffice (Ubuntu):
status: Triaged → Fix Released
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)

Tested in LO 3.5.1, LO 3.5.2 rc0+ and master : probable memory leak (up to 2 Go RAM allocated by LO and very, very, very (I am not patient enough to wait the end) long time to save the file in RTF format.
Reopening the bug.

Best regards. JBF

Changed in df-libreoffice:
status: Fix Released → Confirmed
Janne Jokitalo (astraljava) wrote :

I can confirm this for Abiword 2.8.6 on Xubuntu oneiric.

Changed in abiword (Ubuntu):
status: New → Confirmed

(In reply to comment #5)
> Tested in LO 3.5.1, LO 3.5.2 rc0+ and master : probable memory leak (up to 2 Go
> RAM allocated by LO and very, very, very (I am not patient enough to wait the
> end) long time to save the file in RTF format.
> Reopening the bug.
>
> Best regards. JBF

Or infinite loop ?
No problem when saving as MSWord97 format (unless merged cells are not merged anymore). Export as docx works but the result is incorrect (but that's probably another story).

Best regards. JBF

no longer affects: abiword (Ubuntu)

I just tried to reproduce this again, the file save takes about 1-2 seconds here, so closing again. Regarding correctness, please follow the advice in comment 4, that should not be handled here.

Thanks! :-)

Miklos Vajna, thank you for working on this. Unfortunately, the bug noted in the Description https://bugs.freedesktop.org/show_bug.cgi?id=37161#c0 is still not addressed:
lsb_release -rd
Description: Ubuntu Trusty Tahr (development branch)
Release: 14.04

apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:4.1.3-0ubuntu2
  Candidate: 1:4.1.3-0ubuntu2
  Version table:
 *** 1:4.1.3-0ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status

If you found the issue noted in the Description to be resolved, could you please post what version of LibreOffice this is fixed in, as well as a screenshot of both the .odt and .rtf proving this?

Thank you for your understanding.

I am closing this as FIXED once again
@Christopher - if you're seeing a similar problem please report a new bug.

Still reproducible in MASTER, and:
apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:4.2.6.3-0ubuntu1
  Candidate: 1:4.2.6.3-0ubuntu1
  Version table:
 *** 1:4.2.6.3-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu/ trusty-security/main amd64 Packages
        100 /var/lib/dpkg/status
     1:4.2.3~rc3-0ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages

Joel Madero, and anyone else who wants to toggle the bug report Status, let me be crystal clear here, I'm not going to file an additional, frivolous bug report as the original bug reported is still reproducible verbatim as per the Description -> https://bugs.freedesktop.org/show_bug.cgi?id=37161#c0 . Please review it in full so you understand the scope of this report.

With this in mind, this report never was, isn't now, and never will be RESOLVED FIXED until a commit for the bug noted in the Description is released, and in turn, verified by me, the original reporter. It is not fixed when a commit partially fixes, fixes something not related, or anything but fully fixes the issue as previously advised to you.

If your bug triage strategy is to close valid, and still reproducible LibreOffice bug reports when it is clearly not fixed, it would be best if you would cease toggling bug reports altogether.

Despite this, please do not toggle the status of this bug report further unless I have advised it's fixed.

Thank you for your understanding.

(In reply to Christopher M. Penalver from comment #10)

> Thank you for your understanding.

So !

When Miklos writes: " The export result should be now on par with the DOC export, though still not perfect. If you want that improved, please file a separate bug for the DOC exporter (on which the RTF export is based). " that explains the logic how this works.
This issue 37161 then should have a dependency on the new bug.

Please stop messing with the settings if you don't know what you're doing. This bug has to be confirmed by an INDEPENDENT QA TEAM MEMBER. Reopened has a specific meaning and this doesn't meet that. Don't change it again.

Created attachment 108903
deocument containing four screenshots, confirming the bug

Hi!

Managing bugs is important, but testing too!
I confirm and set to new

new..

Hi Miklos,

Since the export to doc is fine, I think currently the result in rtf does not depend on that? Docx-export is broken too, but different.

Pls see my export result with the previous comment.

What would be your advise?

thanks,
Cor

FYI: just to be sure, I tested the same document with an empty paragraph first, before the table.
Results the same.

no longer affects: df-libreoffice
affects: openoffice → df-libreoffice
Changed in df-libreoffice:
importance: Unknown → Undecided
status: In Progress → New
no longer affects: libreoffice (Ubuntu)
affects: df-libreoffice → libreoffice (Ubuntu)
Changed in libreoffice (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.