Changing to some icon themes in Ubuntu 7.04 causes button icons to disappear

Bug #129174 reported by Ryukenden on 2007-07-30
4
Affects Status Importance Assigned to Milestone
openoffice.org (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: openoffice.org

When i change the icon theme in Ubuntu 7.04 Feisty Fawn from Human to Crystal SVG or Tango, and then start OpenOffice.org, the menu icons disappear and are replaced by text buttons.

Amir Eldor (amireldor) wrote :

This is not a bug. These icon themes are uninstalled by default.
I've just installed the package "openoffice.org-style-crystal" and I can now choose the crystal theme and see proper icons.

Amir Eldor (amireldor) wrote :

I didn't get you right in the first place, but still, after I close and restart open office I have my crystal icon theme and not just plain text (instead of icons).

Amir Eldor (amireldor) wrote :

Thanks for the bug report, but it seems that we will need more information about re-creating the bug.
Does this bug repeat on your machine (when choosing an icon-theme, and closing/starting open office)?

I've installed the Tango theme for OpenOffice, and now it displays
correctly the toolbar buttons. But i think OpenOffice should default
to a theme when it doesn't have the same icon theme as the system is
using.

On 7/30/07, Amir Eldor <email address hidden> wrote:
> Thanks for the bug report, but it seems that we will need more information about re-creating the bug.
> Does this bug repeat on your machine (when choosing an icon-theme, and closing/starting open office)?
I don't know if this is still a bug since now i know what went wrong
and i am capable of fixing it. But still i've tried again because i
think OpenOffice should default to a icon theme when it can't use the
same theme as the system. I've tried with Crystal SVG (a theme which i
haven't yet installed for OpenOffice yet) and when i start OpenOffice
after changing the theme, the toolbars don't display icons, only text.
I send anexed to this e-mail a print screen of what happens.
>
> --
> Changing to some icon themes in Ubuntu 7.04 causes button icons to disappear
> https://bugs.launchpad.net/bugs/129174
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
WARNING:
Do not expose your friends e-mail addresses!
Use the "Bcc" (Blind carbon copy) field to send your electronic mail
and remove the addresses from the from the body of the message before
forwarding it.
These simple gestures prevent the spreading of viruses and that those
addresses be placed in Spam lists.

Greetings,
Gabriel

Get Firefox!
http://www.spreadfirefox.com/?q=affiliates&id=21044&t=1

Sergio Zanchetta (primes2h) wrote :

It has been fixed in a recent update for several icon theme, but not for tango one.
See https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/106186/comments/26

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers