OpenOffice writer crashes after Insert->Indices and Tables->Bibliography if openoffice.org-base not installed

Bug #117648 reported by Pedro Saraiva
32
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenOffice
In Progress
Unknown
openoffice.org (Debian)
Fix Released
Unknown
openoffice.org (Ubuntu)
High
Unassigned
Gutsy
Undecided
Unassigned

Bug Description

Binary package hint: openoffice.org

Start writer, go to Insert->Indices and Tables->Bibliography, writer will crash and document recovery popup.

Quickfix:

Install openoffice.org-base

Actual cause:

Needs the following library, which is in openoffice.org-base.

 /usr/lib/openoffice/program/libdba680lx.so

TEST CASE:

Follow above instructions if it doesn't crash then the bug is corrected.

Revision history for this message
Laur Mõtus (vprints) wrote :

Insert > Envelope Makes OOo crash
Insert > Indexes and Tables > Bibliography Entry Makes OOo crash

Confirmed.

Revision history for this message
Laur Mõtus (vprints) wrote :

Assigning to openoffice, change it if it should go to some other.

Changed in openoffice.org:
assignee: nobody → openoffice
status: Unconfirmed → Confirmed
Revision history for this message
Laur Mõtus (vprints) wrote :

Unassigning since openoffice seems to be username rather than a group in LP.

Changed in openoffice.org:
assignee: openoffice → nobody
Revision history for this message
towsonu2003 (towsonu2003) wrote :

importance high - severe impact on core application

Changed in openoffice.org:
importance: Undecided → High
Revision history for this message
Tomas (tomlich) wrote :

Confirmed
OOo also crashes this way when trying to install new dictionaries via File -> Wizards -> Install New Dictionaries.
This is on Kubuntu Fiesty.

Revision history for this message
elektropionir (brana7) wrote :

I think I fixed this on my install!

I had the same problem on a 64bit install of Feisty. Got very frustrated since I could not open at all some old documents with tables and entry fields - openoffice would crash immediately after opening. I also checked and could reproduce all crashes described above.

I installed the openoffice.org package (strangely this package was not installed) and reinstalled openoffice.org-base . I did this pretty hastily but I think this is the only thing I did. Some other java related packages got installed as dependencies. After this everything works. Hope this helps. It seems like a default packages selection problem.

Revision history for this message
Tomas (tomlich) wrote :

I can confirm that elektropionir's solution works. Obviously there are missing packages in the default fiesty installation. Just choose openoffice.org package for installation in adept and they will be installed as dependencies. So it seems it is not really a bug in openoffice. Perhaps we could mark this as resolved?

Revision history for this message
Tomas (tomlich) wrote :

problem solved - missing packages in default fiesty installation

Changed in openoffice.org:
status: Confirmed → Fix Released
Revision history for this message
Laur Mõtus (vprints) wrote :

Tomas, You changed the depencies in repo packages ?

Revision history for this message
Tomas (tomlich) wrote :

No, why do you ask? I do not think it is needed. If you open adept manager, you should notice that openoffice meta-package is not installed on your machine. Just select it and adept will automatically select all missing required packages as a dependency.
At least it worked for me and elektropionir, I believe.
Could you try it on your computer and post results?

Revision history for this message
elektropionir (brana7) wrote :

Tomas, I think it's probably a good idea to change the dependencies such that all necessary packages are always installed since this is very unusual behavior and it basically renders OpenOffice unusable out of the box for any non-trivial usage. For someone not very versed in Ubuntu this crash would seem like a major flaw in OpenOffice and I don't see why they would assume that even though the application is running there are missing packages that are causing it crash. I am working on a deadline right now and had to use old documents and was very frustrated that I had to debug this thing that rendered all my references and many documents that contained forms useless.

Revision history for this message
Tomas (tomlich) wrote :

elektropionir, I admit you are right, but unfortunately I am neither maintainer nor developer. But I think the developers would have to make this change directly on the installation ISOs to address this issue and I do not think they will do it. Anyway I probably changed the status of this bug prematurely, so I apologize for any confusion I may have caused and I am changing it back :)

Changed in openoffice.org:
status: Fix Released → Confirmed
Revision history for this message
Tomas (tomlich) wrote :

And I forgot to add that the change would have no effect on already downloaded ISOs.

Revision history for this message
Laur Mõtus (vprints) wrote :

Tomas, thankyou for changing that back, I somehow had that impression that the situation was how You later confirmed it.
No, there wouldn't be any effect just now for the isos, but the updates are updates, it can be just applied and if there is an update and the user dosen't apply it it's not Ubuntu teams fault ;)
And at some point the 7.04.1 should arrive I belive ?

Revision history for this message
elektropionir (brana7) wrote :

Tomas, no need to apologize, this is the first time I am submitting here so I didn't know what your status was or wether you could change anything in the repositories. Do you know who can make such changes?

Regarding what Laur said: couldn't there just be an update which would force the install of the openoffice.org package if someone has any of the other openoffice.org packages installed (I don't know anything about the internals of updates)? That would fix the problem. I think this is very important especially since more and more people are using Ubuntu and OpenOffice is probably one of the critical applications that people that don't have too much experience with Linux want to use. For an end user Feisty basically has a broken OpenOffice install (even though it is trivial to fix if you find these postings) which is not an impression that you want to give to first time users or people that have recently switched to Ubuntu. Also, an update would, in a sense, have an effect even on existing ISOs since after the install you get prompted for updates and this would immediately fix the problem for both new and existing installs.

Revision history for this message
Laur Mõtus (vprints) wrote :

Issue still here on Gutsy!

description: updated
Revision history for this message
Chris Cheney (ccheney) wrote : Re: [gutsy] Writer crashes, document recovery attempt, after Insert->Indices and Tables->Bibliography

It appears that openoffice.org-base has to be installed for the Bibliography to work. I am trying to narrow down which part of that package is responsible.

Revision history for this message
Chris Cheney (ccheney) wrote :

Missing the following libraries causes the issues:

for it to work at all
--
/usr/lib/openoffice/program/libdba680li.so ** breaks it

==

to show the database on the bibliography...
---
/usr/lib/openoffice/program/libdbaxml680li.so ** causes nothing to show
/usr/lib/openoffice/program/libdbpool2.so ** causes nothing to show
/usr/lib/openoffice/program/libsdbc2.so ** causes nothing to show

description: updated
Changed in openoffice.org:
status: Unknown → Confirmed
Changed in openoffice:
status: Unknown → In Progress
Changed in openoffice:
status: Unknown → In Progress
Revision history for this message
keyan (keyan-web) wrote :

Similar problem with Openoffice in Gutsy and inserting pictures.

After inserting a *.jpg or *.png openoffice freezes completly. After creating the text and inserting the picture with openoffice 2.3.0 under Windows (with no problems at all) and open this with ubuntu openoffice, it freezes after the first click at the picture. The problem exists under 64bit and 32bit ubuntu gutsy.

Revision history for this message
keyan (keyan-web) wrote :

Similar problem with openoffice in gutsy and inserting pictures.

After inserting a *.jpg or *.png openoffice freezes completly. After creating the text and inserting the picture with openoffice 2.3.0 under Windows (with no problems at all) and open this with ubuntu openoffice, it freezes after the first click at the picture. The problem exists under 64bit and 32bit ubuntu gutsy.

Revision history for this message
bladeofholyangel (shoferek) wrote :

sure, this is a big problem in ubuntu, xubuntu etc in gutsy. document can be viewed when deleting pictures, but it is not the best choice...

images can be renamed. just open in file-roller and rename pictures to pictures2. and then take it back... document works, but without images... and without crash...

Revision history for this message
bladeofholyangel (shoferek) wrote : Re: [Bug 117648] Re: OpenOffice writer crashes after Insert->Indices and Tables->Bibliography if openoffice.org-base not installed

Hello

openoffice.org-base is installed of course, but it is not working :(

is it working on your pc?

2007/10/20, Chris Cheney <email address hidden>:
> ** Summary changed:
>
> - [gutsy] Writer crashes, document recovery attempt, after Insert->Indices and Tables->Bibliography
> + OpenOffice writer crashes after Insert->Indices and Tables->Bibliography if openoffice.org-base not installed
>
> --
> OpenOffice writer crashes after Insert->Indices and Tables->Bibliography if openoffice.org-base not installed
> https://bugs.launchpad.net/bugs/117648
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
S pozdravom
Stanislav Hoferek

(ICQ 258126362)
(XMPP: <email address hidden>)

Revision history for this message
Chris Cheney (ccheney) wrote :

Yes on my machine the primary bug in this report is resolved when openoffice.org-base is installed but does not work when openoffice.org-base is removed.

However it appears that Keyan appended another unrelated bug report onto this bug report about Bibliography and Indices not working.

Chris

Revision history for this message
bladeofholyangel (shoferek) wrote :

yes, I know about that another bug (and I past a comment. My nick is
Bladeofholyangel).

Now I tried to remove this file and add it again. And I installed the
updates. But nothing new...

one good thing is, that the document can be opened by OOo, if OOo is
opened first and then by file/open

Stanislav

Chris Cheney (ccheney)
Changed in openoffice.org:
milestone: none → gutsy-updates
Revision history for this message
Simon Bridge (simonbridge) wrote : Re: OpenOffice writer crashes

I'm not sure if this should be a different bug but...

Open Office Writer is crashing on pretty much any none trivial activity. i.e.

Open a blank document
Type "Hello World"
Triple-click the line to highlight it
rt-click the line to bring up the dialog
select "character" (eg to change the color or add effects)

There is a pause of about 10 seconds, then the window becomes grey. Then nothing.
The controls are unresponsive - but the window can be forced to exit.

This is almost 100% reproducable exactly as above (exceptions below). Has been tested with a very wide range of functions as well as those mentioned above. i.e. - insert > picture > from file (select picture), the picture is inserted but the controls become unresponsive and the window turns grey. Same with format > character (in case anyone was wondering).

Windows turn grey when "thinking" or if another dialog requires attention. However, this situation is always temporary (or the other dialog can be found). To rule this out I have tried closing all other windows to make any otherwise unregarded dialog obvious and waiting 24 hours in case it's just thinking. To no effect.

From the above posts, I have checked installed packages... openoffice.org and openoffice.org-base are installed.

dpkg-reconfigure openoffice.org changed behavior in that a beep is now produced when I opt not to recover the previous document. No beep previously. Goodness knows what that tells you but it's odd.

dpkg-reconfigure openoffice.org-base changed behavior in that OOo-writer now loads like lightning!

Using synaptic to reinstall openoffice.org changed behavior in that a dialog popped up in the place of the hang announcing that "due to an unexpected error Open Office has crashed" - the document recovered, but a repeat of the steps just produced a hang as before.

Synaptic again to reinstall openoffice.org-base changed behavior in that the error message on first crash (re above) no longer appears.

Short of completely removing and reistalling OOo I don't know where to go from here.

The distribution is Ubuntu 7.10 - updates to time of writing have been applied.
Other - non-standard - modifications are:
build-essentials, bison, lex, and sdl libs have been installed
medibuntu repo has been installed as well as restricted multimedia and dvdcss
nvidia driver used

Revision history for this message
Chris Cheney (ccheney) wrote :

Simon,

Your issue may be due to the gtk theme issue, make sure you have your theme set to 'Human' and let me know if you still have the problem. If changing the theme corrects the issue I should have fix for that in the next week or two.

Thanks,

Chris Cheney

Revision history for this message
Simon Bridge (simonbridge) wrote : Re: [Bug 117648] Re: OpenOffice writer crashes after Insert->Indices and Tables->Bibliography if openoffice.org-base not installed

On Tue, 2007-10-30 at 14:52 +0000, Chris Cheney wrote:
> Simon,
>
> Your issue may be due to the gtk theme issue, make sure you have your
> theme set to 'Human' and let me know if you still have the problem.

OK - setting the theme to human stops the behaviour.
I figured it was samething to do with WM but couldn't figure what.
Thanks for the quick response.

> If
> changing the theme corrects the issue I should have fix for that in the
> next week or two.
>

Cool... I'll look forward to it.

> Thanks,
>
> Chris Cheney
>

Revision history for this message
Laur Mõtus (vprints) wrote :

AAND Kubuntu users ?

Revision history for this message
Chris Cheney (ccheney) wrote :

Laur,

For Kubuntu users installing openoffice.org-base should resolve the problem. The bug Simon reported appears to be unrelated. The underlying issue is that the /usr/lib/openoffice/program/libdba680li.so library needs to be on the system and that library will be moved to openoffice.org-core in the near future.

Thanks,

Chris Cheney

Chris Cheney (ccheney)
description: updated
Changed in openoffice.org:
status: Confirmed → Fix Released
Revision history for this message
Pelládi Gábor (pelladigabor) wrote :

This has been fixed in openoffice.org 2.3.0-1ubuntu5.3

Changed in openoffice.org:
status: Confirmed → Fix Released
Changed in openoffice.org:
status: New → Fix Released
Revision history for this message
Laur Mõtus (vprints) wrote :

It might be fix released for Hardy but is it really fix released for FEISTY and gutsy ?

Revision history for this message
Risto H. Kurppa (risto.kurppa) wrote :

Hardy w. openoffice 2.4

Bibliography tool doesn't work unless you manually install openoffice.org2-base.
If it isn't installed, it doesn't crash but the bibliography tool is somewhat disabled/empty.

I think that the user at least should be notified that base needs to be installed for this to work if not install base by default or when user opens the bibliography tool.

Revision history for this message
David D Lowe (flimm) wrote :

I experienced this bug in Lucid.

Revision history for this message
Russell Hedger (spambollox) wrote :

I too am experiencing this on Lucid. Have tried deleting the user profile and installing the openoffice.org metapackage from the standard repositories without success.

Revision history for this message
Russell Hedger (spambollox) wrote :

The only way I could fix this was to uninstall the ubuntu packages for OpenOffice and install the packages from the OpenOffice website - these appear to work fine.

Revision history for this message
soundpartner (michael-soundpartner) wrote :

it seems the fix here also is to install the openoffice.org pakkage. this should solve it without having to uninstall and install from website

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.