[feisty] Icons don't appear at all

Bug #108237 reported by Emiliano on 2007-04-20
4
Affects Status Importance Assigned to Milestone
openoffice.org (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: openoffice.org-base

When starting any openoffice application, icons in the menu bars don't appear. Is this a bug or not? That's strange because in the beta version they appeared, and in the final version all I got are the buttons only, even trying to modify the view options.

Emiliano,

Thanks for reporting this bug. To diagnose the problem properly the developers will need more information. Does the problem occur with all openoffice applications?

Could you try running openoffice from a terminal. Open a terminal and type 'ooffice -writer' (without the quotes). Then post the terminal output here. Do you see the same result doing this?

Could you also try doing the same thing as a different user. If you only have one user on the system create a new one. Log in as that user and then run the ooffice -writer command again. Post that output as well. Do you get the same result?

Your input is appreciated.
Richard

Changed in openoffice.org:
assignee: nobody → rbirnie
status: Unconfirmed → Needs Info
Emiliano (emiliano-perulli) wrote :

Well, I solved the problem.
At this point, I don't know if this bug affects the Feisty installer or this package.
However this problem occurs with all openoffice applications.
I ran 'ooffice -writer' from a terminal with my default login,the application started with no icons, but there was no output from the terminal.
Secondly, I created a new login, as you requested, and tried to run openoffice both from a terminal and from the menu, and it worked, the icons appeared.
So, I returned to my default login to check with synaptic if all was installed correctly, and the following default packages were not installed by the system (I installed feisty from a normal CD, no alternate install and not upgraded from edgy):
openoffice.org-style.-default
openoffice.org-style-crystal
openoffice.org-style-industrial
openoffice.org-style-hicontrast
I installed all style packages and now all works, I get the icons with all openoffice's applications.
The only package already installed was openoffice.org-style-human which didn't work, so I had to reinstall it.
The other style packages work except the openoffice.org-style-tango which is installed but unselectable from the view options.
That's all.
I hope this will be helpful to you.
Emiliano

Thanks Emiliano that's very helpful.

I was unable to replicate the problem on a clean upgrade of feisty but I use Kubuntu so I have KDE rather than gnome. The only openoffice.org-style packages I have installed are andromeda, crystal and default. It does sound as if the problem was caused by a missing style package. My guess would be crystal or human but why those packages were not installed/usable I have no idea. I'll leave this bug as 'Needs info' for now until we see if someone can confirm it on an Edgy->feisty upgrade with gnome. If you encounter anyone else with the same problem ask them to comment here and we can set this to confirmed

Richard

tim (tim-se-hicks) wrote :

I can confirm this.

New Feisty Fawn install, switched to using Tango icon theme in Theme Preferences, loaded OpenOffice (does this in every app), no toolbar icons. See attachment.

Installing package openoffice.org-style-tango fixed the problem for me. Maybe the style packages should be installed by default?

Changing status, bug confirmed by Tim

Changed in openoffice.org:
status: Needs Info → Confirmed
Changed in openoffice.org:
assignee: rbirnie → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers