Toolbars have text instaed of icons.

Bug #105823 reported by blekos on 2007-04-12
12
Affects Status Importance Assigned to Milestone
openoffice.org (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: openoffice.org

I am using Kubuntu Feisty Fawn and have 00 2.2 installed. I dont know what has changed but instead of having the relavent icons for eg. Bold, Italic, Align left etc. i have the whole word (the link below has a screenshot of my OO)
http://www.blekos.com/misc/oo.png

I've uninstalled and isntalled OO. Nothing happened. I've uninstalled, and removed any config files both from /root and /home/user/.openoffice etc. Installed again but no luck. I've check in the relevant position for the human_*.zip theme and it was there. I've run 00 both as a user and root (sudo openooffice -writer) but no change.

Also in my screen shot there is a big X at the top *left* corner. (Like the one of the X.org).
Moreover when you go to options->writing aids (or whatever option that has subcategories) there is no "+" sign to denote that there are subcategories etc. But if u double click on it, it works fine.

Need to mention that OO would take the colors i had set for my system and would be just grey. Problem solved when I installed a gtk lib.

I've spent almost my day 8hrs trying to figure out what's going on. I'd appreciate any help.

P.S apart from that visual thing, OO seems to work ok.
Also tried to change theme with no luck.

Matthias Klose (doko) wrote :

please go to Tools/Options/View and check for the current icon set selected; change it to Human (when running Gnome), or Crystal (when running KDE). The icons should reappear; as an alternative:

apt-cache -n search openoffice.org-style

and then install all style packages.

Changed in openoffice.org:
status: Unconfirmed → Needs Info
Sergio Zanchetta (primes2h) wrote :

I think this bug is related to bug #106186.
It's an inconsistency between icons theme in (K)Ubuntu and icons in OO.o

Mantas Kriaučiūnas (mantas) wrote :

I can confirm the bug - problem is, that installation of openoffice.org package doesn't automatically install openoffice.org-style package :(
I just tested this - I installed openoffice.org package (on Ubuntu Server with IceWM Window Manager installed) with Synaptic and now I have openoffice.org package installed, but on my system there are no openoffice.org-style package installed :(

Changed in openoffice.org:
status: Needs Info → Confirmed
levhita (levhita) wrote :

I see that his importance is still undecided, I would like to suggest that if possible, this packages should be "recommended" in the package tree when openoffice and tango, industrial, etc.. are installed, so they download automagically when installing openoffice or the iconsets(just a tough).

A notice given by openoffice pointing out that a given iconset must be installed would be good to avoid misunderstandings when someone try to fix it.

Sergio Zanchetta (primes2h) wrote :

This bug has been fixed. (Yesterday)
See https://bugs.launchpad.net/bugs/106186

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers