OpenOffice Writer freezes on paste of image from unknown SSL website

Bug #102186 reported by John Paulett on 2007-04-03
4
Affects Status Importance Assigned to Milestone
openoffice.org (Ubuntu)
Undecided
Brian Murray

Bug Description

Binary package hint: openoffice.org

openoffice 2.2.0-0ubuntu2
on Ubuntu Feisty beta (current apt-get upgrade/dist=upgrade) as of morning of the Apr 2, 2007.

When I try to paste an image (located on a website that has an SSL certificate from an 'unknown authority') from firefox into OpenOffice, Open Office freezes permentently. After several minutes of seeing OpenOffice greyed out, I force it to quit. I have reproduced this on my machine several times.

This is the page, from which I tried to copy (Ctrl+C) the person's photo by highlighting it and some text:
http://hmi.missouri.edu/ID_UserSQL.php?pass_ID=14

I then just pasted (Ctrl+V) into a blank OpenOffice Writer document. The text appeared, but the image was replaced by an icon, then the program froze.

I temporarily accepted the SSL cert in firefox.

I tried doing the same with several pictures
-the google logo from http://google.com, so it was not https:. which worked fine
-a screenshote from https://help.ubuntu.com/community/SeamlessVirtualization ... which had a valid SSL cert, which worked fine

Having no experience with the OO codebase, it seems like OO just does not handle SSL certs that are not officially signed.

Chris Burgan (cburgan) wrote :

I can confirm that trying to copy and paste those images from that site crashes it. However, going to a site like https://moodle.crosemont.qc.ca/login/index.php which also has an invalid certificate allowed me to copy and paste all the pictures without a problem. So I would assume that it is localized to that site. In messing around with other things, I can copy and paste fine from this site now. I had originally tried recreating the image with standard html and copying it to which it worked fine and now even when I am on the HTTPS part of the site it just shows the image as broken and doesn't open it. I can no longer cause it to freeze beyond my initial attempt.

Please let me know if you can copy the image from other page.

Changed in openoffice.org:
assignee: nobody → cburgan
status: Unconfirmed → Needs Info
John Paulett (johnpaulett) wrote :

I'm working on testing some different situations.

I tried out the crosemont site, and I agree that it works properly. However the images are actually hosted on a http server (i did a View Image in Firefox), so that is a difference in setup.

I ran OpenOffice from the terminal (ooffice -writer) . I tried another site: https://carnot.physics.buffalo.edu/ and when I tried to copy, I got the following error message:
** (soffice.bin:13097): WARNING **: Input Stream exceptional result 'Generic error' (2)
This site hosts the image on the https server, but it failed to freeze OO, it just displayed the error.

The missouri.edu site did not display the error message, but rather froze.

So far I can not determine what is unique about the missouri site.

John Paulett (johnpaulett) wrote :

Tried it on another site, https://mail.tln.lib.mi.us/webmail/ , which has an unknown certificate, but it actually pasted the image into OO.

The one thing that seems to be unique about the missouri site is that it is an http site with an image hosted on an https server. I think it may be difficult to find many sites that have the same setup, so I might try to set up something similar locally to try to figure what combination of events have to occur to make OO freeze.

Brian Murray (brian-murray) wrote :

I tried recreating your issue with the person's photo indicated in your description and using openoffice.org version 2.2.0-1ubuntu3. However, OpenOffice.org did not freeze on me and I just got a broken link for the picture. In your last post you mention you were trying to track down the issue. Have you had any luck? Thanks again.

Changed in openoffice.org:
assignee: cburgan → brian-murray
John Paulett (johnpaulett) wrote :

I tried testing it again recently, this time using 2.2.0-1ubuntu3, and I can not reproduce the issue. I did notice a lag and the broken image icon did appear in the image's place, but this is better than the freezing that I experienced earlier. Since I can not reproduce the issue, I am closing the bug.

John Paulett (johnpaulett) wrote :

Bug not reproducible in openoffice v. 2.2.0-1ubuntu3.

Changed in openoffice.org:
status: Needs Info → Rejected
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers