Add romanian translation to openoffice.org

Bug #261881 reported by Jani Monoses
6
Affects Status Importance Assigned to Milestone
openoffice.org (Debian)
Fix Released
Unknown
openoffice.org-l10n (Ubuntu)
Medium
Unassigned

Bug Description

This is the Romanian translation done outside of Launchpad by the Romanian OO team.
Dropping it into ooo-build/src over the existing less complete file should suffice

Revision history for this message
Jani Monoses (jani) wrote :
Changed in openoffice.org-l10n:
importance: Undecided → High
milestone: none → ubuntu-8.10-beta
Changed in openoffice.org-l10n:
status: New → Confirmed
Revision history for this message
Jani Monoses (jani) wrote :
Jani Monoses (jani)
Changed in openoffice.org-l10n:
milestone: ubuntu-8.10-beta → ubuntu-8.10
Revision history for this message
Chris Cheney (ccheney) wrote :

The file attached appears to be corrupted. Is this file newer than what is now currently in intrepid?

Thanks,

Chris Cheney

Changed in openoffice.org-l10n:
importance: High → Undecided
milestone: ubuntu-8.10 → none
status: Confirmed → Incomplete
Revision history for this message
Jani Monoses (jani) wrote :

Hi Chris,

in what way are they corrupted? Does the build fail with them?
I thave built OO from Hardy using the first attachment, and created the second using the same technique (uuencoded bz2)
somewhat later. Admittedly I have not tried an intrepid build, could it be that the process changed?
The current translations in intrepid are not up to date, the romanian team is not using LP for them.

thanks
Jani

Revision history for this message
Chris Cheney (ccheney) wrote :

Corrupt as in I can't uudecode the file:

ccheney@laptop-c2d:~/t$ ls
GSI_ro.sdf.bz2.uu
ccheney@laptop-c2d:~/t$ uudecode GSI_ro.sdf.bz2.uu
uudecode: GSI_ro.sdf.bz2.uu: Short file

Then I looked a bit further just now and it says this:

ccheney@laptop-c2d:~/t$ file GSI_ro.sdf.bz2.uu
GSI_ro.sdf.bz2.uu: bzip2 compressed data, block size = 900k

So it somehow automagically decoded it for me when I downloaded it with wget?

And then bunzip2 says this:

ccheney@laptop-c2d:~/t$ bunzip2 GSI_ro.sdf.bz2

bunzip2: Compressed file ends unexpectedly;
 perhaps it is corrupted? *Possible* reason follows.
bunzip2: No such file or directory
 Input file = GSI_ro.sdf.bz2, output file = GSI_ro.sdf

It is possible that the compressed file(s) have become corrupted.
You can use the -tvv option to test integrity of such files.

You can use the `bzip2recover' program to attempt to recover
data from undamaged sections of corrupted files.

bunzip2: Deleting output file GSI_ro.sdf, if it exists.

Revision history for this message
Chris Cheney (ccheney) wrote :

Apparently it did uudecode it when I ran the command even though it said it was a 'short file' and did not rename the file. But then that left the bzip2 file in a corrupted state.

When I downloaded the file again I verified that the file right after wget was in fact a uuencoded file so uudecode just didn't rename it, etc since it was corrupted.

Revision history for this message
Jani Monoses (jani) wrote :

Hi Chris,

I was also confused by uudecode's filename handling and it's interaction with bzip2

If I get this attachment via "save link as", I can create the text file from it using
uudecode -o /dev/stdout GSI_ro.sdf.bz2.uu | bunzip2 > anyname.txt

The oo build needs it in this bz2.uu format AFAIK, that's why I did not just attach the plain text file

thanks

Revision history for this message
Chris Cheney (ccheney) wrote :

Hmm, apparently extracting it that way works but doing it the normal two step process causes uudecode to think the file is corrupted.

Revision history for this message
Chris Cheney (ccheney) wrote :

Ah I found out why now, the file was somehow created incorrectly:

begin 644 GSI_ro.sdf.bz2.uu

it should have been something like:

begin 644 GSI_ro.sd.bz2

note no uu at the end. Which means it must be trying to overwrite the uuencoded file when you uudecode it which causes the error message and why it puts most of the bz2 file into the GSI_ro.sdf.bz2.uu file without renaming it.

Chris

Changed in openoffice.org-l10n:
status: Incomplete → Confirmed
Revision history for this message
Jani Monoses (jani) wrote :

when syncing again from debian experimental, please consider adding this to the scribblers PPA OO 3.0, in addition to intrepid-updates for OO 2.4

thanks

Revision history for this message
Jani Monoses (jani) wrote :

Today's translation snapshot for Romanian, has the uuencode header fixed as well. Please consider for the next intrepid and jaunty uploads as current translations are very incomplete. Thank you.

Revision history for this message
Jani Monoses (jani) wrote :

Chris, please consider this for Jaunty. The updated ro translations are neither in upstream yet, nor in LP - they use a different web translation tool. They're much better than what we currently have in Ubuntu. I keep rebuilding OO for this single change in the kiwilinux PPA but I'd rather have all Ubuntu-ro users have them by default

thanks

Revision history for this message
Chris Cheney (ccheney) wrote :

Jani,

Has this been submitted to Debian as well? I normally pick up the translations from them on every update, so if they have the update I will get it more or less automatically. Also submitting the translation to either the ftp.linux.cz site or official OpenOffice.org would be the best way to get more exposure for the translations.

Thanks,

Chris

Changed in openoffice.org-l10n:
status: Confirmed → Incomplete
Revision history for this message
Jani Monoses (jani) wrote :

Hi Chris,

no I have not submitted to Debian, the rationale being that our LP translations are also in addition to what Debian has.
The upstream translator (subscibed to the this bug report) does not want yet to submit to ftp.linux.cz . Our views on when a translation should be included probably differ on this one as I am firmly convinced Ubuntu users are much better off having the current not 100% validated translations than the ones that are in LP.

Jani

Revision history for this message
Jani Monoses (jani) wrote :

Another thing: if LP had an easy way to import te existing translations they would be picked up by the build and this would be a non-issue, but it does not AFAIK.

Revision history for this message
Alexandru Szasz (alexxed) wrote :

Hello,

I'm the Romanian lead for the OpenOffice.org Romanian project.
I'm using linux.cz, but I can't submit to the official repository until we have a more substantial check and testing on the translations. Because Windows and OS X users don't receive translations updates as Linux users do.

Revision history for this message
Adi Roiban (adiroiban) wrote :

Hi,

I am the coordinator or Romanian Ubuntu Localization team.

We try not to use Rosetta for translating OpenOffice but rather join the upstream translation effort.

The problems is that in Rosetta, OO.org translations are split in many small templates (about 100) and manualy updating is a pain: https://translations.edge.launchpad.net/ubuntu/jaunty/+source/openoffice.org

Now for one reason or another the upstream does not want to use those translations yet, but we should like to have them in Ubuntu, as the Romanian localization team thinks they are ready.

Many thanks,

Revision history for this message
Jani Monoses (jani) wrote :
Jani Monoses (jani)
Changed in openoffice.org-l10n (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Confirmed
Revision history for this message
Chris Cheney (ccheney) wrote :

I noticed that the translations already in Ubuntu OOo seem to be much more complete than what is attached here? Or is something else going on?

In the upload I am currently working on:
7121073 2009-01-06 08:57 GSI_ro.sdf

The update one in this bug report:
4642427 2009-03-24 03:58 GSI_ro.sdf

Changed in openoffice.org-l10n (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Jani Monoses (jani) wrote :

The recommended GSI file to take is the one from ftp.linux.cz, the one that has recently been added in Debian to the 3.1 branch.
thank you.

Revision history for this message
Adi Roiban (adiroiban) wrote :

The current OO.org translation from Jaunty has many problems that were fixed in GSI file from ftp.linux.cz

I don't know what is the initial source of those translations, but we prefer to use the upstream version.

Many thanks,
Adi

Revision history for this message
Chris Cheney (ccheney) wrote :

I believe that this is fixed as I took the current Romanian translation from ftp.linux.cz for 3.0.1 in the recent openoffice.org 1:3.0.1-9ubuntu1 upload.

Changed in openoffice.org-l10n (Ubuntu):
status: Incomplete → Fix Released
Changed in openoffice.org (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.