package openoffice.org-hyphenation-de 1:3.2.0-2ubuntu2 failed to install/upgrade: trying to overwrite '/usr/share/myspell/dicts/hyph_de_CH.dic', which is also in package openoffice.org-hyphenation 0:0.4

Bug #568514 reported by murmelhunter on 2010-04-22
114
This bug affects 22 people
Affects Status Importance Assigned to Milestone
openoffice.org-dictionaries (Ubuntu)
High
Unassigned
Lucid
High
Unassigned
openoffice.org-hyphenation (Ubuntu)
High
Chris Cheney
Lucid
High
Chris Cheney

Bug Description

by installation of todays update package openoffice.org-hyphenation-de, got error code 1 with info that the package is already installed during installation.

ProblemType: Package
DistroRelease: Ubuntu 10.04
Package: openoffice.org-hyphenation-de 1:3.2.0-2ubuntu2
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Thu Apr 22 18:08:06 2010
ErrorMessage: trying to overwrite '/usr/share/myspell/dicts/hyph_de_CH.dic', which is also in package openoffice.org-hyphenation 0:0.4
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta i386 (20100318)
PackageArchitecture: all
SourcePackage: openoffice.org-dictionaries
Title: package openoffice.org-hyphenation-de 1:3.2.0-2ubuntu2 failed to install/upgrade: trying to overwrite '/usr/share/myspell/dicts/hyph_de_CH.dic', which is also in package openoffice.org-hyphenation 0:0.4

murmelhunter (dirk-drehlich) wrote :
Chris Cheney (ccheney) on 2010-04-22
Changed in openoffice.org-dictionaries (Ubuntu):
assignee: nobody → Chris Cheney (ccheney)
importance: Undecided → High
milestone: none → ubuntu-10.04
status: New → Triaged

I can confirm (see duplicate bug).

Chris Cheney (ccheney) wrote :

I think I must be confused.

/usr/share/myspell/dicts/hyph_de_CH.dic

is in openoffice.org-hyphentation 0.4 but it is not in openoffice.org-hyphenation-de 3.2.0-2ubuntu2. I am not sure why it is claiming it is.

Chris Cheney (ccheney) wrote :

Ah it is actually a problem with openoffice.org-hyphenation-de 3.2.0-3ubuntu1 which I can't download at the moment for some reason.

Chris Cheney (ccheney) on 2010-04-22
affects: openoffice.org-dictionaries (Ubuntu) → openoffice.org-hyphenation (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openoffice.org-hyphenation - 0.5

---------------
openoffice.org-hyphenation (0.5) lucid; urgency=low

  * Removed de_CH since it is in its own package now. Closes LP: #568514
  * Updated copyright file.
 -- Chris Cheney <email address hidden> Thu, 22 Apr 2010 14:30:00 -0500

Changed in openoffice.org-hyphenation (Ubuntu):
status: Triaged → Fix Released
Linuxexperte (andrea-koeth) wrote :
Download full text (3.2 KiB)

Hi people,

now the same Bug appeares in the german hyphenation of openoffice.org.

Here the terminal-Output of the last current dist-upgrade:

andrea@andrea-desktop:~$ sudo apt-get dist-upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut
Status-Informationen einlesen... Fertig
Berechne Upgrade (Paketaktualisierung) ...Fertig
Die folgenden Pakete werden aktualisiert:
  fglrx-modaliases hdparm libgtk2-perl libparted0 libparted0debian1
  openoffice.org-hyphenation-de parted
7 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
55 nicht vollständig installiert oder entfernt.
Es müssen noch 1.858kB von 1.892kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 4.096B Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren [J/n]? J
Hole:1 http://archive.ubuntu.com/ubuntu/ lucid/main hdparm 9.15-1ubuntu9 [85,3kB]
Hole:2 http://archive.ubuntu.com/ubuntu/ lucid/main libparted0 2.2-5ubuntu5 [109kB]
Hole:3 http://archive.ubuntu.com/ubuntu/ lucid/main libparted0debian1 2.2-5ubuntu5 [335kB]
Hole:4 http://archive.ubuntu.com/ubuntu/ lucid/main parted 2.2-5ubuntu5 [153kB]
Hole:5 http://archive.ubuntu.com/ubuntu/ lucid/main libgtk2-perl 1:1.221-4ubuntu2 [1.162kB]
Hole:6 http://archive.ubuntu.com/ubuntu/ lucid/main fglrx-modaliases 2:8.723.1-0ubuntu3 [14,9kB]
Es wurden 1.858kB in 51s geholt (36,4kB/s)
(Lese Datenbank ... 362061 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereiten zum Ersetzen von hdparm 9.15-1ubuntu8 (durch .../hdparm_9.15-1ubuntu9_amd64.deb) ...
Entpacke Ersatz für hdparm ...
Vorbereiten zum Ersetzen von libparted0 2.2-5ubuntu4 (durch .../libparted0_2.2-5ubuntu5_amd64.deb) ...
Entpacke Ersatz für libparted0 ...
Vorbereiten zum Ersetzen von libparted0debian1 2.2-5ubuntu4 (durch .../libparted0debian1_2.2-5ubuntu5_amd64.deb) ...
Entpacke Ersatz für libparted0debian1 ...
Vorbereiten zum Ersetzen von parted 2.2-5ubuntu4 (durch .../parted_2.2-5ubuntu5_amd64.deb) ...
Entpacke Ersatz für parted ...
Vorbereiten zum Ersetzen von libgtk2-perl 1:1.221-4ubuntu1 (durch .../libgtk2-perl_1%3a1.221-4ubuntu2_amd64.deb) ...
Entpacke Ersatz für libgtk2-perl ...
Vorbereiten zum Ersetzen von openoffice.org-hyphenation-de 1:3.2.0-2ubuntu2 (durch .../openoffice.org-hyphenation-de_1%3a3.2.0-3ubuntu1_all.deb) ...
Entpacke Ersatz für openoffice.org-hyphenation-de ...
dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/openoffice.org-hyphenation-de_1%3a3.2.0-3ubuntu1_all.deb (--unpack):
Versuche, »/usr/share/myspell/dicts/hyph_de_CH.dic« zu überschreiben, welches auch in Paket openoffice.org-hyphenation 0:0.4 ist
Vorbereiten zum Ersetzen von fglrx-modaliases 2:8.723.1-0ubuntu2 (durch .../fglrx-modaliases_2%3a8.723.1-0ubuntu3_amd64.deb) ...
Entpacke Ersatz für fglrx-modaliases ...
Verarbeite Trigger für man-db ...
Fehler traten auf beim Bearbeiten von:
 /var/cache/apt/archives/openoffice.org-hyphenation-de_1%3a3.2.0-3ubuntu1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
andrea@andrea-desktop:~$

Perhaps the same thing which helped fpr the package above could help in this case?? I do...

Read more...

Chris Cheney (ccheney) wrote :

Yes the bug was that openoffice.org-hyphenation was still shipping the de_CH hyphen file, in the new 0.5 version it doesn't.

Steve Langasek (vorlon) wrote :

Dropping the file from openoffice.org-hyphenation is not sufficient (and if -hyphenation was still shipping it, we certainly should not have been adding it to -hyphenation-de at this late stage!) -hyphenation-de now needs a proper versioned Conflicts/Replaces against openoffice.org-hyphenation, for a smooth upgrade path from karmic.

Changed in openoffice.org-dictionaries (Ubuntu Lucid):
importance: Undecided → High
milestone: none → ubuntu-10.04
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openoffice.org-dictionaries - 1:3.2.0~rc2-3ubuntu2

---------------
openoffice.org-dictionaries (1:3.2.0~rc2-3ubuntu2) lucid; urgency=low

  * Add missing Conflicts/Replaces on the Ubuntu-only
    openoffice.org-hyphenation (<< 0.5). LP: #568514.
 -- Steve Langasek <email address hidden> Fri, 23 Apr 2010 09:44:38 +0000

Changed in openoffice.org-dictionaries (Ubuntu Lucid):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers