[SRU 10.04] South African English Dictionary still missing lots of words

Bug #467278 reported by dinger
68
This bug affects 5 people
Affects Status Importance Assigned to Milestone
openoffice.org-dictionaries (Debian)
Fix Released
Unknown
openoffice.org-dictionaries (Ubuntu)
Undecided
Unassigned
Nominated for Jaunty by Dwayne Bailey
Nominated for Karmic by Dwayne Bailey
Nominated for Maverick by Dwayne Bailey
Lucid
Undecided
Unassigned

Bug Description

The bug:
The south African English Dictionary is missing lots and lots of words. It's practically unusable. This problem is present in both OpenOffice and Evolution. For example the word "have" is in the dictionary, but the word "havin"g is reported as being a spelling error. The word "dad" is in the dictionary but "dad's" is reported as a spelling error.

A bug in the en_ZA dictionary was fixed in OOo upstream and worked-around in Debian at the same time. However the Debian work-around broke the OOo fix.

The fix:
Debian reverted this workaround in 1:3.2.0~rc2-5, and we have merged that into Maverick (1:3.2.0~rc2-5ubuntu1). Attached is a debdiff to fix this for lucid. (The old nominations for other releases can be ignored)

Impact:
This affects all English speaking South African desktop users. It will affect all applications that provide spellchecking. It's highly user-visible and can't be good for the image of OSS in ZA.
On the other hand, the South African english dictionary has been broken in OOo for a long time, so many ZA users have probably switched to en_GB or en_ZA years ago.

TEST CASE:
1. Run from a terminal: LANG=en_ZA.utf8 openoffice.org
2. Start a new text document.
3. Confirm that OOo is spellchecking in South African English, if not, tell it to.
4. Type a word
5. You should see tens of thousands of errors appearing in the console. This is a sign of the bug
6
. The following words should be considered to be correct by the spellechecker, but not all will be: have having dad dad's biltong braai bliksem

Regression potential:
Minimal. The changes only affect the myspell-en-za package, removing the symlink /usr/share/hunspell/en_ZA.aff and installing a real file.

Original report:
============
Binary package hint: yelp

Hi,

I have just installed Ubuntu Karmic 9.10 on x64 architecture.

I am not sure the exact package effected, but it's probably myspel-en-za 1:3.0.1-8ubuntu1

I reported this bug in Ubuntu Jaunty. The bug seems to have been propogated again in Karmic:
http://www.openoffice.org/issues/show_bug.cgi?id=100281

The south African English Dictionary is missing lots and lots of words. It's practically unusable. This problem is present in both OpenOffice and Evolution. For example the word "have" is in the dictionary, but the word "havin"g is reported as being a spelling error. The word "dad" is in the dictionary but "dad's" is reported as a spelling error.

Thanks for looking into this

Adam Baldinger

ProblemType: Bug
Architecture: amd64
Date: Sat Oct 31 21:19:26 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/yelp
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
NonfreeKernelModules: fglrx
Package: yelp 2.28.0-0ubuntu2
ProcEnviron:
 LANG=en_ZA.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: yelp
Uname: Linux 2.6.31-14-generic x86_64

Revision history for this message
dinger (baldinger) wrote :
Revision history for this message
Pedro Villavicencio (pedro) wrote :

re assigning.

affects: yelp (Ubuntu) → openoffice.org-dictionaries (Ubuntu)
Revision history for this message
Dwayne Bailey (dwayne-translate) wrote :

This patch fixes the en_ZA.aff file in older Ubuntu versions. I based this on an old CVS checkout from OOo and the latest affix files from http://extensions.services.openoffice.org/project/dict-en_ZA

Alternatively you could patch out both en_ZA.dic and en_ZA.aff with the files in the above extension.

Revision history for this message
PrivateUser132781 (privateuser132781-deactivatedaccount) wrote :

Thanks for submitting a patch, Dwayne. I notice, though that the bug is unassigned, which worries me somewhat. I've also nominated for release, given that it is now trivial to fix.

Revision history for this message
PrivateUser132781 (privateuser132781-deactivatedaccount) wrote :
Revision history for this message
Dwayne Bailey (dwayne-translate) wrote :

Anyone have suggestions on how we get progress on this bug? Upstream bug is closed, but the problem is still present on Ubuntu with Lucid.

Revision history for this message
Walter Leibbrandt (walterl) wrote :

I have just downloaded the source for this package (https://launchpad.net/ubuntu/+archive/primary/+files/openoffice.org-dictionaries_3.2.0~rc2.orig.tar.gz) and copied the contained en_ZA.aff to /usr/share/myspell/dicts, overwriting the one installed by myspell-en-za. That seems to fix the problem, as tested in OpenOffice. Does this indicate that, for some odd reason, the current source is not used in the packaged version of myspell-en-za?

This was done right after upgrading from Karmic to Lucid.

Revision history for this message
Chris Cheney (ccheney) wrote :

The linkage was done because of bug:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=536643

which was filed by Eduard Grebe who originally filed this Ubuntu bug:

https://launchpad.net/bugs/398320

which is apparently now a duplicate of this bug report.

The gist of the bugs is that before he said that the dictionary was broken and that linking in en_GB.aff in place of en_ZA.aff would fix it, now Walter is saying the fix is actually breaking the dictionary. If that was true then why didn't it work correctly originally before the supposed fix?

So what is supposed to actually fix this?

I think I can do a SRU to fix this if we can come up with a solution that actually works for everyone.

Revision history for this message
Dwayne Bailey (dwayne-translate) wrote : Re: [Bug 467278] Re: South African English Dictionary still missing lots of words

On Thu, 2010-05-06 at 18:36 +0000, Chris Cheney wrote:
> The linkage was done because of bug:
>
> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=536643
>
> which was filed by Eduard Grebe who originally filed this Ubuntu bug:
>
> https://launchpad.net/bugs/398320
>
> which is apparently now a duplicate of this bug report.
>
> The gist of the bugs is that before he said that the dictionary was
> broken and that linking in en_GB.aff in place of en_ZA.aff would fix it,
> now Walter is saying the fix is actually breaking the dictionary. If
> that was true then why didn't it work correctly originally before the
> supposed fix?
>
> So what is supposed to actually fix this?

Since the fix is upstream at OpenOffice.org, just using that code would
fix it... or

Using the dictionary from
http://extensions.services.openoffice.org/project/dict-en_ZA would also
fix this.

> I think I can do a SRU to fix this if we can come up with a solution
> that actually works for everyone.
>
> ** Bug watch added: Debian Bug tracker #536643
> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=536643
>

--
Dwayne Bailey
Associate Research Director +27 12 460 1095 (w)
Translate.org.za ANLoc +27 83 443 7114 (c)

Recent blog posts:
* Translate Toolkit - a powerful localisation toolkit
http://www.translate.org.za/blogs/dwayne/en/content/translate-toolkit-powerful-localisation-toolkit
* The sky's the limit for new Zulu spell checker
* Everyone has the power to champion their language

Firefox web browser in Afrikaans - http://af.www.mozilla.com/af/
African Network for Localisation (ANLoc) - http://africanlocalisation.net/

Revision history for this message
Stefano Rivera (stefanor) wrote : Re: South African English Dictionary still missing lots of words

I've sent a patch to the Debian maintainer: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=583795

With any luck he'll do a new upload soon, and we can see about doing some SRUs.

Changed in openoffice.org-dictionaries (Debian):
status: Unknown → New
Changed in openoffice.org-dictionaries (Debian):
status: New → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openoffice.org-dictionaries - 1:3.2.0~rc2-5ubuntu1

---------------
openoffice.org-dictionaries (1:3.2.0~rc2-5ubuntu1) maverick; urgency=low

  * Merge from debian unstable. (Closes LP: #587706) Remaining changes:
    - Add dependencies on language-support-writing-* packages.
      Closes LP: #537609
    - Fix the unversioned thunderbird entry in Conflicts for the hunspell-*
      packages.
    - define symlinks for the fr_FR dictionary too otherwise only the other
      variants are listed in GNOME dialogs
    - Refreshed: Add missing compat symlinks. Closes LP: #568760.
    - openoffice.org-thesaurus-en-us claims to provide en-gb but did not have
      a symlink. Closes LP: #578744
  * myspell-en-za fix in 1:3.2.0~rc2-5 closes LP: #467278.
 -- Chris Cheney <email address hidden> Sat, 05 Jun 2010 18:20:00 -0500

Changed in openoffice.org-dictionaries (Ubuntu):
status: New → Fix Released
Revision history for this message
Stefano Rivera (stefanor) wrote :
description: updated
summary: - South African English Dictionary still missing lots of words
+ [SRU 10.04] South African English Dictionary still missing lots of words
Revision history for this message
Benjamin Drung (bdrung) wrote :

uploaded to lucid

Changed in openoffice.org-dictionaries (Ubuntu Lucid):
status: New → Fix Committed
Revision history for this message
John Dong (jdong) wrote :

ACK from SRU team

Revision history for this message
Jonathan Riddell (jr) wrote : Please test proposed package

Accepted into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Revision history for this message
Stefano Rivera (stefanor) wrote :

SRU works for me

tags: added: verification-done
removed: verification-needed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openoffice.org-dictionaries - 1:3.2.0~rc2-3ubuntu3.1

---------------
openoffice.org-dictionaries (1:3.2.0~rc2-3ubuntu3.1) lucid-proposed; urgency=low

  * Undo broken South African English dictionary workaround in 1:3.1.0-4.
    Closes LP: #467278
 -- Stefano Rivera <email address hidden> Wed, 09 Jun 2010 22:08:51 +0200

Changed in openoffice.org-dictionaries (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.