Spellchecking doesn't work in Pidgin and Tomboy with LC_ALL=fr_CH.UTF8

Bug #278943 reported by Jonathan Ernst on 2008-10-06
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
openoffice.org-dictionaries (Debian)
Fix Released
Unknown
openoffice.org-dictionaries (Ubuntu)
Undecided
François Marier
Intrepid
Undecided
François Marier

Bug Description

In a freshly installed intrepid beta with full language support installed, Pidgin and Tomboy spellchecking doesn't work with my locale. It works if I force it into french (France). This is a regression as it used to work in hardy.

Jonathan Ernst (jonathan.ernst) wrote :

François you fixed the bug for OpenOffice https://launchpad.net/bugs/139570 (thanks for that) but there are still missing symlinks in /usr/share/myspell/dicts. ln -s fr_FR.aff fr_CH.aff and ln -s fr_FR.dic fr_CH.dic fixes this bug.

Changed in pidgin:
assignee: nobody → fmarier
François Marier (fmarier) wrote :

Hi Jonathan, can you send me the output of the following commands:

  dpkg -l myspell-fr

  ls -l /usr/share/myspell/dicts/

  dpkg -L myspell-fr

Cheers,
Francois

Jonathan Ernst (jonathan.ernst) wrote :
Download full text (4.7 KiB)

Hi,

1)
I don't have myspell-fr as it conflicts with default packages installed with language-support-fr (i.e. hunspell-fr
language-support-fr
language-support-writing-fr)

The myspell dictionnaries are bundled in hunspell-fr (from openoffice.org-dictionaries).

dpkg -l myspell-fr
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/H=à garder/besoin Réinstallation/X=les deux (État,Err: majuscule=mauvais)
||/ Nom Version Description
+++-==============-==============-============================================
un myspell-fr <néant> (aucune description n'est disponible)

2) Here is the list of myspell dictionnaries showing the missing fr_CH entries (and others as usual) :

ls -l /usr/share/myspell/dicts/
total 46748
-rw-r--r-- 1 root root 129761 2008-09-30 00:14 DicOOo.sxw
lrwxrwxrwx 1 root root 30 2008-10-07 07:58 dictionary.lst -> /etc/openoffice/dictionary.lst
-rw-r--r-- 1 root root 28518 2008-06-26 11:56 en_AU.aff
lrwxrwxrwx 1 root root 9 2008-10-04 15:35 en-AU.aff -> en_AU.aff
-rw-r--r-- 1 root root 557918 2008-06-26 11:56 en_AU.dic
lrwxrwxrwx 1 root root 9 2008-10-04 15:35 en-AU.dic -> en_AU.dic
-rw-r--r-- 1 root root 27828 2008-10-06 17:42 en_GB.aff
lrwxrwxrwx 1 root root 9 2008-10-07 07:51 en-GB.aff -> en_GB.aff
-rw-r--r-- 1 root root 527499 2008-10-06 17:42 en_GB.dic
lrwxrwxrwx 1 root root 9 2008-10-07 07:51 en-GB.dic -> en_GB.dic
-rw-r--r-- 1 root root 11352 2008-09-09 11:30 en_US.aff
lrwxrwxrwx 1 root root 9 2008-10-04 15:35 en-US.aff -> en_US.aff
-rw-r--r-- 1 root root 696228 2008-09-09 11:30 en_US.dic
lrwxrwxrwx 1 root root 9 2008-10-04 15:35 en-US.dic -> en_US.dic
-rw-r--r-- 1 root root 27519 2008-10-06 17:42 en_ZA.aff
-rw-r--r-- 1 root root 594430 2008-10-06 17:42 en_ZA.dic
-rw-r--r-- 1 root root 21297 2008-10-06 17:42 fr_FR.aff
-rw-r--r-- 1 root root 1129958 2008-10-06 17:42 fr_FR.dic
-rw-r--r-- 1 root root 20049 2008-04-08 16:00 hyph_cs_CZ.dic
-rw-r--r-- 1 root root 6049 2008-04-08 16:00 hyph_da_DK.dic
-rw-r--r-- 1 root root 42600 2008-04-08 16:00 hyph_de_CH.dic
-rw-r--r-- 1 root root 3205 2008-04-08 16:00 hyph_el_GR.dic
-rw-r--r-- 1 root root 79272 2008-04-08 16:00 hyph_en_CA.dic
-rw-r--r-- 1 root root 79272 2008-04-08 16:00 hyph_en_GB.dic
-rw-r--r-- 1 root root 93307 2008-07-02 03:53 hyph_en_US.dic
-rw-r--r-- 1 root root 4217 2008-04-08 16:00 hyph_es_ES.dic
-rw-r--r-- 1 root root 2072 2008-04-08 16:00 hyph_fi_FI.dic
-rw-r--r-- 1 root root 7979 2008-04-08 16:00 hyph_fr_BE.dic
-rw-r--r-- 1 root root 7979 2008-04-08 16:00 hyph_fr_FR.dic
-rw-r--r-- 1 root root 40226 2008-04-08 16:00 hyph_ga_IE.dic
-rw-r--r-- 1 root root 71039 2008-04-08 16:00 hyph_id_ID.dic
-rw-r--r-- 1 root root 28448 2008-04-08 16:00 hyph_is_IS.dic
-rw-r--r-- 1 root root 116507 2008-04-08 16:00 hyph_nl_NL.dic
-rw-r--r-- 1 root root 1288 2008-04-08 16:00 hyph_pt_BR.dic
-rw-r--r-- 1 root root 1288 2008-04-08 16:00 hyph_pt_PT.dic
-rw-r--r-- 1 root root 30805 2008-04-08 16:00 hyph...

Read more...

Jonathan Ernst (jonathan.ernst) wrote :

This affects tomboy as well, that's a shame.

http://www.ubuntu.com/community/ubuntustory/philosophy
"2. Every computer user should be able to use their software in the language of their choice."

I guess that's true, but I have to change country

description: updated
François Marier (fmarier) wrote :

Hi Jonathan,

I think that I may have found a way to get this to work. Can you test the openoffice.org-dictionaries_2.4.0~m240-2ubuntu4~ppa1 package from my PPA:

  deb http://ppa.launchpad.net/fmarier/ubuntu intrepid main

Cheers,
Francois

Jonathan Ernst (jonathan.ernst) wrote :

Hi François, thanks for getting back to this regression.

After installing your new packages I have new symlinks fr.aff -> fr_FR.aff and fr.dic -> fr_FR.dic but it still doesn't work. Maybe you could rename fr_FR.* into fr.* and then have symlinks from fr_CH.*, fr_FR.*, fr_LU.*, fr_CA.*, etc. to fr.* ?

François Marier (fmarier) wrote :

Thanks for the quick testing.

What happens if you create the symlinks manually, does it work then?

Francois

Jonathan Ernst (jonathan.ernst) wrote :

Yes it does.

François Marier (fmarier) wrote :

Ok, I have created a new version of the package in my PPA:

  openoffice.org-dictionaries_2.4.0~m240-2ubuntu4~ppa2

Can you confirm that it fixes this problem for you? Then I'll attach a debdiff to the bug report.

I'm not sure whether this problem can justify a freeze exception at this point, but I'm sure that it would qualify for a Stable Release Update at least.

François

Chris Cheney (ccheney) wrote :

François Marier,

Ask slangasek on IRC, I imagine he will allow a freeze exception if done fairly soon.

Thanks François, it fixes all those applications.

I sure hope the freeze exception will be granted as this makes spell checking quite crippled for every French speaker not living in France. This wouldn't be so bad if those applications weren't underlining every single word when no dictionary is found (I reported bugs for pidgin and tomboy about it).

Thanks again for your repeated efforts on those class of bugs.

One more question : do those (this one and #139570) bugs affect Debian (or even somewhere more upstream) too? If yes, do you plan to send your patches there to avoid fixing those packages again in six month (and improving other users' experience) ?

François Marier (fmarier) wrote :

Here is a debdiff between the current package in intrepid and the one in my PPA. The only change is to add a few symlinks from non-France French locales back to the fr_FR dictionary.

I don't believe that there is much potential to break any other dictionaries (or even the fr_FR one).

However, this fix is quite important because without it French speakers outside of France will not be able to use the spellchecker in programs like pidgin and tomboy.

I know that it is very late in the release schedule, but please consider giving this package a Freeze exception. Otherwise, it should be considered for the first Stable Release Update.

Francois

Changed in openoffice.org-dictionaries:
status: Unknown → New
Steve Langasek (vorlon) wrote :

This is fine for upload.

For straightforward bugfixes such as this (i.e., they don't require a freeze exception for features), it's preferable if you upload directly and let the release team review them in the package queue.

François Marier (fmarier) wrote :

Thanks for reviewing this Steve.

Do I actually have the required access to be able to upload to the package queue? I thought you have to be an Ubuntu member for that.

If I upload to intrepid directly using "dput ubuntu", my upload gets rejected:

  Rejected:
  Signer has no upload rights at all to this distribution.

Francois

Martin Pitt (pitti) wrote :

Sponsored with fixed version number and changelog bug reference. Thank you!

Changed in openoffice.org-dictionaries:
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openoffice.org-dictionaries - 1:2.4.0~m240-2ubuntu4

---------------
openoffice.org-dictionaries (1:2.4.0~m240-2ubuntu4) intrepid; urgency=low

  * Add BE, CA, CH and LU symlinks to the fr_FR myspell dictionary (LP: #278943)

 -- Francois Marier <email address hidden> Sat, 18 Oct 2008 12:44:16 +1300

Changed in openoffice.org-dictionaries:
status: Fix Committed → Fix Released
Changed in openoffice.org-dictionaries:
status: New → Fix Released

On Sun, Oct 19, 2008 at 07:31:18AM -0000, François Marier wrote:
> Thanks for reviewing this Steve.

> Do I actually have the required access to be able to upload to the
> package queue?

No - but Chris does, he could have uploaded for you or directed you to the
ubuntu-main-sponsors queue instead of to the release team :)

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.