Ubuntu

OpenOffice used to load but now segfaults - I don't know why

Reported by Frank Bob on 2005-04-15
4
Affects Status Importance Assigned to Milestone
openoffice.org-amd64 (Ubuntu)
Medium
Matthias Klose

Bug Description

Immediately after install of Hoary64, OpenOffice worked well.

Now it segfaults when I try to start it. I don't know which package I installed
might have caused this.
It is the same crash wether I use gnome or kde.

I saw elsewhere that fonts are a common problem but I think I ruled this out
using the steps here:
http://www.openoffice.org/FAQs/fontguide.html#6

Solution:
Downgrade openoffice.org-bin to Warty 1.1.2-2ubuntu6-1

Here is the error log. I don't think it is very helpful

Error log:

frank@Monster64:~$ openoffice

(process:13504): Gdk-WARNING **: locale not supported by Xlib

(process:13504): Gdk-WARNING **: can not set locale modifiers

(soffice.bin.real:13504): Gdk-WARNING **: Error converting from UTF-8 to STRING:
Conversion from character set 'UTF-8' to 'ISO-8859-1' is not supported

(soffice.bin.real:13504): Gdk-WARNING **: Error converting from UTF-8 to STRING:
Conversion from character set 'UTF-8' to 'ISO-8859-1' is not supported
Segmentation fault

Chris Jones (cmsj-bugz-ubu) wrote :

I too am seeing this on the amd64 hoary.

Matthias Klose (doko) wrote :

Closing this one, the current openoffice.org/openoffice.org2 packages in breezy
don't segfault anymore.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.