[FFe] Please provide OpenMPI 1.5 packages

Bug #889644 reported by Dave Walker on 2011-11-12
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
openmpi (Debian)
Fix Released
Unknown
openmpi (Ubuntu)
Wishlist
Robie Basak

Bug Description

Rationale for OpenMPI 1.5:
OpenMPI 1.5 includes upstream support for ARM architectures; this is of importance for future ARM server deployments supporting HPC clusters.

openmpi 1.5.4-2~exp2 is currently in Debian experimental and includes fixes for bugs identified during this evaluation process.

OpenMPI 1.5 is considered the beta/feature release by upstream; As the packaging of OpenMPI 1.4 for Ubuntu and Debian includes patches to enable ARM support AND its quite late in the release cycle to undertake a transition for ~60 packages a new openmpi1.5 package has been created and will be uploaded to universe.

This will allow users to preview the OpemMPI 1.5 release in Ubuntu precise without risking the proven function of the OpenMPI 1.4 and its dependencies in the Ubuntu archive.

Upstream Changelog:
See attached changelog.txt

Impact: New package which will Conflict with existing openmpi packages (transition not being undertaken this cycle).

Build log: openmpi1.5_1.5.4-0ubuntu1_amd64.build

Testing:
Straight install of new packages - see piuparts.log
Conflict check with existing openmpi-* packages and MPI_Hello test - see openmpi-conflict-check.log

>>> Original Bug Report <<<

1.4.3-2.1ubuntu1 is the current Ubuntu Precise version.

1.5 adds support for ARM server, and is therefore interesting.

As per:
https://blueprints.launchpad.net/ubuntu/+spec/servercloud-p-arm-openmpi

Dave Walker (davewalker) on 2011-11-12
Changed in openmpi (Ubuntu):
importance: Undecided → Wishlist
tags: added: upgrade-software-version
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in openmpi (Ubuntu):
status: New → Confirmed

@Sylvestre, Hey - I didn't understand your previous comment. Is this something you are currently working on?

Sylvestre Ledru (sylvestre) wrote :

Yes, Manuel Prinz from the Debian OpenMPI team is working on it.

Changed in openmpi (Debian):
status: Unknown → Fix Committed
Changed in openmpi (Debian):
status: Fix Committed → Fix Released
Robie Basak (racb) on 2012-01-17
Changed in openmpi (Ubuntu):
assignee: nobody → Robie Basak (racb)
James Page (james-page) wrote :

This upgrade is currently blocked by http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=658600 which is preventing testing of the transition required for this upgrade.

James Page (james-page) wrote :

A fix has been identified and tested for the issue we where seeing relating to http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=658600 - see also bug 932628.

Rebuild testing to evaluate whether this is a sensible thing todo.

James Page (james-page) wrote :

Rebuild testing looks OK - see
https://launchpad.net/~james-page/+archive/openmpi2/+packages and
https://launchpad.net/~james-page/+archive/openmpi/+packages

4 FTBFS - two are existing issues; one is new (mpi4py) and one build timed-out - this should be fixable.

summary: - Please update OpenMPI to the 1.5 upstream version
+ [FFe] Please update OpenMPI to the 1.5 upstream version
description: updated
description: updated
description: updated
James Page (james-page) on 2012-02-20
description: updated
James Page (james-page) on 2012-02-20
description: updated
James Page (james-page) on 2012-02-20
description: updated
description: updated
James Page (james-page) on 2012-02-21
description: updated
summary: - [FFe] Please update OpenMPI to the 1.5 upstream version
+ [FFe] Please provide OpenMPI 1.5 packages
James Page (james-page) wrote :
description: updated
James Page (james-page) wrote :
description: updated
James Page (james-page) wrote :
description: updated
James Page (james-page) wrote :

From #ubuntu-release:

<infinity> jamespage: Was rdeps testing a miserable failure, or was it just deemed too much work to validate?
<jamespage> infinity, not a miserable failure (most things rebuild OK) - I discussed with the Debian maintainer and we where both uncomfortable about the beta/feature status that upstream assign the 1.5.x branch being the default
<infinity> Mmkay, fair enough.
 Then yeah, dump it in NEW, and we'll find time to give it a once-over.

Robie Basak (racb) wrote :

openmpi1.5 (1.5.4-0ubuntu1) precise; urgency=low

  * Fork new openmpi1.5 package for co-existence with openmpi 1.4
    (LP: #889644).
  * Move required plugins from openmpi-checkpoint to libopenmpi1.5-2:
    - d/control: openmpi-checkpoint now depends on libopenmpi1-5-2
    - d/libopenmpi1.5-2.install*: switch to wildcard plugin install, drop
      specific install files for armel and armhf.
    - d/openmpi-checkpoint.install: Don't install any plugins.
 -- Robie Basak <email address hidden> Thu, 23 Feb 2012 10:42:19 +0000

Changed in openmpi (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.