Missing gridengine MCA ras

Bug #373456 reported by blucini on 2009-05-07
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
openmpi (Ubuntu)
Undecided
Unassigned

Bug Description

According to this FAQ

http://www.open-mpi.org/faq/?category=building#build-rte-sge

with version 1.3 the compatibility with gridengine is not built-in automatically, but must be requested, by passing the option --with-sge to the configure script. Given the modularity of openmpi, this should not be a problem. It can be achieved by changing the rules file:

COMMON_CONFIG_PARAMS = \
   $(CROSS) \
   --prefix=/usr \
   --mandir=\$${prefix}/share/man \
   --infodir=\$${prefix}/share/info \
   --sysconfdir=/etc/openmpi \
   --libdir=\$${prefix}/lib/openmpi/lib \
   --includedir=\$${prefix}/lib/openmpi/include \
   --with-devel-headers \
   --with-sge

(I added the last line).

This bug would allow the end user to build a gridengine + openmpi based cluster without recompiling openmpi.

Jeffrey Baker (jwbaker) on 2010-06-22
Changed in openmpi (Ubuntu):
status: New → Confirmed

Please fix this ASAP, as it is very annoying the rebuild openmpi and deploy it on every node on the cluster.

Vang Le (lqvang79) wrote :

After more than a year, current version of openmpi on Ubuntu Lucid is 1.4. I hope this bug is not forgotten.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers