[SRU] Linked against libpt-1.9, which is not in dapper

Bug #73722 reported by Pauli Virtanen on 2006-11-29
10
Affects Status Importance Assigned to Milestone
openmcu (Ubuntu)
Undecided
Unassigned
Dapper
Undecided
Luca Falavigna
Feisty
Undecided
Luca Falavigna

Bug Description

Openmcu in Dapper is linked against libpt-1.9, which is not in dapper, and not contained in libpt-dev package that openmcu depends on:

$ ldd /usr/bin/openmcu
        linux-gate.so.1 => (0xffffe000)
        libopenh323.so.1.17.3 => /usr/lib/libopenh323.so.1.17.3 (0xb7963000)
        libpt.so.1.9.2 => not found
        libldap_r.so.2 => /usr/lib/libldap_r.so.2 (0xb792f000)
        liblber.so.2 => /usr/lib/liblber.so.2 (0xb7923000)
        libpthread.so.0 => /lib/tls/i686/cmov/libpthread.so.0 (0xb7911000)
        libsasl2.so.2 => /usr/lib/libsasl2.so.2 (0xb78fc000)
        libssl.so.0.9.8 => /usr/lib/i686/cmov/libssl.so.0.9.8 (0xb78bf000)
        libcrypto.so.0.9.8 => /usr/lib/i686/cmov/libcrypto.so.0.9.8 (0xb7790000)
        libexpat.so.1 => /usr/lib/libexpat.so.1 (0xb7771000)
        libSDL-1.2.so.0 => /usr/lib/libSDL-1.2.so.0 (0xb76e9000)
        libresolv.so.2 => /lib/tls/i686/cmov/libresolv.so.2 (0xb76d6000)
        libdl.so.2 => /lib/tls/i686/cmov/libdl.so.2 (0xb76d2000)
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb75fd000)
        libm.so.6 => /lib/tls/i686/cmov/libm.so.6 (0xb75db000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb75d1000)
        libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0xb74a2000)
        libgsm.so.1 => /usr/lib/libgsm.so.1 (0xb7492000)
        libspeex.so.1 => /usr/lib/libspeex.so.1 (0xb7474000)
        libpt.so.1.9.2 => not found
        libcrypt.so.1 => /lib/tls/i686/cmov/libcrypt.so.1 (0xb7447000)
        libgnutls.so.12 => /usr/lib/libgnutls.so.12 (0xb73de000)
        /lib/ld-linux.so.2 (0xb7fb5000)
        libz.so.1 => /usr/lib/libz.so.1 (0xb73ca000)
        libasound.so.2 => /usr/lib/libasound.so.2 (0xb7314000)
        libX11.so.6 => /usr/lib/libX11.so.6 (0xb722e000)
        libXext.so.6 => /usr/lib/libXext.so.6 (0xb7221000)
        libtasn1.so.2 => /usr/lib/libtasn1.so.2 (0xb7211000)
        libgcrypt.so.11 => /usr/lib/libgcrypt.so.11 (0xb71c5000)
        libgpg-error.so.0 => /usr/lib/libgpg-error.so.0 (0xb71c0000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0xb71bd000)
        libnsl.so.1 => /lib/tls/i686/cmov/libnsl.so.1 (0xb71a8000)
$ dpkg --list|grep libpt
ii libpt-1.10.0 1.10.0-1ubuntu1 Portable Windows Library
ii libpt-dev 1.10.0-1ubuntu1 Portable Windows Library development files

This makes openmcu unusable in Dapper.

Changed in openmcu:
assignee: nobody → motu
status: Unconfirmed → Confirmed
Luca Falavigna (dktrkranz) wrote :

Confirmed in Dapper:
root@gandalf:/# ldd /usr/bin/openmcu | grep found
        libpt.so.1.9.2 => not found
        libpt.so.1.9.2 => not found
root@gandalf:/#

Confirmed in Feisty:
root@gandalf:/# ldd /usr/bin/openmcu | grep found
        libpt.so.1.10.0 => not found
root@gandalf:/#

Changed in openmcu:
assignee: motu → dktrkranz
Luca Falavigna (dktrkranz) wrote :

Debdiff for feisty-proposed.

Luca Falavigna (dktrkranz) wrote :

Debdiff for dapper-proposed.

Changed in openmcu:
assignee: dktrkranz → nobody
Changed in openmcu:
status: New → Triaged
status: New → Triaged
Changed in openmcu:
status: Confirmed → Invalid
assignee: nobody → kitterman
status: Triaged → In Progress
assignee: nobody → kitterman
status: Triaged → In Progress
Scott Kitterman (kitterman) wrote :

Uploaded waiting for archive admin to publish.

Changed in openmcu:
assignee: kitterman → dktrkranz
assignee: kitterman → dktrkranz
Martin Pitt (pitti) wrote :

Accepted into dapper-proposed, please test.

Changed in openmcu:
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

Accepted into feisty-proposed, please test.

Changed in openmcu:
status: In Progress → Fix Committed
Lord_neo (lord-neo) wrote :

Fix tested successfully on both Feisty and Dapper. Thanks Luca Falavigna!

Remo Quintino (remoquintino) wrote :

Works for me too on feisty and dapper.

Luca Falavigna (dktrkranz) wrote :

Seven days testing period elapsed and two persons confirmed the fix is good on each version.
Tagging with verification-motu-done as per https://wiki.ubuntu.com/MOTU/SRU.

Fabián Rodríguez (magicfab) wrote :

Sorry to crash the mood but I am still getting an error in Feisty.

openmcu: error while loading shared libraries: libpt.so.1.10.0: cannot open shared object file: No such file or directory

ldd /usr/bin/openmcu | grep found returns:
        libpt.so.1.10.0 => not found

However it's fixed in Gutsy.

Luca Falavigna (dktrkranz) wrote :

Fabián, could you please check if your version is 2.1.1-3build0.1 ?

Martin Pitt (pitti) wrote :

Copied to dapper-updates and feisty-updates.

Changed in openmcu:
status: Fix Committed → Fix Released
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers