openldap (slapd) installation fails

Bug #321689 reported by Jakub Nadulski on 2009-01-26
4
Affects Status Importance Assigned to Milestone
openldap2.3 (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Unassigned

Bug Description

Binary package hint: slapd

There is a version mismatch for libldap 2.4-2 and slapd (openLDAP) which prevents the latter to install via apt-get. Slapd seems to require libldap 2.4-2 (2.4.9 ubuntu 8.04.1) while 2.4-2 (2.4.9 ubuntu 8.04.2) is installed on the system.

The above happens on fresh installation of Ubuntu Server 8.04.2 (openSSH server selected during installation).

Andreas Olsson (andol) wrote :

I confirm this, also on a freshly installed and upgraded 8.04.2

To make sure this wasn't some kind of mirror-glitch I made sure that I switched to using http://archive.ubuntu.com.

root@pc13267v8:~# apt-get update
Hit http://security.ubuntu.com hardy-security Release.gpg
Hit http://archive.ubuntu.com hardy Release.gpg
Hit http://archive.ubuntu.com hardy-updates Release.gpg
Hit http://security.ubuntu.com hardy-security Release
Hit http://archive.ubuntu.com hardy Release
Hit http://archive.ubuntu.com hardy-updates Release
Hit http://security.ubuntu.com hardy-security/main Packages
Hit http://archive.ubuntu.com hardy/main Packages
Hit http://archive.ubuntu.com hardy/restricted Packages
Hit http://archive.ubuntu.com hardy/main Sources
Hit http://security.ubuntu.com hardy-security/restricted Packages
Hit http://security.ubuntu.com hardy-security/main Sources
Hit http://security.ubuntu.com hardy-security/restricted Sources
Hit http://archive.ubuntu.com hardy/restricted Sources
Hit http://archive.ubuntu.com hardy/universe Packages
Hit http://archive.ubuntu.com hardy/universe Sources
Hit http://archive.ubuntu.com hardy/multiverse Packages
Hit http://archive.ubuntu.com hardy/multiverse Sources
Hit http://security.ubuntu.com hardy-security/universe Packages
Hit http://security.ubuntu.com hardy-security/universe Sources
Hit http://security.ubuntu.com hardy-security/multiverse Packages
Hit http://security.ubuntu.com hardy-security/multiverse Sources
Hit http://archive.ubuntu.com hardy-updates/main Packages
Hit http://archive.ubuntu.com hardy-updates/restricted Packages
Hit http://archive.ubuntu.com hardy-updates/main Sources
Hit http://archive.ubuntu.com hardy-updates/restricted Sources
Hit http://archive.ubuntu.com hardy-updates/universe Packages
Hit http://archive.ubuntu.com hardy-updates/universe Sources
Hit http://archive.ubuntu.com hardy-updates/multiverse Packages
Hit http://archive.ubuntu.com hardy-updates/multiverse Sources
Reading package lists... Done
root@pc13267v8:~# apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@pc13267v8:~# apt-get install slapd
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  slapd: Depends: libldap-2.4-2 (= 2.4.9-0ubuntu0.8.04.1) but 2.4.9-0ubuntu0.8.04.2 is to be installed
E: Broken packages
root@pc13267v8:~#

Changed in openldap:
status: New → Confirmed

On Mon, Jan 26, 2009 at 11:53:47PM -0000, Andreas Olsson wrote:
> I confirm this, also on a freshly installed and upgraded 8.04.2
>
> The following packages have unmet dependencies:
> slapd: Depends: libldap-2.4-2 (= 2.4.9-0ubuntu0.8.04.1) but 2.4.9-0ubuntu0.8.04.2 is to be installed

2.4.9-0ubuntu0.8.04.2 only exists in hardy-proposed. Could you make sure
you're not running with -proposed enabled?

--
Mathias Gug
Ubuntu Developer http://www.ubuntu.com

Andreas Olsson (andol) wrote :

No -proposed enabled.

Besides switching from http://se.archive.ubuntu.com to http://archive.ubuntu.com I'm using exactly the same sources.list as I was given during the install.

Jakub Nadulski (cuban) wrote :

"-proposed" is not enabled. This is fresh installation problem - no changes to sources.list no apt-get update or apt-get upgrade.

Andreas Olsson (andol) wrote :

I believe I might have found the problem. It seems as if 2.4.9-0ubuntu0.8.04.2 was provided by the install CD.

andreas@pc13267v8:~$ apt-cache policy libldap-2.4-2
libldap-2.4-2:
  Installerad: 2.4.9-0ubuntu0.8.04.2
  Kandidat: 2.4.9-0ubuntu0.8.04.2
  Versionstabell:
 *** 2.4.9-0ubuntu0.8.04.2 0
        100 /var/lib/dpkg/status
     2.4.9-0ubuntu0.8.04.1 0
        500 http://archive.ubuntu.com hardy-updates/main Packages
        500 http://security.ubuntu.com hardy-security/main Packages
     2.4.7-6ubuntu3 0
        500 http://archive.ubuntu.com hardy/main Packages

If I manually remove libldap-2.4-2, and then reinstall it; this time from the repositories, I do get the correct version. After that it works just fine to install slapd.

Mathias Gug (mathiaz) wrote :

I can confirm that 2.4.9-0ubuntu0.8.04.2 is on the cd:

/pool/main/o/openldap2.3/libldap-2.4-2_2.4.9-0ubuntu0.8.04.2_amd64.deb

Changed in openldap2.3:
status: Confirmed → Invalid
status: New → Confirmed
Steve Langasek (vorlon) wrote :

Sorry for this, there was a terrible mix-up when rolling the 8.04.2 server media and some packages were included on the image that had not yet completed the SRU process.

The SRU for openldap2.3 has now been completed, so you should see slapd 2.4.9-0ubuntu0.8.04.2 available now in hardy-updates.

Changed in openldap2.3:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers